summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-pages/man-pages_5.03.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-11-20 14:44:46 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-25 17:57:23 +0000
commited5c98b9247c31c21ee422b71e27782abad91ec7 (patch)
tree0813eeff461b9ceef3b3406ba12ea42c12475448 /meta/recipes-extended/man-pages/man-pages_5.03.bb
parent6d5e13f65f99f829778591e4f38703ad2665bc4f (diff)
downloadpoky-ed5c98b9247c31c21ee422b71e27782abad91ec7.tar.gz
man-pages: update to 5.03
(From OE-Core rev: 73ea9a2a2bf04910cb397a3074dc21ab5144f29b) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/man-pages/man-pages_5.03.bb')
-rw-r--r--meta/recipes-extended/man-pages/man-pages_5.03.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-pages/man-pages_5.03.bb b/meta/recipes-extended/man-pages/man-pages_5.03.bb
new file mode 100644
index 0000000000..2381ba4348
--- /dev/null
+++ b/meta/recipes-extended/man-pages/man-pages_5.03.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Linux man-pages"
2DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs"
3SECTION = "console/utils"
4HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
5LICENSE = "GPLv2+"
6
7LIC_FILES_CHKSUM = "file://README;md5=794f701617cc03fe50c53257660d8ec4"
8SRC_URI = "${KERNELORG_MIRROR}/linux/docs/${BPN}/${BP}.tar.gz"
9
10SRC_URI[md5sum] = "d1da6babb99cbd269233a35de9d8718e"
11SRC_URI[sha256sum] = "e8bab0b10c6fb3a6d69615edb488f8a27020f3625c4cf43b8451ba206acbb1b8"
12
13inherit manpages
14
15MAN_PKG = "${PN}"
16
17PACKAGECONFIG ??= ""
18PACKAGECONFIG[manpages] = ""
19
20do_configure[noexec] = "1"
21do_compile[noexec] = "1"
22
23do_install() {
24 oe_runmake install DESTDIR=${D}
25}
26
27# Only deliveres man-pages so FILES_${PN} gets everything
28FILES_${PN}-doc = ""
29FILES_${PN} = "${mandir}/*"
30
31inherit update-alternatives
32
33ALTERNATIVE_PRIORITY = "100"
34ALTERNATIVE_${PN} = "passwd.5 getspnam.3 crypt.3"
35ALTERNATIVE_LINK_NAME[passwd.5] = "${mandir}/man5/passwd.5"
36ALTERNATIVE_LINK_NAME[getspnam.3] = "${mandir}/man3/getspnam.3"
37ALTERNATIVE_LINK_NAME[crypt.3] = "${mandir}/man3/crypt.3"