summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-pages/man-pages_4.11.bb
diff options
context:
space:
mode:
authorFan Xin <fan.xin@jp.fujitsu.com>2017-06-07 14:00:00 +0900
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-09 17:12:14 +0100
commitd4e974b0a69eafbe9e3ec221eaacc2808c271e74 (patch)
tree7c0078729f075f68558f9829d1b43ca942ecbc5a /meta/recipes-extended/man-pages/man-pages_4.11.bb
parentd5214ebaf7ba115cf5ceeffc274dbfe44518e63b (diff)
downloadpoky-d4e974b0a69eafbe9e3ec221eaacc2808c271e74.tar.gz
man-pages: Upgrade to 4.11
(From OE-Core rev: b4052ce99349dc3fc9fba87b831d19a2e7c4e90e) Signed-off-by: Fan Xin <fan.xin@jp.fujitsu.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/man-pages/man-pages_4.11.bb')
-rw-r--r--meta/recipes-extended/man-pages/man-pages_4.11.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-pages/man-pages_4.11.bb b/meta/recipes-extended/man-pages/man-pages_4.11.bb
new file mode 100644
index 0000000000..a3077a9fff
--- /dev/null
+++ b/meta/recipes-extended/man-pages/man-pages_4.11.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Linux man-pages"
2DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs"
3SECTION = "console/utils"
4HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
5LICENSE = "GPLv2+"
6
7LIC_FILES_CHKSUM = "file://README;md5=8f2a3d43057d458e5066714980567a60"
8SRC_URI = "${KERNELORG_MIRROR}/linux/docs/${BPN}/Archive/${BP}.tar.gz"
9
10SRC_URI[md5sum] = "408300ed09d1ad5938070158b21da1d1"
11SRC_URI[sha256sum] = "e6db91a24e68c7c765b7b8e60f1591ed1049bc2dc3143db779eae4838b89d195"
12
13RDEPENDS_${PN} = "man"
14
15do_configure[noexec] = "1"
16do_compile[noexec] = "1"
17
18do_install() {
19 oe_runmake install DESTDIR=${D}
20}
21
22# Only deliveres man-pages so FILES_${PN} gets everything
23FILES_${PN}-doc = ""
24FILES_${PN} = "${mandir}/*"
25
26inherit update-alternatives
27
28ALTERNATIVE_PRIORITY = "100"
29ALTERNATIVE_${PN} = "passwd.5 getspnam.3"
30ALTERNATIVE_LINK_NAME[passwd.5] = "${mandir}/man5/passwd.5"
31ALTERNATIVE_LINK_NAME[getspnam.3] = "${mandir}/man3/getspnam.3"