summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-pages/man-pages_4.04.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2016-01-11 08:30:37 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-15 11:54:49 +0000
commitac0e0d58ba6674881bb67a46338d482884c65b6c (patch)
tree5fa2723fd25f3fd436c2ac4b36d80371c94736a5 /meta/recipes-extended/man-pages/man-pages_4.04.bb
parent1e0cbb9321bc645715526685734b3aa7b003d3a9 (diff)
downloadpoky-ac0e0d58ba6674881bb67a46338d482884c65b6c.tar.gz
man-pages: 4.02 -> 4.04
(From OE-Core rev: 500d3d1dce0fcad25f418b02bf3557e1a283238d) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/man-pages/man-pages_4.04.bb')
-rw-r--r--meta/recipes-extended/man-pages/man-pages_4.04.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-pages/man-pages_4.04.bb b/meta/recipes-extended/man-pages/man-pages_4.04.bb
new file mode 100644
index 0000000000..65df0aad35
--- /dev/null
+++ b/meta/recipes-extended/man-pages/man-pages_4.04.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Linux man-pages"
2DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs"
3SECTION = "console/utils"
4HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
5LICENSE = "GPLv2+"
6
7LIC_FILES_CHKSUM = "file://README;md5=8f2a3d43057d458e5066714980567a60"
8SRC_URI = "${KERNELORG_MIRROR}/linux/docs/${BPN}/Archive/${BP}.tar.gz"
9
10SRC_URI[md5sum] = "901cd52e0ee2a9d7508ae1ab15d5e835"
11SRC_URI[sha256sum] = "bff072462baea8d1b8e4568759324c5ed6c760716fe830bca71129cc09e00668"
12
13RDEPENDS_${PN} = "man"
14
15do_configure[noexec] = "1"
16do_compile[noexec] = "1"
17
18do_install() {
19 oe_runmake install DESTDIR=${D}
20}
21
22# Only deliveres man-pages so FILES_${PN} gets everything
23FILES_${PN}-doc = ""
24FILES_${PN} = "${mandir}/*"
25
26inherit update-alternatives
27
28ALTERNATIVE_PRIORITY = "100"
29ALTERNATIVE_${PN} = "passwd.5 getspnam.3"
30ALTERNATIVE_LINK_NAME[passwd.5] = "${mandir}/man5/passwd.5"
31ALTERNATIVE_LINK_NAME[getspnam.3] = "${mandir}/man3/getspnam.3"