summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-pages/man-pages_4.02.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@enea.com>2015-08-20 13:11:27 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-24 23:47:01 +0100
commitbb00ebc24a6333852f3e531c4a1b85abe9d89ce3 (patch)
tree89159e4f686b6d5da9146438fc53ba83821f6956 /meta/recipes-extended/man-pages/man-pages_4.02.bb
parent37b73ce41e0fb5508e1dbf251e0f27c30399fe43 (diff)
downloadpoky-bb00ebc24a6333852f3e531c4a1b85abe9d89ce3.tar.gz
man-pages: update to 4.02
4.01 -> 4.02 (From OE-Core rev: b396c98e4379ef080ad7e90efe0d5fb21a3b046c) Signed-off-by: Maxin B. John <maxin.john@enea.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/man-pages/man-pages_4.02.bb')
-rw-r--r--meta/recipes-extended/man-pages/man-pages_4.02.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-pages/man-pages_4.02.bb b/meta/recipes-extended/man-pages/man-pages_4.02.bb
new file mode 100644
index 0000000000..1b90a44f99
--- /dev/null
+++ b/meta/recipes-extended/man-pages/man-pages_4.02.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Linux man-pages"
2DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs"
3SECTION = "console/utils"
4HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
5LICENSE = "GPLv2+"
6
7LIC_FILES_CHKSUM = "file://README;md5=8f2a3d43057d458e5066714980567a60"
8SRC_URI = "${KERNELORG_MIRROR}/linux/docs/${BPN}/Archive/${BP}.tar.gz"
9
10SRC_URI[md5sum] = "93df3279798a3345bb2c709584c83639"
11SRC_URI[sha256sum] = "42324f9ed47c89a43cb37b6bb0d5fbcad44838eee45cd394e181c98d038c49ff"
12
13RDEPENDS_${PN} = "man"
14
15do_configure[noexec] = "1"
16do_compile[noexec] = "1"
17
18do_install() {
19 oe_runmake install DESTDIR=${D}
20}
21
22# Only deliveres man-pages so FILES_${PN} gets everything
23FILES_${PN}-doc = ""
24FILES_${PN} = "${mandir}/*"
25
26inherit update-alternatives
27
28ALTERNATIVE_PRIORITY = "100"
29ALTERNATIVE_${PN} = "passwd.5 getspnam.3"
30ALTERNATIVE_LINK_NAME[passwd.5] = "${mandir}/man5/passwd.5"
31ALTERNATIVE_LINK_NAME[getspnam.3] = "${mandir}/man3/getspnam.3"