summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-pages/man-pages_3.76.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2015-01-09 19:36:24 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-23 11:36:30 +0000
commit36763782feba44279db01e2b225fa2a994e1b457 (patch)
tree36ab496af027f7ae6488a9cd299783b810684786 /meta/recipes-extended/man-pages/man-pages_3.76.bb
parentf733dad3c5a69db93d959b0bd7a32803efe89ddb (diff)
downloadpoky-36763782feba44279db01e2b225fa2a994e1b457.tar.gz
man-pages: upgrade to 3.76
(From OE-Core rev: b5c979b90c42c1ae0351138aedd5d0d61083257b) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/man-pages/man-pages_3.76.bb')
-rw-r--r--meta/recipes-extended/man-pages/man-pages_3.76.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-pages/man-pages_3.76.bb b/meta/recipes-extended/man-pages/man-pages_3.76.bb
new file mode 100644
index 0000000000..ed8a15f51d
--- /dev/null
+++ b/meta/recipes-extended/man-pages/man-pages_3.76.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Linux man-pages"
2DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs"
3SECTION = "console/utils"
4HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
5LICENSE = "GPLv2+"
6
7LIC_FILES_CHKSUM = "file://README;md5=8f2a3d43057d458e5066714980567a60"
8SRC_URI = "${KERNELORG_MIRROR}/linux/docs/${BPN}/Archive/${BP}.tar.gz"
9
10SRC_URI[md5sum] = "d00cf09677caefc3e827737afc565583"
11SRC_URI[sha256sum] = "eff558c13b61a46136994514b3ec00a74dcf00414d3bde4f0edca80a36d36359"
12
13RDEPENDS_${PN} = "man"
14
15do_configure () {
16 :
17}
18
19do_compile() {
20 :
21}
22
23do_install() {
24 oe_runmake install DESTDIR=${D}
25}
26
27# Only deliveres man-pages so FILES_${PN} gets everything
28FILES_${PN}-doc = ""
29FILES_${PN} = "${mandir}/*"
30
31inherit update-alternatives
32
33ALTERNATIVE_PRIORITY = "100"
34ALTERNATIVE_${PN} = "passwd.5 getspnam.3"
35ALTERNATIVE_LINK_NAME[passwd.5] = "${mandir}/man5/passwd.5"
36ALTERNATIVE_LINK_NAME[getspnam.3] = "${mandir}/man3/getspnam.3"