summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lzip/lzip_1.21.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-02-18 17:49:03 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-19 16:14:57 +0000
commit69a9ddc07c6187867dbcd2a984958bd61e978ada (patch)
tree1a10e64281d9427346a62bb1417dbc53447975b7 /meta/recipes-extended/lzip/lzip_1.21.bb
parentbb2d6cc85d558b2292a1a76d42c7cb1ff9713332 (diff)
downloadpoky-69a9ddc07c6187867dbcd2a984958bd61e978ada.tar.gz
lzip: upgrade 1.20 -> 1.21
(From OE-Core rev: c745d5bba0fecfc20b2ba0daea33a0d78230c06e) Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lzip/lzip_1.21.bb')
-rw-r--r--meta/recipes-extended/lzip/lzip_1.21.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-extended/lzip/lzip_1.21.bb b/meta/recipes-extended/lzip/lzip_1.21.bb
new file mode 100644
index 0000000000..bb3d2a6fe3
--- /dev/null
+++ b/meta/recipes-extended/lzip/lzip_1.21.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Lossless data compressor based on the LZMA algorithm"
2HOMEPAGE = "http://lzip.nongnu.org/lzip.html"
3SECTION = "console/utils"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=76d6e300ffd8fb9d18bd9b136a9bba13 \
6 file://decoder.cc;beginline=3;endline=16;md5=db09fe3f9573f94d0076f7f07959e6e1"
7
8SRC_URI = "${SAVANNAH_GNU_MIRROR}/lzip/lzip-${PV}.tar.gz"
9SRC_URI[md5sum] = "c0061730d017ea593a09308edc547128"
10SRC_URI[sha256sum] = "e48b5039d3164d670791f9c5dbaa832bf2df080cb1fbb4f33aa7b3300b670d8b"
11
12B = "${WORKDIR}/build"
13do_configure[cleandirs] = "${B}"
14
15CONFIGUREOPTS = "\
16 '--srcdir=${S}' \
17 '--prefix=${prefix}' \
18 '--exec-prefix=${exec_prefix}' \
19 '--bindir=${bindir}' \
20 '--datadir=${datadir}' \
21 '--infodir=${infodir}' \
22 '--sysconfdir=${sysconfdir}' \
23 'CXX=${CXX}' \
24 'CPPFLAGS=${CPPFLAGS}' \
25 'CXXFLAGS=${CXXFLAGS}' \
26 'LDFLAGS=${LDFLAGS}' \
27"
28
29do_configure () {
30 ${S}/configure ${CONFIGUREOPTS}
31}
32
33do_install () {
34 oe_runmake 'DESTDIR=${D}' install
35 # Info dir listing isn't interesting at this point so remove it if it exists.
36 if [ -e "${D}${infodir}/dir" ]; then
37 rm -f ${D}${infodir}/dir
38 fi
39}
40
41BBCLASSEXTEND = "native nativesdk"