summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lzip/lzip_1.20.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2018-03-19 21:11:08 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 13:28:01 +0100
commit1f7283fd0fb26fbaabd790f2439187f28dfe2371 (patch)
treef525d2c50f6a99894aa42ae4f7ab2616ba2b69d0 /meta/recipes-extended/lzip/lzip_1.20.bb
parentd845b9960b177cf094c4d1564e7a371aa5377c7e (diff)
downloadpoky-1f7283fd0fb26fbaabd790f2439187f28dfe2371.tar.gz
lzip: upgrade 1.19 -> 1.20
(From OE-Core rev: 64fea1fcd3bd5b63937874cd07498dee66ca3748) Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lzip/lzip_1.20.bb')
-rw-r--r--meta/recipes-extended/lzip/lzip_1.20.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-extended/lzip/lzip_1.20.bb b/meta/recipes-extended/lzip/lzip_1.20.bb
new file mode 100644
index 0000000000..d1fc2a1da8
--- /dev/null
+++ b/meta/recipes-extended/lzip/lzip_1.20.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Lossless data compressor based on the LZMA algorithm"
2HOMEPAGE = "http://lzip.nongnu.org/lzip.html"
3SECTION = "console/utils"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=76d6e300ffd8fb9d18bd9b136a9bba13 \
6 file://decoder.cc;beginline=3;endline=16;md5=db09fe3f9573f94d0076f7f07959e6e1"
7
8SRC_URI = "${SAVANNAH_GNU_MIRROR}/lzip/lzip-${PV}.tar.gz"
9
10SRC_URI[md5sum] = "21c1517da2ace9689fd953918660b3c3"
11SRC_URI[sha256sum] = "c93b81a5a7788ef5812423d311345ba5d3bd4f5ebf1f693911e3a13553c1290c"
12
13CONFIGUREOPTS = "\
14 '--srcdir=${S}' \
15 '--prefix=${prefix}' \
16 '--exec-prefix=${exec_prefix}' \
17 '--bindir=${bindir}' \
18 '--datadir=${datadir}' \
19 '--infodir=${infodir}' \
20 '--sysconfdir=${sysconfdir}' \
21 'CXX=${CXX}' \
22 'CPPFLAGS=${CPPFLAGS}' \
23 'CXXFLAGS=${CXXFLAGS}' \
24 'LDFLAGS=${LDFLAGS}' \
25"
26EXTRA_OEMAKE = ""
27
28B = "${S}/obj"
29do_configure () {
30 ${S}/configure ${CONFIGUREOPTS}
31}
32
33do_install () {
34 oe_runmake 'DESTDIR=${D}' install
35 # Info dir listing isn't interesting at this point so remove it if it exists.
36 if [ -e "${D}${infodir}/dir" ]; then
37 rm -f ${D}${infodir}/dir
38 fi
39}
40
41BBCLASSEXTEND = "native nativesdk"