summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp/ltp_20210524.bb
diff options
context:
space:
mode:
authorPetr Vorel <petr.vorel@gmail.com>2021-05-25 23:59:10 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-27 13:21:38 +0100
commit2f97ec19e09e3ef099927681deaf7041a884a935 (patch)
treea05b26f5f5058426fb6d616427fcb7da43892aad /meta/recipes-extended/ltp/ltp_20210524.bb
parent6aaaa066ce360da138bfd155b56585bdf814ebd1 (diff)
downloadpoky-2f97ec19e09e3ef099927681deaf7041a884a935.tar.gz
ltp: Update to 20210524
Remove patches accepted in this upstream release * determinism.patch (45530792a, 01fefa08c) * libswapon.patch (2b64c727f) * 0001-open_posix_testsuite-generate-makefiles.sh-Avoid-inc.patch (f38172209) * 0002-Makefile-Avoid-wildcard-determinism-issues.patch (edf60cf6a) * 0003-syscalls-swapon-swapoff-Move-common-library-to-libs.patch (ac140ed58) Removed (test rewritten to new API) * 0007-Fix-test_proc_kill-hanging.patch (From OE-Core rev: d36bd5a532d38c786b87ec15f0eec1d849487fa5) Signed-off-by: Petr Vorel <petr.vorel@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ltp/ltp_20210524.bb')
-rw-r--r--meta/recipes-extended/ltp/ltp_20210524.bb139
1 files changed, 139 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp_20210524.bb b/meta/recipes-extended/ltp/ltp_20210524.bb
new file mode 100644
index 0000000000..4328b1efee
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp_20210524.bb
@@ -0,0 +1,139 @@
1SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "https://linux-test-project.github.io/"
4SECTION = "console/utils"
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
9 file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \
10 file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
11 file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
12 file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \
13 file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
14 file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
15"
16
17DEPENDS = "attr libaio libcap acl openssl zip-native"
18DEPENDS_append_libc-musl = " fts "
19EXTRA_OEMAKE_append_libc-musl = " LIBC=musl "
20EXTRA_OECONF_append_libc-musl = " LIBS=-lfts "
21
22# since ltp contains x86-64 assembler which uses the frame-pointer register,
23# set -fomit-frame-pointer x86-64 to handle cases where optimisation
24# is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer
25# earlier in CFLAGS, etc.
26CFLAGS_append_x86-64 = " -fomit-frame-pointer"
27
28CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__"
29CFLAGS_append_mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
30SRCREV = "0fb171f2beddaf64bd27597577c206c0f892b3cd"
31
32SRC_URI = "git://github.com/linux-test-project/ltp.git \
33 file://0001-Remove-OOM-tests-from-runtest-mm.patch \
34 file://disable_hanging_tests.patch \
35 "
36
37S = "${WORKDIR}/git"
38
39inherit autotools-brokensep pkgconfig
40
41TARGET_CC_ARCH += "${LDFLAGS}"
42
43export prefix = "/opt/${PN}"
44export exec_prefix = "/opt/${PN}"
45
46PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
47EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
48EXTRA_OECONF = " --with-realtime-testsuite --with-open-posix-testsuite "
49# ltp network/rpc test cases ftbfs when libtirpc is found
50EXTRA_OECONF += " --without-tirpc "
51
52do_install(){
53 install -d ${D}${prefix}/
54 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install include-install
55
56 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
57 # as it lacks dependency on some perl moudle such as LWP::Simple
58 # And this script previously works as a tool for analyzing failures from LTP
59 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
60 # http://khack.osdl.org to retrieve ltp test results run on
61 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
62 rm -rf ${D}${prefix}/bin/STPfailure_report.pl
63
64 # Copy POSIX test suite into ${D}${prefix}/testcases by manual
65 cp -r testcases/open_posix_testsuite ${D}${prefix}/testcases
66
67 # Makefile were configured in the build system
68 find ${D}${prefix} -name Makefile | xargs -n 1 sed -i \
69 -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
70 -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \
71 -e 's@[^ ]*-ffile-prefix-map=[^ "]*@@g' \
72 -e 's@[^ ]*--sysroot=[^ "]*@@g'
73
74 # The controllers memcg_stree test seems to cause us hangs and takes 900s
75 # (maybe we expect more regular output?), anyhow, skip it
76 sed -e '/^memcg_stress/d' -i ${D}${prefix}/runtest/controllers
77}
78
79RDEPENDS_${PN} = "\
80 attr \
81 bash \
82 bc \
83 coreutils \
84 cpio \
85 cronie \
86 curl \
87 e2fsprogs \
88 e2fsprogs-mke2fs \
89 expect \
90 file \
91 gawk \
92 gdb \
93 gzip \
94 iproute2 \
95 ldd \
96 libaio \
97 logrotate \
98 net-tools \
99 perl \
100 python3-core \
101 procps \
102 quota \
103 unzip \
104 util-linux \
105 which \
106 tar \
107"
108
109FILES_${PN} += "${prefix}/* ${prefix}/runtest/* ${prefix}/scenario_groups/* ${prefix}/testcases/bin/* ${prefix}/testcases/bin/*/bin/* ${prefix}/testscripts/* ${prefix}/testcases/open_posix_testsuite/* ${prefix}/testcases/open_posix_testsuite/conformance/* ${prefix}/testcases/open_posix_testsuite/Documentation/* ${prefix}/testcases/open_posix_testsuite/functional/* ${prefix}/testcases/open_posix_testsuite/include/* ${prefix}/testcases/open_posix_testsuite/scripts/* ${prefix}/testcases/open_posix_testsuite/stress/* ${prefix}/testcases/open_posix_testsuite/tools/* ${prefix}/testcases/data/nm01/lib.a ${prefix}/lib/libmem.a"
110
111# Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail
112INHIBIT_PACKAGE_STRIP_FILES = "${prefix}/testcases/bin/nm01 ${prefix}/testcases/bin/ldd01"
113INSANE_SKIP_${PN} += "already-stripped staticdev"
114
115remove_broken_musl_sources() {
116 [ "${TCLIBC}" = "musl" ] || return 0
117
118 cd ${S}
119 echo "WARNING: remove unsupported tests (until they're fixed)"
120
121 # sync with upstream
122 # https://github.com/linux-test-project/ltp/blob/master/travis/alpine.sh#L33
123 rm -rfv \
124 testcases/kernel/sched/process_stress/process.c \
125 testcases/kernel/syscalls/confstr/confstr01.c \
126 testcases/kernel/syscalls/fmtmsg/fmtmsg01.c \
127 testcases/kernel/syscalls/getcontext/getcontext01.c \
128 testcases/kernel/syscalls/rt_tgsigqueueinfo/rt_tgsigqueueinfo01.c \
129 testcases/kernel/syscalls/timer_create/timer_create01.c \
130 testcases/kernel/syscalls/timer_create/timer_create03.c \
131 utils/benchmark/ebizzy-0.3
132}
133do_patch[postfuncs] += "remove_broken_musl_sources"
134
135# Avoid file dependency scans, as LTP checks for things that may or may not
136# exist on the running system. For instance it has specific checks for
137# csh and ksh which are not typically part of OpenEmbedded systems (but
138# can be added via additional layers.)
139SKIP_FILEDEPS_${PN} = '1'