summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp/ltp_20160126.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-02-12 09:54:20 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-14 11:42:19 +0000
commitb5b8003a0b99fb591f2e2a0a5ed74e60a120dc87 (patch)
treedc2c9b361a74923b39f75c5b1dc0f845a335051d /meta/recipes-extended/ltp/ltp_20160126.bb
parentf6b39575fb4cbc7cd9f7fbe57562ebca8901d59d (diff)
downloadpoky-b5b8003a0b99fb591f2e2a0a5ed74e60a120dc87.tar.gz
ltp: Upgrade to 20160126 and fix build on musl
pass -D__SANE_USERSPACE_TYPES__ to CFLAGS MIPS64/PPC64 uses long long for u64 in the kernel, but powerpc's asm/types.h prevents 64-bit userland from seeing this definition, instead defaulting to u64 == long in userspace. Define __SANE_USERSPACE_TYPES__ to get int-ll64.h included. (From OE-Core rev: d17984eda9635f98d4472019d4af83f661b4dfe7) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ltp/ltp_20160126.bb')
-rw-r--r--meta/recipes-extended/ltp/ltp_20160126.bb106
1 files changed, 106 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp_20160126.bb b/meta/recipes-extended/ltp/ltp_20160126.bb
new file mode 100644
index 0000000000..ac1679382d
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp_20160126.bb
@@ -0,0 +1,106 @@
1SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "http://ltp.sourceforge.net"
4SECTION = "console/utils"
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
9 file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \
10 file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
11 file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
12 file://testcases/open_posix_testsuite/COPYING;md5=216e43b72efbe4ed9017cc19c4c68b01 \
13 file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
14 file://tools/netpipe-2.4/COPYING;md5=9e3781bb5fe787aa80e1f51f5006b6fa \
15 file://tools/netpipe-2.4-ipv6/COPYING;md5=9e3781bb5fe787aa80e1f51f5006b6fa \
16 file://tools/top-LTP/proc/COPYING;md5=aefc88eb8a41672fbfcfe6b69ab8c49c \
17 file://tools/pounder21/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
18 file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
19 file://utils/ffsb-6.0-rc2/COPYING;md5=c46082167a314d785d012a244748d803 \
20"
21
22DEPENDS = "attr libaio libcap acl openssl zip-native"
23DEPENDS_append_libc-musl = " fts "
24EXTRA_OEMAKE_append_libc-musl = " LIBC=musl "
25CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__"
26CFLAGS_append_mips64 = " -D__SANE_USERSPACE_TYPES__"
27SRCREV = "fce797676b14f50406718e7ef640b50da66c9b36"
28
29SRC_URI = "git://github.com/linux-test-project/ltp.git \
30 file://0001-ltp-Don-t-link-against-libfl.patch \
31 file://0002-Add-knob-to-control-whether-numa-support-should-be-c.patch \
32 file://0003-Add-knob-to-control-tirpc-support.patch \
33 file://0004-build-Add-option-to-select-libc-implementation.patch \
34 file://0005-kernel-controllers-Link-with-libfts-explicitly-on-mu.patch \
35 file://0006-sendfile-Use-off64_t-instead-of-__off64_t.patch \
36 file://0007-replace-SIGCLD-with-SIGCHLD.patch \
37 file://0008-Check-if-__GLIBC_PREREQ-is-defined-before-using-it.patch \
38 file://0009-Guard-error.h-with-__GLIBC__.patch \
39 file://0010-replace-__BEGIN_DECLS-and-__END_DECLS.patch \
40 file://0011-Rename-sigset-variable-to-sigset1.patch \
41 file://0012-fsstress.c-Replace-__int64_t-with-int64_t.patch \
42 file://0013-include-fcntl.h-for-getting-O_-definitions.patch \
43 file://0014-hyperthreading-Include-sys-types.h-for-pid_t-definit.patch \
44 file://0015-mincore01-Rename-PAGESIZE-to-pagesize.patch \
45 file://0016-ustat-Change-header-from-ustat.h-to-sys-ustat.h.patch \
46 file://0017-replace-sigval_t-with-union-sigval.patch \
47 file://0018-guard-mallocopt-with-__GLIBC__.patch \
48 file://0019-tomoyo-Replace-canonicalize_file_name-with-realpath.patch \
49 file://0020-getdents-define-getdents-getdents64-only-for-glibc.patch \
50 file://0021-Define-_GNU_SOURCE-for-MREMAP_MAYMOVE-definition.patch \
51 file://0022-include-sys-types.h.patch \
52 file://0023-ptrace-Use-int-instead-of-enum-__ptrace_request.patch \
53 file://0024-rt_sigaction-rt_sigprocmark-Define-_GNU_SOURCE.patch \
54 file://0025-mc_gethost-include-sys-types.h.patch \
55 file://0026-crash01-Define-_GNU_SOURCE.patch \
56 file://0027-sysconf01-Use-_SC_2_C_VERSION-conditionally.patch \
57 file://0028-rt_sigaction.h-Use-sighandler_t-instead-of-__sighand.patch \
58 file://0029-trace_shed-Fix-build-with-musl.patch \
59 file://0030-lib-Use-PTHREAD_MUTEX_RECURSIVE-in-place-of-PTHREAD_.patch \
60 file://0031-vma03-fix-page-size-offset-as-per-page-size-alignmen.patch \
61 file://0032-regen.sh-Include-asm-unistd.h-explicitly.patch \
62"
63
64S = "${WORKDIR}/git"
65
66inherit autotools-brokensep
67
68TARGET_CC_ARCH += "${LDFLAGS}"
69
70export prefix = "/opt/ltp"
71export exec_prefix = "/opt/ltp"
72
73PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
74EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
75EXTRA_OECONF = " --with-power-management-testsuite --with-realtime-testsuite "
76# ltp network/rpc test cases ftbfs when libtirpc is found
77EXTRA_OECONF += " --without-tirpc "
78
79# The makefiles make excessive use of make -C and several include testcases.mk
80# which triggers a build of the syscall header. To reproduce, build ltp,
81# then delete the header, then "make -j XX" and watch regen.sh run multiple
82# times. Its easier to generate this once here instead.
83do_compile_prepend () {
84 ( make -C ${B}/testcases/kernel include/linux_syscall_numbers.h )
85}
86
87do_install(){
88 install -d ${D}/opt/ltp/
89 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install
90
91 # Copy POSIX test suite into ${D}/opt/ltp/testcases by manual
92 cp -r testcases/open_posix_testsuite ${D}/opt/ltp/testcases
93}
94
95RDEPENDS_${PN} = "perl e2fsprogs-mke2fs python-core libaio bash gawk expect ldd"
96
97FILES_${PN}-staticdev += "/opt/ltp/lib/libmem.a"
98
99FILES_${PN} += "/opt/ltp/* /opt/ltp/runtest/* /opt/ltp/scenario_groups/* /opt/ltp/testcases/bin/* /opt/ltp/testcases/bin/*/bin/* /opt/ltp/testscripts/* /opt/ltp/testcases/open_posix_testsuite/* /opt/ltp/testcases/open_posix_testsuite/conformance/* /opt/ltp/testcases/open_posix_testsuite/Documentation/* /opt/ltp/testcases/open_posix_testsuite/functional/* /opt/ltp/testcases/open_posix_testsuite/include/* /opt/ltp/testcases/open_posix_testsuite/scripts/* /opt/ltp/testcases/open_posix_testsuite/stress/* /opt/ltp/testcases/open_posix_testsuite/tools/*"
100
101# Avoid generated binaries stripping. Otherwise some of the ltp tests such as ldd01 & nm01 fails
102INHIBIT_PACKAGE_STRIP = "1"
103INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
104# However, test_arch_stripped is already stripped, so...
105INSANE_SKIP_${PN} += "already-stripped"
106