summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp/ltp_20140115.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2014-06-26 14:36:22 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2014-06-26 15:32:53 +0200
commitf4cf9fe05bb3f32fabea4e54dd92d368967a80da (patch)
tree487180fa9866985ea7b28e625651765d86f515c3 /meta/recipes-extended/ltp/ltp_20140115.bb
downloadpoky-f4cf9fe05bb3f32fabea4e54dd92d368967a80da.tar.gz
initial commit for Enea Linux 4.0
Migrated from the internal git server on the daisy-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'meta/recipes-extended/ltp/ltp_20140115.bb')
-rw-r--r--meta/recipes-extended/ltp/ltp_20140115.bb85
1 files changed, 85 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp_20140115.bb b/meta/recipes-extended/ltp/ltp_20140115.bb
new file mode 100644
index 0000000000..76c22cb960
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp_20140115.bb
@@ -0,0 +1,85 @@
1SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "http://ltp.sourceforge.net"
4SECTION = "console/utils"
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
8 file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
9 file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \
10 file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
11 file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
12 file://testcases/open_posix_testsuite/COPYING;md5=216e43b72efbe4ed9017cc19c4c68b01 \
13 file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
14 file://tools/netpipe-2.4/COPYING;md5=9e3781bb5fe787aa80e1f51f5006b6fa \
15 file://tools/netpipe-2.4-ipv6/COPYING;md5=9e3781bb5fe787aa80e1f51f5006b6fa \
16 file://tools/top-LTP/proc/COPYING;md5=aefc88eb8a41672fbfcfe6b69ab8c49c \
17 file://tools/pounder21/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
18 file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
19 file://utils/ffsb-6.0-rc2/COPYING;md5=c46082167a314d785d012a244748d803 \
20"
21
22DEPENDS = "attr libaio libcap acl openssl"
23SRCREV = "c8b3e28097e7d3208df9daceaf92c25eae87ebf0"
24
25SRC_URI = "git://github.com/linux-test-project/ltp.git \
26 file://0001-Rename-runtests_noltp.sh-script-so-have-unique-name.patch \
27 file://regen-makefile.patch \
28 file://ffsb-remove-hardcoded-configure.patch \
29 file://periodic_output.patch \
30 file://ltp-Do-not-link-against-libfl.patch \
31"
32
33S = "${WORKDIR}/git"
34
35inherit autotools-brokensep
36
37TARGET_CC_ARCH += "${LDFLAGS}"
38
39export prefix = "/opt/ltp"
40export exec_prefix = "/opt/ltp"
41
42# ltp doesn't regenerate ffsb-6.0-rc2 configure and hardcode configure call.
43# we explicitly force regeneration of that directory and pass configure options.
44do_configure_append() {
45 (cd utils/ffsb-6.0-rc2; autoreconf -fvi; ./configure ${CONFIGUREOPTS})
46}
47
48# The makefiles make excessive use of make -C and several include testcases.mk
49# which triggers a build of the syscall header. To reproduce, build ltp,
50# then delete the header, then "make -j XX" and watch regen.sh run multiple
51# times. Its easier to generate this once here instead.
52do_compile_prepend () {
53 ( make -C ${B}/testcases/kernel include/linux_syscall_numbers.h )
54}
55
56do_install(){
57 install -d ${D}/opt/ltp/
58 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install
59
60 # Copy POSIX test suite into ${D}/opt/ltp/testcases by manual
61 cp -r testcases/open_posix_testsuite ${D}/opt/ltp/testcases
62
63 # We need to remove all scripts which depend on /usr/bin/expect, since expect is not supported in oe-core
64 # We will add expect for enhancement in future
65 find ${D} -type f -print | xargs grep "\!.*\/usr\/bin\/expect" | awk -F":" '{print $1}' | xargs rm -f
66}
67
68RDEPENDS_${PN} = "perl e2fsprogs-mke2fs"
69
70FILES_${PN}-dbg += "\
71 /opt/ltp/runtest/.debug \
72 /opt/ltp/testcases/bin/.debug \
73 /opt/ltp/testcases/bin/*/bin/.debug \
74 /opt/ltp/testcases/bin/*/test/.debug \
75 /opt/ltp/scenario_groups/.debug \
76 /opt/ltp/testscripts/.debug \
77 /opt/ltp/testscripts/open_posix_testsuite/.debug \
78"
79
80FILES_${PN}-staticdev += "/opt/ltp/lib/libmem.a"
81
82FILES_${PN} += "/opt/ltp/* /opt/ltp/runtest/* /opt/ltp/scenario_groups/* /opt/ltp/testcases/bin/* /opt/ltp/testcases/bin/*/bin/* /opt/ltp/testscripts/* /opt/ltp/testcases/open_posix_testsuite/* /opt/ltp/testcases/open_posix_testsuite/conformance/* /opt/ltp/testcases/open_posix_testsuite/Documentation/* /opt/ltp/testcases/open_posix_testsuite/functional/* /opt/ltp/testcases/open_posix_testsuite/include/* /opt/ltp/testcases/open_posix_testsuite/scripts/* /opt/ltp/testcases/open_posix_testsuite/stress/* /opt/ltp/testcases/open_posix_testsuite/tools/*"
83
84# Avoid generated binaries stripping. Otherwise some of the ltp tests such as ldd01 & nm01 fails
85INHIBIT_PACKAGE_STRIP = "1"