summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp/ltp_20140115.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-01 15:17:50 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-02 17:25:29 +0000
commit4b048ac882a265e0da73faeac31cedba96c4a811 (patch)
tree18e11c20e117ef76836688464640b3b00b85d3b6 /meta/recipes-extended/ltp/ltp_20140115.bb
parent7d949e5406a7c2e0bb0490e0d33cc220c68b675b (diff)
downloadpoky-4b048ac882a265e0da73faeac31cedba96c4a811.tar.gz
ltp: Work around parallel make race
As per the comments, the makefiles use make -C extensively and this causes particular problems around the kernel syscall header. We therefore ensure its up to date in advance. Also, append the configure, not prepend since otherwise the configure will rerun during the build due to the timestamps being outdated. (From OE-Core rev: e52d6bc4e6567e8a68749ee1eb66fd6176810222) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ltp/ltp_20140115.bb')
-rw-r--r--meta/recipes-extended/ltp/ltp_20140115.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta/recipes-extended/ltp/ltp_20140115.bb b/meta/recipes-extended/ltp/ltp_20140115.bb
index 361eccb0b1..2a3999b8cb 100644
--- a/meta/recipes-extended/ltp/ltp_20140115.bb
+++ b/meta/recipes-extended/ltp/ltp_20140115.bb
@@ -39,10 +39,18 @@ export exec_prefix = "/opt/ltp"
39 39
40# ltp doesn't regenerate ffsb-6.0-rc2 configure and hardcode configure call. 40# ltp doesn't regenerate ffsb-6.0-rc2 configure and hardcode configure call.
41# we explicitly force regeneration of that directory and pass configure options. 41# we explicitly force regeneration of that directory and pass configure options.
42do_configure_prepend() { 42do_configure_append() {
43 (cd utils/ffsb-6.0-rc2; autoreconf -fvi; ./configure ${CONFIGUREOPTS}) 43 (cd utils/ffsb-6.0-rc2; autoreconf -fvi; ./configure ${CONFIGUREOPTS})
44} 44}
45 45
46# The makefiles make excessive use of make -C and several include testcases.mk
47# which triggers a build of the syscall header. To reproduce, build ltp,
48# then delete the header, then "make -j XX" and watch regen.sh run multiple
49# times. Its easier to generate this once here instead.
50do_compile_prepend () {
51 ( make -C ${B}/testcases/kernel include/linux_syscall_numbers.h )
52}
53
46do_install(){ 54do_install(){
47 install -d ${D}/opt/ltp/ 55 install -d ${D}/opt/ltp/
48 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install 56 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install