summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsof/lsof_4.91.bb
diff options
context:
space:
mode:
authorOvidiu Panait <ovidiu.panait@windriver.com>2018-07-25 16:06:39 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-30 12:44:34 +0100
commitad02cb7f8265a0d8b4988a3f1f68bafd9507ae63 (patch)
tree53faa9ee56ddb559d322aef40f77912d848d4fd1 /meta/recipes-extended/lsof/lsof_4.91.bb
parentebc0069b3660e87a0360494351539cfb73fcb05d (diff)
downloadpoky-ad02cb7f8265a0d8b4988a3f1f68bafd9507ae63.tar.gz
lsof: upgrade 4.89 -> 4.91
(From OE-Core rev: 784f993f52c8e591d96efadfec486a736b6f1ff5) Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lsof/lsof_4.91.bb')
-rw-r--r--meta/recipes-extended/lsof/lsof_4.91.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta/recipes-extended/lsof/lsof_4.91.bb b/meta/recipes-extended/lsof/lsof_4.91.bb
new file mode 100644
index 0000000000..0128de4a6e
--- /dev/null
+++ b/meta/recipes-extended/lsof/lsof_4.91.bb
@@ -0,0 +1,64 @@
1SUMMARY = "LiSt Open Files tool"
2DESCRIPTION = "Lsof is a Unix-specific diagnostic tool. \
3Its name stands for LiSt Open Files, and it does just that."
4HOMEPAGE = "http://people.freebsd.org/~abe/"
5SECTION = "devel"
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://00README;beginline=645;endline=679;md5=964df275d26429ba3b39dbb9f205172a"
8
9# Upstream lsof releases are hosted on an ftp server which times out download
10# attempts from hosts for which it can not perform a DNS reverse-lookup (See:
11# https://people.freebsd.org/~abe/ ). http://www.mirrorservice.org seems to be
12# the most commonly used alternative.
13
14SRC_URI = "http://www.mirrorservice.org/sites/lsof.itap.purdue.edu/pub/tools/unix/lsof/lsof_${PV}.tar.bz2 \
15 file://lsof-remove-host-information.patch \
16 "
17
18SRC_URI[md5sum] = "148ed410cb52e08c2adc0c60f480f11f"
19SRC_URI[sha256sum] = "c9da946a525fbf82ff80090b6d1879c38df090556f3fe0e6d782cb44172450a3"
20
21LOCALSRC = "file://${WORKDIR}/lsof_${PV}/lsof_${PV}_src.tar"
22
23S = "${WORKDIR}/lsof_${PV}_src"
24
25python do_unpack () {
26 # temporarily change S for unpack
27 # of lsof_${PV}
28 s = d.getVar('S', False)
29 d.setVar('S', '${WORKDIR}/lsof_${PV}')
30 bb.build.exec_func('base_do_unpack', d)
31 # temporarily change SRC_URI for unpack
32 # of lsof_${PV}_src
33 src_uri = d.getVar('SRC_URI', False)
34 d.setVar('SRC_URI', '${LOCALSRC}')
35 d.setVar('S', s)
36 bb.build.exec_func('base_do_unpack', d)
37 d.setVar('SRC_URI', src_uri)
38}
39
40export LSOF_INCLUDE = "${STAGING_INCDIR}"
41
42do_configure () {
43 export LSOF_AR="${AR} cr"
44 export LSOF_RANLIB="${RANLIB}"
45 if [ "x${GLIBCVERSION}" != "x" ]; then
46 LINUX_CLIB=`echo ${GLIBCVERSION} |sed -e 's,\.,,g'`
47 LINUX_CLIB="-DGLIBCV=${LINUX_CLIB}"
48 export LINUX_CLIB
49 fi
50 yes | ./Configure linux
51}
52
53export I = "${STAGING_INCDIR}"
54export L = "${STAGING_INCDIR}"
55
56do_compile () {
57 oe_runmake 'CC=${CC}' 'CFGL=${LDFLAGS} -L./lib -llsof' 'DEBUG=' 'INCL=${CFLAGS}'
58}
59
60do_install () {
61 install -d ${D}${sbindir} ${D}${mandir}/man8
62 install -m 0755 lsof ${D}${sbindir}/lsof
63 install -m 0644 lsof.8 ${D}${mandir}/man8/lsof.8
64}