summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsof/lsof_4.88.bb
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linux.intel.com>2014-12-29 11:24:09 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-31 08:14:21 +0000
commit0d58be6bf285f6de81660688a13b21e735026727 (patch)
tree3f212666dc78a021334ea3a52467e8d93a90343d /meta/recipes-extended/lsof/lsof_4.88.bb
parent6e13bfb174d44f0f993597750299aabbb16e4a1a (diff)
downloadpoky-0d58be6bf285f6de81660688a13b21e735026727.tar.gz
lsof: Upgrade to 4.88
(From OE-Core rev: b463d7001972a255447aec9dfdecd4af693293b4) Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lsof/lsof_4.88.bb')
-rw-r--r--meta/recipes-extended/lsof/lsof_4.88.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-extended/lsof/lsof_4.88.bb b/meta/recipes-extended/lsof/lsof_4.88.bb
new file mode 100644
index 0000000000..a96b06eae7
--- /dev/null
+++ b/meta/recipes-extended/lsof/lsof_4.88.bb
@@ -0,0 +1,53 @@
1SUMMARY = "LiSt Open Files tool"
2DESCRIPTION = "Lsof is a Unix-specific diagnostic tool. \
3Its name stands for LiSt Open Files, and it does just that."
4SECTION = "devel"
5LICENSE = "BSD"
6
7SRC_URI = "ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/lsof_${PV}.tar.bz2"
8
9SRC_URI[md5sum] = "1b29c10db4aa88afcaeeaabeef6790db"
10SRC_URI[sha256sum] = "fe6f9b0e26b779ccd0ea5a0b6327c2b5c38d207a6db16f61ac01bd6c44e5c99b"
11
12LOCALSRC = "file://${WORKDIR}/lsof_${PV}/lsof_${PV}_src.tar"
13S = "${WORKDIR}/lsof_${PV}_src"
14
15LIC_FILES_CHKSUM = "file://${S}/00README;beginline=645;endline=679;md5=964df275d26429ba3b39dbb9f205172a"
16
17python do_unpack () {
18 bb.build.exec_func('base_do_unpack', d)
19 src_uri = d.getVar('SRC_URI')
20 d.setVar('SRC_URI', '${LOCALSRC}')
21 bb.build.exec_func('base_do_unpack', d)
22 d.setVar('SRC_URI', src_uri)
23}
24
25export LSOF_OS = "${TARGET_OS}"
26LSOF_OS_libc-uclibc = "linux"
27LSOF_OS_libc-glibc = "linux"
28export LSOF_INCLUDE = "${STAGING_INCDIR}"
29
30do_configure () {
31 export LSOF_AR="${AR} cr"
32 export LSOF_RANLIB="${RANLIB}"
33 if [ "x${GLIBCVERSION}" != "x" ];then
34 LINUX_CLIB=`echo ${GLIBCVERSION} |sed -e 's,\.,,g'`
35 LINUX_CLIB="-DGLIBCV=${LINUX_CLIB}"
36 export LINUX_CLIB
37 fi
38 yes | ./Configure ${LSOF_OS}
39}
40
41export I = "${STAGING_INCDIR}"
42export L = "${STAGING_INCDIR}"
43export EXTRA_OEMAKE = ""
44
45do_compile () {
46 oe_runmake 'CC=${CC}' 'CFGL=${LDFLAGS} -L./lib -llsof' 'DEBUG=' 'INCL=${CFLAGS}'
47}
48
49do_install () {
50 install -d ${D}${sbindir} ${D}${mandir}/man8
51 install -m 4755 lsof ${D}${sbindir}/lsof
52 install -m 0644 lsof.8 ${D}${mandir}/man8/lsof.8
53}