diff options
author | Bogdan Marinescu <bogdan.a.marinescu@intel.com> | 2013-01-08 12:09:54 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2013-01-10 23:43:10 +0000 |
commit | b06f1f3cd899b106e27df6702d9ade8649a1b8d3 (patch) | |
tree | a2de217031c6f8e64a62018caffe29b492105542 /meta/recipes-extended/lsof/lsof_4.87.bb | |
parent | 1226f29bf0d06ae6cf99fd6b6ee286daa88f3229 (diff) | |
download | poky-b06f1f3cd899b106e27df6702d9ade8649a1b8d3.tar.gz |
lsof: updated to 4.87
(From OE-Core rev: 24b57b871ab559e8ff5fe5cdd0412ef6ac51f689)
Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lsof/lsof_4.87.bb')
-rw-r--r-- | meta/recipes-extended/lsof/lsof_4.87.bb | 54 |
1 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-extended/lsof/lsof_4.87.bb b/meta/recipes-extended/lsof/lsof_4.87.bb new file mode 100644 index 0000000000..2f425aab4a --- /dev/null +++ b/meta/recipes-extended/lsof/lsof_4.87.bb | |||
@@ -0,0 +1,54 @@ | |||
1 | SUMMARY = "LiSt Open Files tool" | ||
2 | DESCRIPTION = "Lsof is a Unix-specific diagnostic tool. \ | ||
3 | Its name stands for LiSt Open Files, and it does just that." | ||
4 | SECTION = "devel" | ||
5 | LICENSE = "BSD" | ||
6 | PR = "r0" | ||
7 | |||
8 | SRC_URI = "ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/lsof_${PV}.tar.bz2" | ||
9 | |||
10 | SRC_URI[md5sum] = "80e2a76d0e05826db910ec88e631296c" | ||
11 | SRC_URI[sha256sum] = "dfdd3709d82bc79ccdf3e404b84aafa9aede5948642a824ecaefd0aac589da2c" | ||
12 | |||
13 | LOCALSRC = "file://${WORKDIR}/lsof_${PV}/lsof_${PV}_src.tar" | ||
14 | S = "${WORKDIR}/lsof_${PV}_src" | ||
15 | |||
16 | LIC_FILES_CHKSUM = "file://${S}/00README;beginline=645;endline=679;md5=964df275d26429ba3b39dbb9f205172a" | ||
17 | |||
18 | python do_unpack () { | ||
19 | bb.build.exec_func('base_do_unpack', d) | ||
20 | src_uri = d.getVar('SRC_URI') | ||
21 | d.setVar('SRC_URI', '${LOCALSRC}') | ||
22 | bb.build.exec_func('base_do_unpack', d) | ||
23 | d.setVar('SRC_URI', src_uri) | ||
24 | } | ||
25 | |||
26 | export LSOF_OS = "${TARGET_OS}" | ||
27 | LSOF_OS_libc-uclibc = "linux" | ||
28 | LSOF_OS_libc-glibc = "linux" | ||
29 | export LSOF_INCLUDE = "${STAGING_INCDIR}" | ||
30 | |||
31 | do_configure () { | ||
32 | export LSOF_AR="${AR} cr" | ||
33 | export LSOF_RANLIB="${RANLIB}" | ||
34 | if [ "x${EGLIBCVERSION}" != "x" ];then | ||
35 | LINUX_CLIB=`echo ${EGLIBCVERSION} |sed -e 's,\.,,g'` | ||
36 | LINUX_CLIB="-DGLIBCV=${LINUX_CLIB}" | ||
37 | export LINUX_CLIB | ||
38 | fi | ||
39 | yes | ./Configure ${LSOF_OS} | ||
40 | } | ||
41 | |||
42 | export I = "${STAGING_INCDIR}" | ||
43 | export L = "${STAGING_INCDIR}" | ||
44 | export EXTRA_OEMAKE = "" | ||
45 | |||
46 | do_compile () { | ||
47 | oe_runmake 'CC=${CC}' 'CFGL=${LDFLAGS} -L./lib -llsof' 'DEBUG=' 'INCL=${CFLAGS}' | ||
48 | } | ||
49 | |||
50 | do_install () { | ||
51 | install -d ${D}${sbindir} ${D}${mandir}/man8 | ||
52 | install -m 4755 lsof ${D}${sbindir}/lsof | ||
53 | install -m 0644 lsof.8 ${D}${mandir}/man8/lsof.8 | ||
54 | } | ||