diff options
author | Andrei Gherzan <andrei@gherzan.ro> | 2012-09-20 12:56:59 +0300 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-09-20 13:33:50 +0100 |
commit | 42d91a7db404bacc50541e1813c537d9c260ffb4 (patch) | |
tree | 5ffa8dd4259197731192f3e6b2d47fc93b3c2f62 /meta/recipes-extended/lsb/lsb_4.1.bb | |
parent | 82a08d42ffddc4d955706ebe2e0078134574a6ba (diff) | |
download | poky-42d91a7db404bacc50541e1813c537d9c260ffb4.tar.gz |
Replace "echo -e" with "printf" to have the same behavior in dash or bash
oe-core removed the prerequisite to have sh as bash. POSIX doesn't define
any options and furthermore allows 'echo -e' to be the default behavior.
This means that in dash 'echo -e' will actually print '-e' and interpret
backslashes by default. We use instead 'printf' builtin command with or
without '\n' to simulate 'echo -e' or 'echo -n'.
'printf' needs format while 'echo' can be used without any arguments. So
'echo >' was replaced by 'printf "" >'.
'echo' without '-n' flag adds a new line by default so to keep the same
behavior of two new lines while using 'echo "\n"', 'printf "\n\n"' is
used.
[YOCTO #3138]
(From OE-Core rev: a19880ad10ccb5d7d909dcf9de5c3dc58a0ebcd3)
Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lsb/lsb_4.1.bb')
-rw-r--r-- | meta/recipes-extended/lsb/lsb_4.1.bb | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-extended/lsb/lsb_4.1.bb b/meta/recipes-extended/lsb/lsb_4.1.bb index a3242db708..55ea241783 100644 --- a/meta/recipes-extended/lsb/lsb_4.1.bb +++ b/meta/recipes-extended/lsb/lsb_4.1.bb | |||
@@ -31,12 +31,12 @@ do_install(){ | |||
31 | mkdir -p ${D}${base_bindir} | 31 | mkdir -p ${D}${base_bindir} |
32 | mkdir -p ${D}/${baselib} | 32 | mkdir -p ${D}/${baselib} |
33 | mkdir -p ${D}${sysconfdir}/lsb-release.d | 33 | mkdir -p ${D}${sysconfdir}/lsb-release.d |
34 | echo -n "LSB_VERSION=\"core-4.1-noarch:" > ${D}${sysconfdir}/lsb-release | 34 | printf "LSB_VERSION=\"core-4.1-noarch:" > ${D}${sysconfdir}/lsb-release |
35 | 35 | ||
36 | if [ "${TARGET_ARCH}" = "i586" ];then | 36 | if [ "${TARGET_ARCH}" = "i586" ];then |
37 | echo -n "core-4.1-ia32" >> ${D}${sysconfdir}/lsb-release | 37 | printf "core-4.1-ia32" >> ${D}${sysconfdir}/lsb-release |
38 | else | 38 | else |
39 | echo -n "core-4.1-${TARGET_ARCH}" >> ${D}${sysconfdir}/lsb-release | 39 | printf "core-4.1-${TARGET_ARCH}" >> ${D}${sysconfdir}/lsb-release |
40 | fi | 40 | fi |
41 | echo "\"" >> ${D}${sysconfdir}/lsb-release | 41 | echo "\"" >> ${D}${sysconfdir}/lsb-release |
42 | echo "DISTRIB_ID=${DISTRO}" >> ${D}${sysconfdir}/lsb-release | 42 | echo "DISTRIB_ID=${DISTRO}" >> ${D}${sysconfdir}/lsb-release |