diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-04-18 12:06:48 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-04-18 12:07:25 +0100 |
commit | b76513948b754458f0b1ea63290f46253aa5d624 (patch) | |
tree | e683c87c1df8e07fc8b1d2e2de87fdb55a46a297 /meta/recipes-extended/lsb/lsb_1.4.bb | |
parent | d220e071abfe33fa43d1cbe67b0ec5764364b284 (diff) | |
download | poky-b76513948b754458f0b1ea63290f46253aa5d624.tar.gz |
lsb: Fix PR bump, fix bashisms, correct dependency issue, tweak package description
(From OE-Core rev: 48ef8dbb0d1bdbc7e0e62665b5112282637f3266)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lsb/lsb_1.4.bb')
-rw-r--r-- | meta/recipes-extended/lsb/lsb_1.4.bb | 21 |
1 files changed, 11 insertions, 10 deletions
diff --git a/meta/recipes-extended/lsb/lsb_1.4.bb b/meta/recipes-extended/lsb/lsb_1.4.bb index e414d93260..15dbeaafdf 100644 --- a/meta/recipes-extended/lsb/lsb_1.4.bb +++ b/meta/recipes-extended/lsb/lsb_1.4.bb | |||
@@ -1,10 +1,11 @@ | |||
1 | DESCRIPTION = "LSB support for Poky Linux" | 1 | DESCRIPTION = "LSB support for OpenEmbedded" |
2 | SECTION = "console/utils" | 2 | SECTION = "console/utils" |
3 | HOMEPAGE = "http://prdownloads.sourceforge.net/lsb" | 3 | HOMEPAGE = "http://prdownloads.sourceforge.net/lsb" |
4 | LICENSE = "GPLv2+" | 4 | LICENSE = "GPLv2+" |
5 | PR = "r2" | 5 | PR = "r3" |
6 | 6 | ||
7 | DEPENDS="util-linux" | 7 | # lsb_release needs getopt |
8 | RDEPENDS_${PN} += "util-linux" | ||
8 | 9 | ||
9 | LIC_FILES_CHKSUM = "file://README;md5=12da544b1a3a5a1795a21160b49471cf" | 10 | LIC_FILES_CHKSUM = "file://README;md5=12da544b1a3a5a1795a21160b49471cf" |
10 | 11 | ||
@@ -27,7 +28,7 @@ do_install(){ | |||
27 | mkdir -p ${D}/etc/lsb-release.d | 28 | mkdir -p ${D}/etc/lsb-release.d |
28 | echo -n "LSB_VERSION=\"core-4.1-noarch:" > ${D}/etc/lsb-release | 29 | echo -n "LSB_VERSION=\"core-4.1-noarch:" > ${D}/etc/lsb-release |
29 | 30 | ||
30 | if [ "${TARGET_ARCH}" == "i586" ];then | 31 | if [ "${TARGET_ARCH}" = "i586" ];then |
31 | echo -n "core-4.1-ia32" >> ${D}/etc/lsb-release | 32 | echo -n "core-4.1-ia32" >> ${D}/etc/lsb-release |
32 | else | 33 | else |
33 | echo -n "core-4.1-${TARGET_ARCH}" >> ${D}/etc/lsb-release | 34 | echo -n "core-4.1-${TARGET_ARCH}" >> ${D}/etc/lsb-release |
@@ -37,7 +38,7 @@ do_install(){ | |||
37 | echo "DISTRIB_RELEASE=${DISTRO_VERSION}" >> ${D}/etc/lsb-release | 38 | echo "DISTRIB_RELEASE=${DISTRO_VERSION}" >> ${D}/etc/lsb-release |
38 | echo "DISTRIB_DESCRIPTION=\"${DISTRO_NAME} ${DISTRO_VERSION}\"" >> ${D}/etc/lsb-release | 39 | echo "DISTRIB_DESCRIPTION=\"${DISTRO_NAME} ${DISTRO_VERSION}\"" >> ${D}/etc/lsb-release |
39 | 40 | ||
40 | if [ "${TARGET_ARCH}" == "i586" ];then | 41 | if [ "${TARGET_ARCH}" = "i586" ];then |
41 | mkdir -p ${D}/etc/lsb-release.d | 42 | mkdir -p ${D}/etc/lsb-release.d |
42 | touch ${D}/etc/lsb-release.d/graphics-4.1-noarch | 43 | touch ${D}/etc/lsb-release.d/graphics-4.1-noarch |
43 | touch ${D}/etc/lsb-release.d/graphics-${PV}-noarch | 44 | touch ${D}/etc/lsb-release.d/graphics-${PV}-noarch |
@@ -45,7 +46,7 @@ do_install(){ | |||
45 | touch ${D}/etc/lsb-release.d/graphics-4.1-ia32 | 46 | touch ${D}/etc/lsb-release.d/graphics-4.1-ia32 |
46 | touch ${D}/etc/lsb-release.d/graphics-${PV}-ia32 | 47 | touch ${D}/etc/lsb-release.d/graphics-${PV}-ia32 |
47 | touch ${D}/etc/lsb-release.d/desktop-${PV}-ia32 | 48 | touch ${D}/etc/lsb-release.d/desktop-${PV}-ia32 |
48 | elif [ "${TARGET_ARCH}" == "x86_64" ];then | 49 | elif [ "${TARGET_ARCH}" = "x86_64" ];then |
49 | touch ${D}/etc/lsb-release.d/graphics-4.1-noarch | 50 | touch ${D}/etc/lsb-release.d/graphics-4.1-noarch |
50 | touch ${D}/etc/lsb-release.d/graphics-4.1-amd64 | 51 | touch ${D}/etc/lsb-release.d/graphics-4.1-amd64 |
51 | touch ${D}/etc/lsb-release.d/graphics-${PV}-amd64 | 52 | touch ${D}/etc/lsb-release.d/graphics-${PV}-amd64 |
@@ -72,7 +73,7 @@ do_install_append(){ | |||
72 | install -m 0755 ${WORKDIR}/${i} ${D}/etc/core-lsb | 73 | install -m 0755 ${WORKDIR}/${i} ${D}/etc/core-lsb |
73 | done | 74 | done |
74 | install -m 0755 ${WORKDIR}/init-functions ${D}/${baselib}/lsb | 75 | install -m 0755 ${WORKDIR}/init-functions ${D}/${baselib}/lsb |
75 | if [ "${TARGET_ARCH}" == "x86_64" ];then | 76 | if [ "${TARGET_ARCH}" = "x86_64" ];then |
76 | cd ${D} | 77 | cd ${D} |
77 | if [ "${baselib}" != "lib64" ]; then | 78 | if [ "${baselib}" != "lib64" ]; then |
78 | ln -sf ${baselib} lib64 | 79 | ln -sf ${baselib} lib64 |
@@ -81,13 +82,13 @@ do_install_append(){ | |||
81 | ln -sf ld-linux-x86-64.so.2 ld-lsb-x86-64.so.2 | 82 | ln -sf ld-linux-x86-64.so.2 ld-lsb-x86-64.so.2 |
82 | ln -sf ld-linux-x86-64.so.2 ld-lsb-x86-64.so.3 | 83 | ln -sf ld-linux-x86-64.so.2 ld-lsb-x86-64.so.3 |
83 | fi | 84 | fi |
84 | if [ "${TARGET_ARCH}" == "i586" ];then | 85 | if [ "${TARGET_ARCH}" = "i586" ];then |
85 | cd ${D}/${baselib} | 86 | cd ${D}/${baselib} |
86 | ln -sf ld-linux.so.2 ld-lsb.so.2 | 87 | ln -sf ld-linux.so.2 ld-lsb.so.2 |
87 | ln -sf ld-linux.so.2 ld-lsb.so.3 | 88 | ln -sf ld-linux.so.2 ld-lsb.so.3 |
88 | fi | 89 | fi |
89 | 90 | ||
90 | if [ "${TARGET_ARCH}" == "powerpc64" ];then | 91 | if [ "${TARGET_ARCH}" = "powerpc64" ];then |
91 | cd ${D} | 92 | cd ${D} |
92 | if [ "${baselib}" != "lib64" ]; then | 93 | if [ "${baselib}" != "lib64" ]; then |
93 | ln -sf ${baselib} lib64 | 94 | ln -sf ${baselib} lib64 |
@@ -96,7 +97,7 @@ do_install_append(){ | |||
96 | ln -sf ld64.so.1 ld-lsb-ppc64.so.2 | 97 | ln -sf ld64.so.1 ld-lsb-ppc64.so.2 |
97 | ln -sf ld64.so.1 ld-lsb-ppc64.so.3 | 98 | ln -sf ld64.so.1 ld-lsb-ppc64.so.3 |
98 | fi | 99 | fi |
99 | if [ "${TARGET_ARCH}" == "powerpc" ];then | 100 | if [ "${TARGET_ARCH}" = "powerpc" ];then |
100 | cd ${D}/${baselib} | 101 | cd ${D}/${baselib} |
101 | ln -sf ld.so.1 ld-lsb-ppc32.so.2 | 102 | ln -sf ld.so.1 ld-lsb-ppc32.so.2 |
102 | ln -sf ld.so.1 ld-lsb-ppc32.so.3 | 103 | ln -sf ld.so.1 ld-lsb-ppc32.so.3 |