summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/logrotate/logrotate_3.8.1.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2012-03-14 17:55:17 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-19 14:37:36 +0000
commit7f33f59c7ad2184aa66d0b417853a6b33e9bfbb3 (patch)
treef66e71591bbb8b50a15dc251d0884a9f671a1cd0 /meta/recipes-extended/logrotate/logrotate_3.8.1.bb
parenta163d2168ffc3cc72adcb711a59b1331215bb91c (diff)
downloadpoky-7f33f59c7ad2184aa66d0b417853a6b33e9bfbb3.tar.gz
upgrade logrotate: update the recipe
update the recipe: ogrotate_3.7.9.bb -> logrotate_3.8.1.bb (From OE-Core rev: 9dc1a8c793e1908032be0f0ea3b3f0832b1bf5aa) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/logrotate/logrotate_3.8.1.bb')
-rw-r--r--meta/recipes-extended/logrotate/logrotate_3.8.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-extended/logrotate/logrotate_3.8.1.bb b/meta/recipes-extended/logrotate/logrotate_3.8.1.bb
new file mode 100644
index 0000000000..5a8156be57
--- /dev/null
+++ b/meta/recipes-extended/logrotate/logrotate_3.8.1.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "Rotates, compresses, removes and mails system log files"
2SECTION = "console/utils"
3HOMEPAGE = "https://fedorahosted.org/releases/l/o/logrotate"
4LICENSE = "GPLv2"
5PR = "r0"
6
7DEPENDS="coreutils popt"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
10
11SRC_URI = "https://fedorahosted.org/releases/l/o/logrotate/logrotate-${PV}.tar.gz \
12 file://act-as-mv-when-rotate.patch \
13 file://disable-check-different-filesystems.patch \
14 file://update-the-manual.patch \
15 "
16
17SRC_URI[md5sum] = "bd2e20d8dc644291b08f9215397d28a5"
18SRC_URI[sha256sum] = "c12471e70ae8bc923bd5c4f25e8fd6483b68c6301f3cd79f7cfe37bc5b370169"
19
20
21EXTRA_OEMAKE = "CC='${CC}'"
22
23do_install(){
24 oe_runmake install DESTDIR=${D} PREFIX=${D} MANDIR=${mandir}
25}
26
27do_install_append(){
28 mkdir -p ${D}${sysconfdir}/logrotate.d
29 mkdir -p ${D}${sysconfdir}/cron.daily
30 mkdir -p ${D}${localstatedir}/lib
31 install -p -m 644 examples/logrotate-default ${D}${sysconfdir}/logrotate.conf
32 install -p -m 755 examples/logrotate.cron ${D}${sysconfdir}/cron.daily/logrotate
33 touch ${D}${localstatedir}/lib/logrotate.status
34}