summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/logrotate/logrotate_3.12.3.bb
diff options
context:
space:
mode:
authorRomain Perier <romain.perier@collabora.com>2017-07-11 08:46:05 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-21 22:51:37 +0100
commit98d3a094d0d474303c3096d4c5d6223b7d5d7c3d (patch)
tree3b31fa83fdbd6b079cfd35547c5d79a0679e2a53 /meta/recipes-extended/logrotate/logrotate_3.12.3.bb
parentc2318ef416e13c3eaae14f395153ad97491a06bf (diff)
downloadpoky-98d3a094d0d474303c3096d4c5d6223b7d5d7c3d.tar.gz
logrotate: Bump to 3.12.3
This commit updates the recipe to the last upstream tag. Then, as the tarball no longer contains the pre-generated Makefile, inherit from autotools (From OE-Core rev: 72490b7a327867872987e63d340051c4980044b2) Signed-off-by: Romain Perier <romain.perier@collabora.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/logrotate/logrotate_3.12.3.bb')
-rw-r--r--meta/recipes-extended/logrotate/logrotate_3.12.3.bb66
1 files changed, 66 insertions, 0 deletions
diff --git a/meta/recipes-extended/logrotate/logrotate_3.12.3.bb b/meta/recipes-extended/logrotate/logrotate_3.12.3.bb
new file mode 100644
index 0000000000..2033be1e2d
--- /dev/null
+++ b/meta/recipes-extended/logrotate/logrotate_3.12.3.bb
@@ -0,0 +1,66 @@
1SUMMARY = "Rotates, compresses, removes and mails system log files"
2SECTION = "console/utils"
3HOMEPAGE = "https://github.com/logrotate/logrotate/issues"
4LICENSE = "GPLv2"
5
6# TODO: Document coreutils dependency. Why not RDEPENDS? Why not busybox?
7
8DEPENDS="coreutils popt"
9
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12# When updating logrotate to latest upstream, SRC_URI should point to
13# a proper release tarball from https://github.com/logrotate/logrotate/releases
14# and we have to take the snapshot for now because there is no such
15# tarball available for 3.9.1.
16
17S = "${WORKDIR}/${BPN}-${PV}"
18
19UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases"
20UPSTREAM_CHECK_REGEX = "logrotate-(?P<pver>\d+(\.\d+)+).tar"
21
22SRC_URI = "https://github.com/${BPN}/${BPN}/archive/${PV}.tar.gz \
23 file://act-as-mv-when-rotate.patch \
24 file://update-the-manual.patch \
25 file://disable-check-different-filesystems.patch \
26 "
27
28SRC_URI[md5sum] = "d1c41bdf63b9993c8e4e8b48a7bd5b8b"
29SRC_URI[sha256sum] = "683ccb7fff74082471aa6bd9e962ae7a3f4d55eea7df41fd97aa12ec6f55e657"
30
31PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'acl selinux', d)}"
32
33PACKAGECONFIG[acl] = ",,acl"
34PACKAGECONFIG[selinux] = ",,libselinux"
35
36CONFFILES_${PN} += "${localstatedir}/lib/logrotate.status \
37 ${sysconfdir}/logrotate.conf"
38
39# If RPM_OPT_FLAGS is unset, it adds -g itself rather than obeying our
40# optimization variables, so use it rather than EXTRA_CFLAGS.
41EXTRA_OEMAKE = "\
42 LFS= \
43 OS_NAME='${OS_NAME}' \
44 'CC=${CC}' \
45 'RPM_OPT_FLAGS=${CFLAGS}' \
46 'EXTRA_LDFLAGS=${LDFLAGS}' \
47 ${@bb.utils.contains('PACKAGECONFIG', 'acl', 'WITH_ACL=yes', '', d)} \
48 ${@bb.utils.contains('PACKAGECONFIG', 'selinux', 'WITH_SELINUX=yes', '', d)} \
49"
50
51# OS_NAME in the makefile defaults to `uname -s`. The behavior for
52# freebsd/netbsd is questionable, so leave it as Linux, which only sets
53# INSTALL=install and BASEDIR=/usr.
54OS_NAME = "Linux"
55
56inherit autotools
57
58do_install(){
59 oe_runmake install DESTDIR=${D} PREFIX=${D} MANDIR=${mandir}
60 mkdir -p ${D}${sysconfdir}/logrotate.d
61 mkdir -p ${D}${sysconfdir}/cron.daily
62 mkdir -p ${D}${localstatedir}/lib
63 install -p -m 644 ${S}/examples/logrotate-default ${D}${sysconfdir}/logrotate.conf
64 install -p -m 755 ${S}/examples/logrotate.cron ${D}${sysconfdir}/cron.daily/logrotate
65 touch ${D}${localstatedir}/lib/logrotate.status
66}