summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lighttpd/lighttpd_1.4.45.bb
diff options
context:
space:
mode:
authorAndrej Valek <andrej.valek@siemens.com>2017-02-10 13:42:29 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-15 20:06:44 -0800
commit18951ec67d96f4525e694ef7ff0f6462c6918065 (patch)
treea5c24b459889ebb0955168673e6d747e0508dbf6 /meta/recipes-extended/lighttpd/lighttpd_1.4.45.bb
parenta06e298de8306356327485be03404e45ed1941fa (diff)
downloadpoky-18951ec67d96f4525e694ef7ff0f6462c6918065.tar.gz
lighttpd: Upgrade 1.4.43 -> 1.4.45
(From OE-Core rev: 94fc70a60a26c1bc402e0e410ab1992d3d9effb4) Signed-off-by: Andrej Valek <andrej.valek@siemens.com> Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lighttpd/lighttpd_1.4.45.bb')
-rw-r--r--meta/recipes-extended/lighttpd/lighttpd_1.4.45.bb84
1 files changed, 84 insertions, 0 deletions
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.45.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.45.bb
new file mode 100644
index 0000000000..c82d93b8a2
--- /dev/null
+++ b/meta/recipes-extended/lighttpd/lighttpd_1.4.45.bb
@@ -0,0 +1,84 @@
1SUMMARY = "Lightweight high-performance web server"
2HOMEPAGE = "http://www.lighttpd.net/"
3BUGTRACKER = "http://redmine.lighttpd.net/projects/lighttpd/issues"
4
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579"
7
8SECTION = "net"
9RDEPENDS_${PN} = "lighttpd-module-dirlisting \
10 lighttpd-module-indexfile \
11 lighttpd-module-staticfile"
12RRECOMMENDS_${PN} = "lighttpd-module-access \
13 lighttpd-module-accesslog"
14
15SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.tar.xz \
16 file://index.html.lighttpd \
17 file://lighttpd.conf \
18 file://lighttpd \
19 file://lighttpd.service \
20 file://0001-Use-pkg-config-for-pcre-dependency-instead-of-config.patch \
21 "
22
23SRC_URI[md5sum] = "a128e1eda76899ce3fd115efae5fe631"
24SRC_URI[sha256sum] = "1c97225deea33eefba6d4158c2cef27913d47553263516bbe9d2e2760fc43a3f"
25
26PACKAGECONFIG ??= "openssl pcre zlib \
27 ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \
28 ${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'lfs', '', d)} \
29 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
30"
31PACKAGECONFIG[lfs] = "--enable-lfs,--disable-lfs"
32PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6"
33PACKAGECONFIG[mmap] = "--enable-mmap,--disable-mmap"
34PACKAGECONFIG[libev] = "--with-libev,--without-libev,libev"
35PACKAGECONFIG[mysql] = "--with-mysql,--without-mysql,mariadb"
36PACKAGECONFIG[ldap] = "--with-ldap,--without-ldap,openldap"
37PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
38PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
39PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl"
40PACKAGECONFIG[krb5] = "--with-krb5,--without-krb5,krb5"
41PACKAGECONFIG[pcre] = "--with-pcre,--without-pcre,libpcre"
42PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
43PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2"
44PACKAGECONFIG[fam] = "--with-fam,--without-fam,gamin"
45PACKAGECONFIG[webdav-props] = "--with-webdav-props,--without-webdav-props,libxml2 sqlite3"
46PACKAGECONFIG[webdav-locks] = "--with-webdav-locks,--without-webdav-locks,util-linux"
47PACKAGECONFIG[gdbm] = "--with-gdbm,--without-gdbm,gdbm"
48PACKAGECONFIG[memcache] = "--with-memcached,--without-memcached,libmemcached"
49PACKAGECONFIG[lua] = "--with-lua,--without-lua,lua5.1"
50
51inherit autotools pkgconfig update-rc.d gettext systemd
52
53INITSCRIPT_NAME = "lighttpd"
54INITSCRIPT_PARAMS = "defaults 70"
55
56SYSTEMD_SERVICE_${PN} = "lighttpd.service"
57
58do_install_append() {
59 install -d ${D}${sysconfdir}/init.d ${D}${sysconfdir}/lighttpd.d ${D}/www/pages/dav
60 install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
61 install -m 0644 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
62 install -m 0644 ${WORKDIR}/index.html.lighttpd ${D}/www/pages/index.html
63
64 install -d ${D}${systemd_unitdir}/system
65 install -m 0644 ${WORKDIR}/lighttpd.service ${D}${systemd_unitdir}/system
66 sed -i -e 's,@SBINDIR@,${sbindir},g' \
67 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
68 -e 's,@BASE_BINDIR@,${base_bindir},g' \
69 ${D}${systemd_unitdir}/system/lighttpd.service
70 #For FHS compliance, create symbolic links to /var/log and /var/tmp for logs and temporary data
71 ln -sf ${localstatedir}/log ${D}/www/logs
72 ln -sf ${localstatedir}/tmp ${D}/www/var
73}
74
75FILES_${PN} += "${sysconfdir} /www"
76
77CONFFILES_${PN} = "${sysconfdir}/lighttpd.conf"
78
79PACKAGES_DYNAMIC += "^lighttpd-module-.*"
80
81python populate_packages_prepend () {
82 lighttpd_libdir = d.expand('${libdir}')
83 do_split_packages(d, lighttpd_libdir, '^mod_(.*)\.so$', 'lighttpd-module-%s', 'Lighttpd module for %s', extra_depends='')
84}