summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lighttpd/lighttpd_1.4.41.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-08-29 17:30:17 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-03 09:58:38 +0100
commit7bb190728788116533a27594e29c2355c8cf364c (patch)
tree292946bc6c267c03959623cfce52f6ed09a53925 /meta/recipes-extended/lighttpd/lighttpd_1.4.41.bb
parent16fae9fffe203cb67e965e2688be2c21b74dbfdd (diff)
downloadpoky-7bb190728788116533a27594e29c2355c8cf364c.tar.gz
lighttpd: update to 1.4.41
Rebase pkgconfig.patch (From OE-Core rev: 45fac4161cb230bc03c6c08d21cc768e52700f02) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lighttpd/lighttpd_1.4.41.bb')
-rw-r--r--meta/recipes-extended/lighttpd/lighttpd_1.4.41.bb76
1 files changed, 76 insertions, 0 deletions
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.41.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.41.bb
new file mode 100644
index 0000000000..a74d3a15b7
--- /dev/null
+++ b/meta/recipes-extended/lighttpd/lighttpd_1.4.41.bb
@@ -0,0 +1,76 @@
1SUMMARY = "Lightweight high-performance web server"
2HOMEPAGE = "http://www.lighttpd.net/"
3BUGTRACKER = "http://redmine.lighttpd.net/projects/lighttpd/issues"
4
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579"
7
8SECTION = "net"
9DEPENDS = "zlib libpcre"
10RDEPENDS_${PN} += " \
11 lighttpd-module-access \
12 lighttpd-module-accesslog \
13 lighttpd-module-indexfile \
14 lighttpd-module-dirlisting \
15 lighttpd-module-staticfile \
16"
17
18SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.tar.xz \
19 file://index.html.lighttpd \
20 file://lighttpd.conf \
21 file://lighttpd \
22 file://lighttpd.service \
23 file://0001-Use-pkg-config-for-pcre-dependency-instead-of-config.patch \
24 "
25
26SRC_URI[md5sum] = "1df2e4dbc965cfe6f99f008ac3db4d8d"
27SRC_URI[sha256sum] = "4bcc383ef6d6dc7b284f68882d71a178e2986c83c4e85eeb3c8f3b882e346b6c"
28
29PACKAGECONFIG ??= "openssl"
30PACKAGECONFIG[openssl] = "--with-openssl, --without-openssl, openssl"
31
32EXTRA_OECONF = " \
33 --without-bzip2 \
34 --without-ldap \
35 --without-lua \
36 --without-memcache \
37 --with-pcre \
38 --without-webdav-props \
39 --without-webdav-locks \
40 --disable-static \
41"
42
43inherit autotools pkgconfig update-rc.d gettext systemd
44
45INITSCRIPT_NAME = "lighttpd"
46INITSCRIPT_PARAMS = "defaults 70"
47
48SYSTEMD_SERVICE_${PN} = "lighttpd.service"
49
50do_install_append() {
51 install -d ${D}${sysconfdir}/init.d ${D}${sysconfdir}/lighttpd.d ${D}/www/pages/dav
52 install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
53 install -m 0644 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
54 install -m 0644 ${WORKDIR}/index.html.lighttpd ${D}/www/pages/index.html
55
56 install -d ${D}${systemd_unitdir}/system
57 install -m 0644 ${WORKDIR}/lighttpd.service ${D}${systemd_unitdir}/system
58 sed -i -e 's,@SBINDIR@,${sbindir},g' \
59 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
60 -e 's,@BASE_BINDIR@,${base_bindir},g' \
61 ${D}${systemd_unitdir}/system/lighttpd.service
62 #For FHS compliance, create symbolic links to /var/log and /var/tmp for logs and temporary data
63 ln -sf ${localstatedir}/log ${D}/www/logs
64 ln -sf ${localstatedir}/tmp ${D}/www/var
65}
66
67FILES_${PN} += "${sysconfdir} /www"
68
69CONFFILES_${PN} = "${sysconfdir}/lighttpd.conf"
70
71PACKAGES_DYNAMIC += "^lighttpd-module-.*"
72
73python populate_packages_prepend () {
74 lighttpd_libdir = d.expand('${libdir}')
75 do_split_packages(d, lighttpd_libdir, '^mod_(.*)\.so$', 'lighttpd-module-%s', 'Lighttpd module for %s', extra_depends='')
76}