diff options
author | Kai Kang <kai.kang@windriver.com> | 2015-07-28 17:38:10 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2015-07-31 10:32:38 +0100 |
commit | 7635f09bf2c425b2e5a360b357c008ef4b170d1e (patch) | |
tree | bccaa34f0404e3c728a1de7f20212487f63a6c3e /meta/recipes-extended/lighttpd/lighttpd_1.4.36.bb | |
parent | 96433ee2c09d6e7ea03954b51dfa5bb5cbdf279e (diff) | |
download | poky-7635f09bf2c425b2e5a360b357c008ef4b170d1e.tar.gz |
lighttpd: 1.4.35 -> 1.4.36
Upgrade lighttpd from 1.4.35 to 1.4.36.
* Remove PR
* Update context of 0001-mod_cgi-buffers-data-without-bound.patch
(From OE-Core rev: 082e54077a88a6104226bc7a2068ea6c10ea1f99)
Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lighttpd/lighttpd_1.4.36.bb')
-rw-r--r-- | meta/recipes-extended/lighttpd/lighttpd_1.4.36.bb | 77 |
1 files changed, 77 insertions, 0 deletions
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.36.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.36.bb new file mode 100644 index 0000000000..67b6e3749b --- /dev/null +++ b/meta/recipes-extended/lighttpd/lighttpd_1.4.36.bb | |||
@@ -0,0 +1,77 @@ | |||
1 | SUMMARY = "Lightweight high-performance web server" | ||
2 | HOMEPAGE = "http://www.lighttpd.net/" | ||
3 | BUGTRACKER = "http://redmine.lighttpd.net/projects/lighttpd/issues" | ||
4 | |||
5 | LICENSE = "BSD" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579" | ||
7 | |||
8 | SECTION = "net" | ||
9 | DEPENDS = "zlib libpcre" | ||
10 | RDEPENDS_${PN} += " \ | ||
11 | lighttpd-module-access \ | ||
12 | lighttpd-module-accesslog \ | ||
13 | lighttpd-module-indexfile \ | ||
14 | lighttpd-module-dirlisting \ | ||
15 | lighttpd-module-staticfile \ | ||
16 | " | ||
17 | |||
18 | SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.tar.xz \ | ||
19 | file://index.html.lighttpd \ | ||
20 | file://lighttpd.conf \ | ||
21 | file://lighttpd \ | ||
22 | file://lighttpd.service \ | ||
23 | file://pkgconfig.patch \ | ||
24 | file://0001-mod_cgi-buffers-data-without-bound.patch \ | ||
25 | " | ||
26 | |||
27 | SRC_URI[md5sum] = "1843daffcb018aa528f6d15d43544654" | ||
28 | SRC_URI[sha256sum] = "897ab6b1cc7bd51671f8af759e7846245fbbca0685c30017e93a5882a9ac1a53" | ||
29 | |||
30 | PACKAGECONFIG ??= "openssl" | ||
31 | PACKAGECONFIG[openssl] = "--with-openssl, --without-openssl, openssl" | ||
32 | |||
33 | EXTRA_OECONF = " \ | ||
34 | --without-bzip2 \ | ||
35 | --without-ldap \ | ||
36 | --without-lua \ | ||
37 | --without-memcache \ | ||
38 | --with-pcre \ | ||
39 | --without-webdav-props \ | ||
40 | --without-webdav-locks \ | ||
41 | --disable-static \ | ||
42 | " | ||
43 | |||
44 | inherit autotools pkgconfig update-rc.d gettext systemd | ||
45 | |||
46 | INITSCRIPT_NAME = "lighttpd" | ||
47 | INITSCRIPT_PARAMS = "defaults 70" | ||
48 | |||
49 | SYSTEMD_SERVICE_${PN} = "lighttpd.service" | ||
50 | |||
51 | do_install_append() { | ||
52 | install -d ${D}${sysconfdir}/init.d ${D}${sysconfdir}/lighttpd.d ${D}/www/pages/dav | ||
53 | install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d | ||
54 | install -m 0644 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir} | ||
55 | install -m 0644 ${WORKDIR}/index.html.lighttpd ${D}/www/pages/index.html | ||
56 | |||
57 | install -d ${D}${systemd_unitdir}/system | ||
58 | install -m 0644 ${WORKDIR}/lighttpd.service ${D}${systemd_unitdir}/system | ||
59 | sed -i -e 's,@SBINDIR@,${sbindir},g' \ | ||
60 | -e 's,@SYSCONFDIR@,${sysconfdir},g' \ | ||
61 | -e 's,@BASE_BINDIR@,${base_bindir},g' \ | ||
62 | ${D}${systemd_unitdir}/system/lighttpd.service | ||
63 | #For FHS compliance, create symbolic links to /var/log and /var/tmp for logs and temporary data | ||
64 | ln -sf ${localstatedir}/log ${D}/www/logs | ||
65 | ln -sf ${localstatedir}/tmp ${D}/www/var | ||
66 | } | ||
67 | |||
68 | FILES_${PN} += "${sysconfdir} /www" | ||
69 | |||
70 | CONFFILES_${PN} = "${sysconfdir}/lighttpd.conf" | ||
71 | |||
72 | PACKAGES_DYNAMIC += "^lighttpd-module-.*" | ||
73 | |||
74 | python populate_packages_prepend () { | ||
75 | lighttpd_libdir = d.expand('${libdir}') | ||
76 | do_split_packages(d, lighttpd_libdir, '^mod_(.*)\.so$', 'lighttpd-module-%s', 'Lighttpd module for %s', extra_depends='') | ||
77 | } | ||