summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lighttpd/lighttpd_1.4.32.bb
diff options
context:
space:
mode:
authorConstantin Musca <constantinx.musca@intel.com>2012-12-03 17:11:15 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-06 12:31:10 +0000
commitefedbc4a8af9e8538244f60eaad631e827bc8654 (patch)
treeff37848843bb525ec70d0375654930b544013b31 /meta/recipes-extended/lighttpd/lighttpd_1.4.32.bb
parentbce1cce5990cd064e6eaec859ff5e999bdf0959c (diff)
downloadpoky-efedbc4a8af9e8538244f60eaad631e827bc8654.tar.gz
lighttpd: upgrade to 1.4.32
lighttpd_fix_for_automake-1.12.patch: removed - included in the new version (From OE-Core rev: 6b87ac303c1f7357c9630359614b373082a59506) Signed-off-by: Constantin Musca <constantinx.musca@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lighttpd/lighttpd_1.4.32.bb')
-rw-r--r--meta/recipes-extended/lighttpd/lighttpd_1.4.32.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.32.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.32.bb
new file mode 100644
index 0000000000..df6ce9723d
--- /dev/null
+++ b/meta/recipes-extended/lighttpd/lighttpd_1.4.32.bb
@@ -0,0 +1,63 @@
1DESCRIPTION = "Lightweight high-performance web server"
2HOMEPAGE = "http://www.lighttpd.net/"
3BUGTRACKER = "http://redmine.lighttpd.net/projects/lighttpd/issues"
4
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579"
7
8
9SECTION = "net"
10DEPENDS = "zlib libpcre"
11RDEPENDS_${PN} += " \
12 lighttpd-module-access \
13 lighttpd-module-accesslog \
14 lighttpd-module-indexfile \
15 lighttpd-module-dirlisting \
16 lighttpd-module-staticfile \
17"
18
19PR = "r0"
20
21SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.tar.bz2 \
22 file://index.html.lighttpd \
23 file://lighttpd.conf \
24 file://lighttpd \
25 "
26
27SRC_URI[md5sum] = "8e2d4ae8e918d4de1aeb9842584d170b"
28SRC_URI[sha256sum] = "60691b2dcf3ad2472c06b23d75eb0c164bf48a08a630ed3f308f61319104701f"
29
30EXTRA_OECONF = " \
31 --without-bzip2 \
32 --without-ldap \
33 --without-lua \
34 --without-memcache \
35 --with-pcre \
36 --without-webdav-props \
37 --without-webdav-locks \
38 --without-openssl \
39 --disable-static \
40"
41
42inherit autotools pkgconfig update-rc.d gettext
43
44INITSCRIPT_NAME = "lighttpd"
45INITSCRIPT_PARAMS = "defaults 70"
46
47do_install_append() {
48 install -d ${D}${sysconfdir}/init.d ${D}/www/logs ${D}/www/pages/dav ${D}/www/var
49 install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
50 install -m 0755 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
51 install -m 0644 ${WORKDIR}/index.html.lighttpd ${D}/www/pages/index.html
52}
53
54FILES_${PN} += "${sysconfdir} /www"
55
56CONFFILES_${PN} = "${sysconfdir}/lighttpd.conf"
57
58PACKAGES_DYNAMIC += "^lighttpd-module-.*"
59
60python populate_packages_prepend () {
61 lighttpd_libdir = d.expand('${libdir}')
62 do_split_packages(d, lighttpd_libdir, '^mod_(.*)\.so$', 'lighttpd-module-%s', 'Lighttpd module for %s', extra_depends='')
63}