summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lighttpd/lighttpd_1.4.30.bb
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2011-12-30 09:53:00 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-03 12:14:38 +0000
commite3928c590c1c870ef52672f56d5188a60747a8c2 (patch)
tree49c24df4abe9c495081127ceabc1b21172d33c4e /meta/recipes-extended/lighttpd/lighttpd_1.4.30.bb
parent8a21b1de584e5e877dad67ebcc387184a850b9a4 (diff)
downloadpoky-e3928c590c1c870ef52672f56d5188a60747a8c2.tar.gz
lighttpd: Upgrade to 1.4.30
(From OE-Core rev: 26d2c86babf13d594d7e735c7bf15196d33605de) Signed-off-by: Zhai Edwin <edwin.zhai@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lighttpd/lighttpd_1.4.30.bb')
-rw-r--r--meta/recipes-extended/lighttpd/lighttpd_1.4.30.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.30.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.30.bb
new file mode 100644
index 0000000000..2c247f0531
--- /dev/null
+++ b/meta/recipes-extended/lighttpd/lighttpd_1.4.30.bb
@@ -0,0 +1,63 @@
1DESCRIPTION = "Lightweight high-performance web server"
2HOMEPAGE = "http://www.lighttpd.net/"
3BUGTRACKER = "http://redmine.lighttpd.net/projects/lighttpd/issues"
4
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579"
7
8
9SECTION = "net"
10DEPENDS = "zlib libpcre"
11RDEPENDS_${PN} += " \
12 lighttpd-module-access \
13 lighttpd-module-accesslog \
14 lighttpd-module-indexfile \
15 lighttpd-module-dirlisting \
16 lighttpd-module-staticfile \
17"
18
19PR = "r0"
20
21SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.tar.bz2 \
22 file://index.html.lighttpd \
23 file://lighttpd.conf \
24 file://lighttpd \
25"
26
27SRC_URI[md5sum] = "63f9df52dcae0ab5689a95c99c54e48a"
28SRC_URI[sha256sum] = "0d795597e4666dbf6ffe44b4a42f388ddb44736ddfab0b1ac091e5bb35212c2d"
29
30EXTRA_OECONF = " \
31 --without-bzip2 \
32 --without-ldap \
33 --without-lua \
34 --without-memcache \
35 --with-pcre \
36 --without-webdav-props \
37 --without-webdav-locks \
38 --without-openssl \
39 --disable-static \
40"
41
42inherit autotools pkgconfig update-rc.d gettext
43
44INITSCRIPT_NAME = "lighttpd"
45INITSCRIPT_PARAMS = "defaults 70"
46
47do_install_append() {
48 install -d ${D}${sysconfdir}/init.d ${D}/www/logs ${D}/www/pages/dav ${D}/www/var
49 install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
50 install -m 0755 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
51 install -m 0644 ${WORKDIR}/index.html.lighttpd ${D}/www/pages/index.html
52}
53
54FILES_${PN} += "${sysconfdir} /www"
55
56CONFFILES_${PN} = "${sysconfdir}/lighttpd.conf"
57
58PACKAGES_DYNAMIC = "lighttpd-module-*"
59
60python populate_packages_prepend () {
61 lighttpd_libdir = bb.data.expand('${libdir}', d)
62 do_split_packages(d, lighttpd_libdir, '^mod_(.*)\.so$', 'lighttpd-module-%s', 'Lighttpd module for %s', extra_depends='')
63}