summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lighttpd/lighttpd_1.4.29.bb
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2011-07-27 16:11:19 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-04 15:04:32 +0100
commit6d3c2628c5a74c76d9524a2a80bb2b588fd31921 (patch)
tree337228171b76c76c6455fdee97a2b453abd433bb /meta/recipes-extended/lighttpd/lighttpd_1.4.29.bb
parentb77f1f327ba3979559fd3756283cb8c1374fcc17 (diff)
downloadpoky-6d3c2628c5a74c76d9524a2a80bb2b588fd31921.tar.gz
lighttpd: Upgrade to 1.4.29
(From OE-Core rev: 765714d2b4dc2b1f6c73c4a8e5fcd0a0c475ad39) Signed-off-by: Zhai Edwin <edwin.zhai@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lighttpd/lighttpd_1.4.29.bb')
-rw-r--r--meta/recipes-extended/lighttpd/lighttpd_1.4.29.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.29.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.29.bb
new file mode 100644
index 0000000000..c1d5f81f62
--- /dev/null
+++ b/meta/recipes-extended/lighttpd/lighttpd_1.4.29.bb
@@ -0,0 +1,63 @@
1DESCRIPTION = "Lightweight high-performance web server"
2HOMEPAGE = "http://www.lighttpd.net/"
3BUGTRACKER = "http://redmine.lighttpd.net/projects/lighttpd/issues"
4
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579"
7
8
9SECTION = "net"
10DEPENDS = "zlib libpcre"
11RDEPENDS_${PN} += " \
12 lighttpd-module-access \
13 lighttpd-module-accesslog \
14 lighttpd-module-indexfile \
15 lighttpd-module-dirlisting \
16 lighttpd-module-staticfile \
17"
18
19PR = "r0"
20
21SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.tar.bz2 \
22 file://index.html \
23 file://lighttpd.conf \
24 file://lighttpd \
25"
26
27SRC_URI[md5sum] = "e6e67b09986cb504db630b5a86b2dd76"
28SRC_URI[sha256sum] = "afd8af213e65afb48b397d004696c6620a7ae7f3d4f162ec46a04b9b9dbfd599"
29
30EXTRA_OECONF = " \
31 --without-bzip2 \
32 --without-ldap \
33 --without-lua \
34 --without-memcache \
35 --with-pcre \
36 --without-webdav-props \
37 --without-webdav-locks \
38 --without-openssl \
39 --disable-static \
40"
41
42inherit autotools pkgconfig update-rc.d gettext
43
44INITSCRIPT_NAME = "lighttpd"
45INITSCRIPT_PARAMS = "defaults 70"
46
47do_install_append() {
48 install -d ${D}${sysconfdir}/init.d ${D}/www/logs ${D}/www/pages/dav ${D}/www/var
49 install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
50 install -m 0755 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
51 install -m 0644 ${WORKDIR}/index.html ${D}/www/pages/
52}
53
54FILES_${PN} += "${sysconfdir} /www"
55
56CONFFILES_${PN} = "${sysconfdir}/lighttpd.conf"
57
58PACKAGES_DYNAMIC = "lighttpd-module-*"
59
60python populate_packages_prepend () {
61 lighttpd_libdir = bb.data.expand('${libdir}', d)
62 do_split_packages(d, lighttpd_libdir, '^mod_(.*)\.so$', 'lighttpd-module-%s', 'Lighttpd module for %s', extra_depends='')
63}