diff options
author | Mark Hatle <mark.hatle@windriver.com> | 2011-08-04 11:33:23 -0500 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-08-05 17:16:02 +0100 |
commit | d6bbdcc030fc6c7720e12d96943031f6b119e69b (patch) | |
tree | bf648281fb8d669a99198938a88738a32c19b611 /meta/recipes-extended/libzypp/libzypp_git.bb | |
parent | be030d3bf5e8bd8be2faf43684f2aafd94545630 (diff) | |
download | poky-d6bbdcc030fc6c7720e12d96943031f6b119e69b.tar.gz |
libzypp: Increase the size of the arch compat table
Fix [YOCTO #1313]
Increase the size of the arch compat table to 30 entries.
Also cleanup a few things related to Poky -> OE name changing.
(From OE-Core rev: 8899c51127fc9df3a054bd38b0b33082fa372fa2)
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Fixed up arm patch
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/libzypp/libzypp_git.bb')
-rw-r--r-- | meta/recipes-extended/libzypp/libzypp_git.bb | 69 |
1 files changed, 35 insertions, 34 deletions
diff --git a/meta/recipes-extended/libzypp/libzypp_git.bb b/meta/recipes-extended/libzypp/libzypp_git.bb index bb36a9069e..1fc6809a35 100644 --- a/meta/recipes-extended/libzypp/libzypp_git.bb +++ b/meta/recipes-extended/libzypp/libzypp_git.bb | |||
@@ -14,16 +14,17 @@ RDEPENDS_${PN} = "sat-solver" | |||
14 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
15 | SRCREV = "15b6c52260bbc52b3d8e585e271b67e10cc7c433" | 15 | SRCREV = "15b6c52260bbc52b3d8e585e271b67e10cc7c433" |
16 | PV = "0.0-git${SRCPV}" | 16 | PV = "0.0-git${SRCPV}" |
17 | PR = "r12" | 17 | PR = "r13" |
18 | 18 | ||
19 | SRC_URI = "git://gitorious.org/opensuse/libzypp.git;protocol=git \ | 19 | SRC_URI = "git://gitorious.org/opensuse/libzypp.git;protocol=git \ |
20 | file://no-doc.patch \ | 20 | file://no-doc.patch \ |
21 | file://rpm5.patch \ | 21 | file://rpm5.patch \ |
22 | file://rpm5-no-rpmdbinit.patch \ | 22 | file://rpm5-no-rpmdbinit.patch \ |
23 | file://config-release.patch \ | 23 | file://config-release.patch \ |
24 | file://libzypp-pokyarch.patch \ | 24 | file://libzypp-oearch.patch \ |
25 | file://libzypp-compatargs.patch \ | ||
25 | file://fix_for_compile_wth_gcc-4.6.0.patch \ | 26 | file://fix_for_compile_wth_gcc-4.6.0.patch \ |
26 | file://hardcode-lib-fix.patch \ | 27 | file://hardcode-lib-fix.patch \ |
27 | " | 28 | " |
28 | 29 | ||
29 | SRC_URI_append_mips = " file://mips-workaround-gcc-tribool-error.patch" | 30 | SRC_URI_append_mips = " file://mips-workaround-gcc-tribool-error.patch" |
@@ -49,57 +50,57 @@ AVOID_CONSTRUCTOR_mips = "true" | |||
49 | do_archgen () { | 50 | do_archgen () { |
50 | # We need to dynamically generate our arch file based on the machine | 51 | # We need to dynamically generate our arch file based on the machine |
51 | # configuration | 52 | # configuration |
52 | echo "/* Automatically generated by the libzypp recipes */" > zypp/poky-arch.h | 53 | echo "/* Automatically generated by the libzypp recipes */" > zypp/oe-arch.h |
53 | echo "/* Avoid Constructor: ${AVOID_CONSTRUCTOR} */" >> zypp/poky-arch.h | 54 | echo "/* Avoid Constructor: ${AVOID_CONSTRUCTOR} */" >> zypp/oe-arch.h |
54 | echo "" >> zypp/poky-arch.h | 55 | echo "" >> zypp/oe-arch.h |
55 | echo "#ifndef POKY_ARCH_H" >> zypp/poky-arch.h | 56 | echo "#ifndef OE_ARCH_H" >> zypp/oe-arch.h |
56 | echo "#define POKY_ARCH_H 1" >> zypp/poky-arch.h | 57 | echo "#define OE_ARCH_H 1" >> zypp/oe-arch.h |
57 | echo "#define Arch_machine Arch_${MACHINE_ARCH}" | tr - _ >> zypp/poky-arch.h | 58 | echo "#define Arch_machine Arch_${MACHINE_ARCH}" | tr - _ >> zypp/oe-arch.h |
58 | echo "#endif /* POKY_ARCH_H */" >> zypp/poky-arch.h | 59 | echo "#endif /* OE_ARCH_H */" >> zypp/oe-arch.h |
59 | echo "" >> zypp/poky-arch.h | 60 | echo "" >> zypp/oe-arch.h |
60 | if [ "${AVOID_CONSTRUCTOR}" != "true" ]; then | 61 | if [ "${AVOID_CONSTRUCTOR}" != "true" ]; then |
61 | echo "#ifdef DEF_BUILTIN" >> zypp/poky-arch.h | 62 | echo "#ifdef DEF_BUILTIN" >> zypp/oe-arch.h |
62 | echo "/* Specify builtin types */" >> zypp/poky-arch.h | 63 | echo "/* Specify builtin types */" >> zypp/oe-arch.h |
63 | for each_arch in ${PACKAGE_ARCHS} ; do | 64 | for each_arch in ${PACKAGE_ARCHS} ; do |
64 | case "$each_arch" in | 65 | case "$each_arch" in |
65 | all | any | noarch) | 66 | all | any | noarch) |
66 | continue;; | 67 | continue;; |
67 | esac | 68 | esac |
68 | echo " DEF_BUILTIN( ${each_arch} );" | tr - _ >> zypp/poky-arch.h | 69 | echo " DEF_BUILTIN( ${each_arch} );" | tr - _ >> zypp/oe-arch.h |
69 | done | 70 | done |
70 | echo "#endif /* DEF_BUILTIN */" >> zypp/poky-arch.h | 71 | echo "#endif /* DEF_BUILTIN */" >> zypp/oe-arch.h |
71 | echo "" >> zypp/poky-arch.h | 72 | echo "" >> zypp/oe-arch.h |
72 | fi | 73 | fi |
73 | echo "#ifdef POKY_EXTERN_PROTO" >> zypp/poky-arch.h | 74 | echo "#ifdef OE_EXTERN_PROTO" >> zypp/oe-arch.h |
74 | echo "/* Specify extern prototypes */" >> zypp/poky-arch.h | 75 | echo "/* Specify extern prototypes */" >> zypp/oe-arch.h |
75 | for each_arch in ${PACKAGE_ARCHS} ; do | 76 | for each_arch in ${PACKAGE_ARCHS} ; do |
76 | case "$each_arch" in | 77 | case "$each_arch" in |
77 | all | any | noarch) | 78 | all | any | noarch) |
78 | continue;; | 79 | continue;; |
79 | esac | 80 | esac |
80 | echo " extern const Arch Arch_${each_arch};" | tr - _ >> zypp/poky-arch.h | 81 | echo " extern const Arch Arch_${each_arch};" | tr - _ >> zypp/oe-arch.h |
81 | done | 82 | done |
82 | echo "#endif /* POKY_EXTERN_PROTO */" >> zypp/poky-arch.h | 83 | echo "#endif /* OE_EXTERN_PROTO */" >> zypp/oe-arch.h |
83 | echo "" >> zypp/poky-arch.h | 84 | echo "" >> zypp/oe-arch.h |
84 | echo "#ifdef POKY_PROTO" >> zypp/poky-arch.h | 85 | echo "#ifdef OE_PROTO" >> zypp/oe-arch.h |
85 | echo "/* Specify prototypes */" >> zypp/poky-arch.h | 86 | echo "/* Specify prototypes */" >> zypp/oe-arch.h |
86 | for each_arch in ${PACKAGE_ARCHS} ; do | 87 | for each_arch in ${PACKAGE_ARCHS} ; do |
87 | case "$each_arch" in | 88 | case "$each_arch" in |
88 | all | any | noarch) | 89 | all | any | noarch) |
89 | continue;; | 90 | continue;; |
90 | esac | 91 | esac |
91 | if [ "${AVOID_CONSTRUCTOR}" != "true" ]; then | 92 | if [ "${AVOID_CONSTRUCTOR}" != "true" ]; then |
92 | echo -n " const Arch Arch_${each_arch} " | tr - _ >> zypp/poky-arch.h | 93 | echo -n " const Arch Arch_${each_arch} " | tr - _ >> zypp/oe-arch.h |
93 | echo "(_${each_arch});" >> zypp/poky-arch.h | 94 | echo "(_${each_arch});" >> zypp/oe-arch.h |
94 | else | 95 | else |
95 | echo -n " const Arch Arch_${each_arch} " | tr - _ >> zypp/poky-arch.h | 96 | echo -n " const Arch Arch_${each_arch} " | tr - _ >> zypp/oe-arch.h |
96 | echo "( IdString ( \"${each_arch}\" ) );" >> zypp/poky-arch.h | 97 | echo "( IdString ( \"${each_arch}\" ) );" >> zypp/oe-arch.h |
97 | fi | 98 | fi |
98 | done | 99 | done |
99 | echo "#endif /* POKY_PROTO */" >> zypp/poky-arch.h | 100 | echo "#endif /* OE_PROTO */" >> zypp/oe-arch.h |
100 | echo "" >> zypp/poky-arch.h | 101 | echo "" >> zypp/oe-arch.h |
101 | echo "#ifdef POKY_DEF_COMPAT" >> zypp/poky-arch.h | 102 | echo "#ifdef OE_DEF_COMPAT" >> zypp/oe-arch.h |
102 | echo "/* Specify compatibility information */" >> zypp/poky-arch.h | 103 | echo "/* Specify compatibility information */" >> zypp/oe-arch.h |
103 | INSTALL_PLATFORM_ARCHS="" | 104 | INSTALL_PLATFORM_ARCHS="" |
104 | for each_arch in ${PACKAGE_ARCHS} ; do | 105 | for each_arch in ${PACKAGE_ARCHS} ; do |
105 | INSTALL_PLATFORM_ARCHS="$each_arch $INSTALL_PLATFORM_ARCHS" | 106 | INSTALL_PLATFORM_ARCHS="$each_arch $INSTALL_PLATFORM_ARCHS" |
@@ -134,10 +135,10 @@ do_archgen () { | |||
134 | COMPAT_WITH="${CARCH},${COMPAT} $COMPAT_WITH" | 135 | COMPAT_WITH="${CARCH},${COMPAT} $COMPAT_WITH" |
135 | done | 136 | done |
136 | for each_compat in ${COMPAT_WITH} ; do | 137 | for each_compat in ${COMPAT_WITH} ; do |
137 | echo " defCompatibleWith( ${each_compat} );" >> zypp/poky-arch.h | 138 | echo " defCompatibleWith( ${each_compat} );" >> zypp/oe-arch.h |
138 | done | 139 | done |
139 | echo "#endif /* DEF_COMPAT */" >> zypp/poky-arch.h | 140 | echo "#endif /* DEF_COMPAT */" >> zypp/oe-arch.h |
140 | echo "" >> zypp/poky-arch.h | 141 | echo "" >> zypp/oe-arch.h |
141 | } | 142 | } |
142 | 143 | ||
143 | addtask archgen before do_configure after do_patch | 144 | addtask archgen before do_configure after do_patch |