summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libnsl/libnsl2_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-05-21 22:00:29 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-25 23:59:32 +0100
commitd06896acf147f2a30a6943e394e588e128a5809f (patch)
tree776762291504a42c507db173aeca98a87b04d083 /meta/recipes-extended/libnsl/libnsl2_git.bb
parent80c00910b8b250ad67e6eb3941d0c8fe56c0fe3f (diff)
downloadpoky-d06896acf147f2a30a6943e394e588e128a5809f.tar.gz
libnsl2: Add recipe
NIS functionality has been split out into independent library from glibc (From OE-Core rev: b73de31cbf58efb303006125f8cd22f130e21d8c) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/libnsl/libnsl2_git.bb')
-rw-r--r--meta/recipes-extended/libnsl/libnsl2_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-extended/libnsl/libnsl2_git.bb b/meta/recipes-extended/libnsl/libnsl2_git.bb
new file mode 100644
index 0000000000..1698f69edb
--- /dev/null
+++ b/meta/recipes-extended/libnsl/libnsl2_git.bb
@@ -0,0 +1,35 @@
1# Copyright (C) 2017 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Library containing NIS functions using TI-RPC (IPv6 enabled)"
5DESCRIPTION = "This library contains the public client interface for NIS(YP) and NIS+\
6 it was part of glibc and now is standalone packages. it also supports IPv6"
7HOMEPAGE = "https://github.com/thkukuk/libnsl"
8LICENSE = "LGPL-2.1"
9LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
10SECTION = "libs"
11DEPENDS = "libtirpc"
12DEPENDS_append_libc-musl = " bsd-headers"
13
14PV = "1.0.5+git${SRCPV}"
15
16SRCREV = "dfa2f313524aff9243c4d8ce1bace73786478356"
17
18SRC_URI = "git://github.com/thkukuk/libnsl \
19 file://0001-include-sys-cdefs.h-explicitly.patch \
20 file://0002-Define-glibc-specific-macros.patch \
21 "
22
23S = "${WORKDIR}/git"
24
25inherit autotools pkgconfig gettext
26
27EXTRA_OECONF += "--libdir=${libdir}/nsl --includedir=${includedir}/nsl"
28
29do_install_append() {
30 install -d ${D}${libdir}
31 mv ${D}${libdir}/nsl/pkgconfig ${D}${libdir}
32}
33
34FILES_${PN} += "${libdir}/nsl/*.so.*"
35FILES_${PN}-dev += "${includedir}/nsl ${libdir}/nsl/*.so"