summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libarchive/libarchive_3.3.3.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-09-16 18:16:23 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-21 18:45:46 -0700
commit4622cc08bfd1f195c17b153cc5ff40e939850434 (patch)
treef8f8cd014c6bca52c70927aad11eb3e370a4e5a4 /meta/recipes-extended/libarchive/libarchive_3.3.3.bb
parent611e090acc76761fbb6c6629f350bacd34705e51 (diff)
downloadpoky-4622cc08bfd1f195c17b153cc5ff40e939850434.tar.gz
libarchive: Update 3.3.2 -> 3.3.3
This upgrades to 3.3.3 release and drop the backported patches when doing the recipe update. (From OE-Core rev: 60d99a4e64fdddbbe5863fa5879c813fa004600b) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/libarchive/libarchive_3.3.3.bb')
-rw-r--r--meta/recipes-extended/libarchive/libarchive_3.3.3.bb68
1 files changed, 68 insertions, 0 deletions
diff --git a/meta/recipes-extended/libarchive/libarchive_3.3.3.bb b/meta/recipes-extended/libarchive/libarchive_3.3.3.bb
new file mode 100644
index 0000000000..eabab16770
--- /dev/null
+++ b/meta/recipes-extended/libarchive/libarchive_3.3.3.bb
@@ -0,0 +1,68 @@
1SUMMARY = "Support for reading various archive formats"
2DESCRIPTION = "C library and command-line tools for reading and writing tar, cpio, zip, ISO, and other archive formats"
3HOMEPAGE = "http://www.libarchive.org/"
4SECTION = "devel"
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=ed99aca006bc346974bb745a35336425"
7
8DEPENDS = "e2fsprogs-native"
9
10PACKAGECONFIG ?= "zlib bz2 xz lzo"
11
12PACKAGECONFIG_append_class-target = "\
13 libxml2 \
14 ${@bb.utils.filter('DISTRO_FEATURES', 'acl xattr', d)} \
15"
16
17DEPENDS_BZIP2 = "bzip2-replacement-native"
18DEPENDS_BZIP2_class-target = "bzip2"
19
20PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
21PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"
22PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib,"
23PACKAGECONFIG[bz2] = "--with-bz2lib,--without-bz2lib,${DEPENDS_BZIP2},"
24PACKAGECONFIG[xz] = "--with-lzma,--without-lzma,xz,"
25PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl,"
26PACKAGECONFIG[libxml2] = "--with-xml2,--without-xml2,libxml2,"
27PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat,"
28PACKAGECONFIG[lzo] = "--with-lzo2,--without-lzo2,lzo,"
29PACKAGECONFIG[nettle] = "--with-nettle,--without-nettle,nettle,"
30PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4,"
31
32EXTRA_OECONF += "--enable-largefile"
33
34SRC_URI = "http://libarchive.org/downloads/libarchive-${PV}.tar.gz \
35 file://non-recursive-extract-and-list.patch \
36"
37
38SRC_URI[md5sum] = "4038e366ca5b659dae3efcc744e72120"
39SRC_URI[sha256sum] = "ba7eb1781c9fbbae178c4c6bad1c6eb08edab9a1496c64833d1715d022b30e2e"
40
41inherit autotools update-alternatives pkgconfig
42
43CPPFLAGS += "-I${WORKDIR}/extra-includes"
44
45do_configure[cleandirs] += "${WORKDIR}/extra-includes"
46do_configure_prepend() {
47 # We just need the headers for some type constants, so no need to
48 # build all of e2fsprogs for the target
49 cp -R ${STAGING_INCDIR_NATIVE}/ext2fs ${WORKDIR}/extra-includes/
50}
51
52ALTERNATIVE_PRIORITY = "80"
53
54PACKAGES =+ "bsdtar"
55FILES_bsdtar = "${bindir}/bsdtar"
56
57ALTERNATIVE_bsdtar = "tar"
58ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
59ALTERNATIVE_TARGET[tar] = "${bindir}/bsdtar"
60
61PACKAGES =+ "bsdcpio"
62FILES_bsdcpio = "${bindir}/bsdcpio"
63
64ALTERNATIVE_bsdcpio = "cpio"
65ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio"
66ALTERNATIVE_TARGET[cpio] = "${bindir}/bsdcpio"
67
68BBCLASSEXTEND = "native nativesdk"