diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2014-06-05 10:46:16 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2014-06-06 09:26:05 +0100 |
commit | f0b9a7cf9f80be1917e45266fa201f464a28c1e5 (patch) | |
tree | f3e4c257c4592551ae5168ed66fdf073eabc3640 /meta/recipes-extended/libarchive/libarchive_3.1.2.bb | |
parent | 7c0aa8fd809c9633b21fbae88e556190263586a2 (diff) | |
download | poky-f0b9a7cf9f80be1917e45266fa201f464a28c1e5.tar.gz |
libarchive: avoid dependency on e2fsprogs
libarchive's configure script looks for ext2fs/ext2_fs.h in order to use
some defines for file attributes support if present (but doesn't link to
any additional libraries.) There is no configure option to disable this,
and if e2fsprogs is rebuilding between do_configure and do_compile you
can currently get a failure. Because it doesn't need anything else from
e2fsprogs, and e2fsprogs isn't currently buildable for nativesdk anyway,
copy the headers in from e2fsprogs-native which we're likely to have
built already (and add it to DEPENDS just to be sure we have.)
Fixes [YOCTO #6268].
(From OE-Core rev: ad754e46ad477acfbe7543187a5c38bc333b8612)
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/libarchive/libarchive_3.1.2.bb')
-rw-r--r-- | meta/recipes-extended/libarchive/libarchive_3.1.2.bb | 11 |
1 files changed, 11 insertions, 0 deletions
diff --git a/meta/recipes-extended/libarchive/libarchive_3.1.2.bb b/meta/recipes-extended/libarchive/libarchive_3.1.2.bb index 3e6cdb4a53..2a2d0f90f9 100644 --- a/meta/recipes-extended/libarchive/libarchive_3.1.2.bb +++ b/meta/recipes-extended/libarchive/libarchive_3.1.2.bb | |||
@@ -5,6 +5,8 @@ SECTION = "devel" | |||
5 | LICENSE = "BSD" | 5 | LICENSE = "BSD" |
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b4e3ffd607d6686c6cb2f63394370841" | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b4e3ffd607d6686c6cb2f63394370841" |
7 | 7 | ||
8 | DEPENDS = "e2fsprogs-native" | ||
9 | |||
8 | PACKAGECONFIG ?= "libxml2 zlib bz2" | 10 | PACKAGECONFIG ?= "libxml2 zlib bz2" |
9 | 11 | ||
10 | PACKAGECONFIG_append_class-target = "\ | 12 | PACKAGECONFIG_append_class-target = "\ |
@@ -36,4 +38,13 @@ SRC_URI[sha256sum] = "eb87eacd8fe49e8d90c8fdc189813023ccc319c5e752b01fb6ad0cc7b2 | |||
36 | 38 | ||
37 | inherit autotools-brokensep lib_package pkgconfig | 39 | inherit autotools-brokensep lib_package pkgconfig |
38 | 40 | ||
41 | CPPFLAGS += "-I${WORKDIR}/extra-includes" | ||
42 | |||
43 | do_configure[cleandirs] += "${WORKDIR}/extra-includes" | ||
44 | do_configure_prepend() { | ||
45 | # We just need the headers for some type constants, so no need to | ||
46 | # build all of e2fsprogs for the target | ||
47 | cp -R ${STAGING_INCDIR_NATIVE}/ext2fs ${WORKDIR}/extra-includes/ | ||
48 | } | ||
49 | |||
39 | BBCLASSEXTEND = "native nativesdk" | 50 | BBCLASSEXTEND = "native nativesdk" |