summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libarchive/libarchive_3.1.2.bb
diff options
context:
space:
mode:
authorPaul Barker <paul@paulbarker.me.uk>2014-01-06 11:55:14 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-10 15:16:48 +0000
commit8d8bcc4284a9cc3dc84912b38e30afa855bef170 (patch)
tree58c2da1d8d46802a77598c5e30bf7ea73a1b37f7 /meta/recipes-extended/libarchive/libarchive_3.1.2.bb
parent0509a60ba5820bd94e107a244b8a01e6f4776741 (diff)
downloadpoky-8d8bcc4284a9cc3dc84912b38e30afa855bef170.tar.gz
libarchive: Upgrade to v3.1.2
All patches against libarchive in oe-core appear to be merged into the latest release. The license checksum has changed because a couple of referenced files have been renamed but there is no change to the license terms themselves. (From OE-Core rev: f3fd24badd189bbb083dba9397598e1566d1e4be) Signed-off-by: Paul Barker <paul@paulbarker.me.uk> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/libarchive/libarchive_3.1.2.bb')
-rw-r--r--meta/recipes-extended/libarchive/libarchive_3.1.2.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-extended/libarchive/libarchive_3.1.2.bb b/meta/recipes-extended/libarchive/libarchive_3.1.2.bb
new file mode 100644
index 0000000000..ffe0b2e673
--- /dev/null
+++ b/meta/recipes-extended/libarchive/libarchive_3.1.2.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Support for reading various archive formats"
2DESCRIPTION = "C library and command-line tools for reading and writing tar, cpio, zip, ISO, and other archive formats"
3HOMEPAGE = "http://www.libarchive.org/"
4SECTION = "devel"
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b4e3ffd607d6686c6cb2f63394370841"
7
8PACKAGECONFIG ?= "libxml2 zlib bz2"
9
10PACKAGECONFIG_append_class-target = "\
11 ${@base_contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \
12 ${@base_contains('DISTRO_FEATURES', 'xattr', 'xattr', '', d)} \
13 ${@base_contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
14"
15
16PACKAGECONFIG_append_class-nativesdk = " largefile"
17
18PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
19PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"
20PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
21PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib,"
22PACKAGECONFIG[bz2] = "--with-bz2lib,--without-bz2lib,bzip2,"
23PACKAGECONFIG[xz] = "--with-lzmadec --with-lzma,--without-lzmadec --without-lzma,xz,"
24PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl,"
25PACKAGECONFIG[libxml2] = "--with-xml2,--without-xml2,libxml2,"
26PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat,"
27
28SRC_URI = "http://libarchive.org/downloads/libarchive-${PV}.tar.gz \
29 "
30
31SRC_URI[md5sum] = "efad5a503f66329bb9d2f4308b5de98a"
32SRC_URI[sha256sum] = "eb87eacd8fe49e8d90c8fdc189813023ccc319c5e752b01fb6ad0cc7b2c53d5e"
33
34inherit autotools lib_package
35
36BBCLASSEXTEND = "native nativesdk"