summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libaio/libaio_0.3.110.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-11-06 15:30:58 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-14 15:18:28 +0000
commit44639bd817f5f42c364333f741168f3b9a3fb950 (patch)
treeb1356a3ac9c6ec47db4df873f4012f1fc39a00b3 /meta/recipes-extended/libaio/libaio_0.3.110.bb
parenta0be9bd862d039307f8349c66496f409290de075 (diff)
downloadpoky-44639bd817f5f42c364333f741168f3b9a3fb950.tar.gz
libaio: don't disable linking to the system libraries
For some reason that I don't understand (a decade-old attempt at optimisation?) libaio disables linkage to the system libraries. Enabling fortify means linking to the system libraries, so remove the existing addition of -lc for x86 (the problem also happens on at least PPC) and just link to the system libraries on all platforms. Also remove the sed of src/Makefile as the build not respecting LDFLAGS has been fixed upstream. (From OE-Core rev: f435ac9db0581d8313a38d586b00c2b3de419298) (From OE-Core rev: 901af5a00338fd8f1ace939123484ea91c090a7a) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/libaio/libaio_0.3.110.bb')
-rw-r--r--meta/recipes-extended/libaio/libaio_0.3.110.bb9
1 files changed, 2 insertions, 7 deletions
diff --git a/meta/recipes-extended/libaio/libaio_0.3.110.bb b/meta/recipes-extended/libaio/libaio_0.3.110.bb
index cbe29ce2ab..2adfa0aa4c 100644
--- a/meta/recipes-extended/libaio/libaio_0.3.110.bb
+++ b/meta/recipes-extended/libaio/libaio_0.3.110.bb
@@ -11,18 +11,13 @@ SRC_URI = "${DEBIAN_MIRROR}/main/liba/libaio/libaio_${PV}.orig.tar.gz \
11 file://destdir.patch \ 11 file://destdir.patch \
12 file://libaio_fix_for_x32.patch \ 12 file://libaio_fix_for_x32.patch \
13 file://libaio_fix_for_mips_syscalls.patch \ 13 file://libaio_fix_for_mips_syscalls.patch \
14" 14 file://system-linkage.patch \
15 "
15 16
16SRC_URI[md5sum] = "2a35602e43778383e2f4907a4ca39ab8" 17SRC_URI[md5sum] = "2a35602e43778383e2f4907a4ca39ab8"
17SRC_URI[sha256sum] = "e019028e631725729376250e32b473012f7cb68e1f7275bfc1bbcdd0f8745f7e" 18SRC_URI[sha256sum] = "e019028e631725729376250e32b473012f7cb68e1f7275bfc1bbcdd0f8745f7e"
18 19
19EXTRA_OEMAKE =+ "prefix=${prefix} includedir=${includedir} libdir=${libdir}" 20EXTRA_OEMAKE =+ "prefix=${prefix} includedir=${includedir} libdir=${libdir}"
20# Need libc for stack-protector's __stack_chk_fail_local() bounce function
21LDFLAGS_append_x86 = " -lc"
22
23do_configure () {
24 sed -i 's#LINK_FLAGS=.*#LINK_FLAGS=$(LDFLAGS)#' src/Makefile
25}
26 21
27do_install () { 22do_install () {
28 oe_runmake install DESTDIR=${D} 23 oe_runmake install DESTDIR=${D}