summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/iptables/iptables_1.8.7.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-28 23:28:15 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-02 15:44:10 +0100
commitbb6ddc3691ab04162ec5fd69a2d5e7876713fd15 (patch)
tree76e376b01253c3aace1a98a5021bcaad3c92e861 /meta/recipes-extended/iptables/iptables_1.8.7.bb
parentfcc456ee4b8f619134abb4649db53c638074082c (diff)
downloadpoky-bb6ddc3691ab04162ec5fd69a2d5e7876713fd15.tar.gz
Convert to new override syntax
This is the result of automated script conversion: scripts/contrib/convert-overrides.py <oe-core directory> converting the metadata to use ":" as the override character instead of "_". (From OE-Core rev: 42344347be29f0997cc2f7636d9603b1fe1875ae) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/iptables/iptables_1.8.7.bb')
-rw-r--r--meta/recipes-extended/iptables/iptables_1.8.7.bb30
1 files changed, 15 insertions, 15 deletions
diff --git a/meta/recipes-extended/iptables/iptables_1.8.7.bb b/meta/recipes-extended/iptables/iptables_1.8.7.bb
index 621f87ff87..93af96b77d 100644
--- a/meta/recipes-extended/iptables/iptables_1.8.7.bb
+++ b/meta/recipes-extended/iptables/iptables_1.8.7.bb
@@ -18,7 +18,7 @@ SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.bz2 \
18 " 18 "
19SRC_URI[sha256sum] = "c109c96bb04998cd44156622d36f8e04b140701ec60531a10668cfdff5e8d8f0" 19SRC_URI[sha256sum] = "c109c96bb04998cd44156622d36f8e04b140701ec60531a10668cfdff5e8d8f0"
20 20
21SYSTEMD_SERVICE_${PN} = "\ 21SYSTEMD_SERVICE:${PN} = "\
22 iptables.service \ 22 iptables.service \
23 ${@bb.utils.contains('PACKAGECONFIG', 'ipv6', 'ip6tables.service', '', d)} \ 23 ${@bb.utils.contains('PACKAGECONFIG', 'ipv6', 'ip6tables.service', '', d)} \
24" 24"
@@ -36,7 +36,7 @@ PACKAGECONFIG[libnfnetlink] = "--enable-libnfnetlink,--disable-libnfnetlink,libn
36# libnftnl recipe is in meta-networking layer(previously known as libnftables) 36# libnftnl recipe is in meta-networking layer(previously known as libnftables)
37PACKAGECONFIG[libnftnl] = "--enable-nftables,--disable-nftables,libnftnl" 37PACKAGECONFIG[libnftnl] = "--enable-nftables,--disable-nftables,libnftnl"
38 38
39do_configure_prepend() { 39do_configure:prepend() {
40 # Remove some libtool m4 files 40 # Remove some libtool m4 files
41 # Keep ax_check_linker_flags.m4 which belongs to autoconf-archive. 41 # Keep ax_check_linker_flags.m4 which belongs to autoconf-archive.
42 rm -f libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4 42 rm -f libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4
@@ -44,7 +44,7 @@ do_configure_prepend() {
44 44
45IPTABLES_RULES_DIR ?= "${sysconfdir}/${BPN}" 45IPTABLES_RULES_DIR ?= "${sysconfdir}/${BPN}"
46 46
47do_install_append() { 47do_install:append() {
48 install -d ${D}${IPTABLES_RULES_DIR} 48 install -d ${D}${IPTABLES_RULES_DIR}
49 install -m 0644 ${WORKDIR}/iptables.rules ${D}${IPTABLES_RULES_DIR} 49 install -m 0644 ${WORKDIR}/iptables.rules ${D}${IPTABLES_RULES_DIR}
50 50
@@ -70,15 +70,15 @@ do_install_append() {
70PACKAGES =+ "${PN}-modules ${PN}-apply" 70PACKAGES =+ "${PN}-modules ${PN}-apply"
71PACKAGES_DYNAMIC += "^${PN}-module-.*" 71PACKAGES_DYNAMIC += "^${PN}-module-.*"
72 72
73python populate_packages_prepend() { 73python populate_packages:prepend() {
74 modules = do_split_packages(d, '${libdir}/xtables', r'lib(.*)\.so$', '${PN}-module-%s', '${PN} module %s', extra_depends='') 74 modules = do_split_packages(d, '${libdir}/xtables', r'lib(.*)\.so$', '${PN}-module-%s', '${PN} module %s', extra_depends='')
75 if modules: 75 if modules:
76 metapkg = d.getVar('PN') + '-modules' 76 metapkg = d.getVar('PN') + '-modules'
77 d.appendVar('RDEPENDS_' + metapkg, ' ' + ' '.join(modules)) 77 d.appendVar('RDEPENDS:' + metapkg, ' ' + ' '.join(modules))
78} 78}
79 79
80RDEPENDS_${PN} = "${PN}-module-xt-standard" 80RDEPENDS:${PN} = "${PN}-module-xt-standard"
81RRECOMMENDS_${PN} = " \ 81RRECOMMENDS:${PN} = " \
82 ${PN}-modules \ 82 ${PN}-modules \
83 kernel-module-x-tables \ 83 kernel-module-x-tables \
84 kernel-module-ip-tables \ 84 kernel-module-ip-tables \
@@ -95,16 +95,16 @@ RRECOMMENDS_${PN} = " \
95 ', '', d)} \ 95 ', '', d)} \
96" 96"
97 97
98FILES_${PN} += "${datadir}/xtables" 98FILES:${PN} += "${datadir}/xtables"
99 99
100FILES_${PN}-apply = "${sbindir}/ip*-apply" 100FILES:${PN}-apply = "${sbindir}/ip*-apply"
101RDEPENDS_${PN}-apply = "${PN} bash" 101RDEPENDS:${PN}-apply = "${PN} bash"
102 102
103# Include the symlinks as well in respective packages 103# Include the symlinks as well in respective packages
104FILES_${PN}-module-xt-conntrack += "${libdir}/xtables/libxt_state.so" 104FILES:${PN}-module-xt-conntrack += "${libdir}/xtables/libxt_state.so"
105FILES_${PN}-module-xt-ct += "${libdir}/xtables/libxt_NOTRACK.so" 105FILES:${PN}-module-xt-ct += "${libdir}/xtables/libxt_NOTRACK.so"
106 106
107ALLOW_EMPTY_${PN}-modules = "1" 107ALLOW_EMPTY:${PN}-modules = "1"
108 108
109INSANE_SKIP_${PN}-module-xt-conntrack = "dev-so" 109INSANE_SKIP:${PN}-module-xt-conntrack = "dev-so"
110INSANE_SKIP_${PN}-module-xt-ct = "dev-so" 110INSANE_SKIP:${PN}-module-xt-ct = "dev-so"