summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/iptables/iptables_1.6.0.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2015-12-29 15:11:59 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-07 13:40:17 +0000
commit20843fa01618d5591e30b2a0336605ddc1f62a61 (patch)
tree8fb125e1feed2b60fef8398c7b0a41534f45e505 /meta/recipes-extended/iptables/iptables_1.6.0.bb
parentc2bda6c000794b881274de953818e0de6635cc4a (diff)
downloadpoky-20843fa01618d5591e30b2a0336605ddc1f62a61.tar.gz
iptables: upgrade to 1.6.0
1.4.21 -> 1.6.0 xtables_globals structure layout has changed. * Refreshed below listed patches to work with this release: 1. 0001-configure-Add-option-to-enable-disable-libnfnetlink.patch 2. 0001-fix-build-with-musl.patch * Added PACKAGECONFIG for libnftnl (From OE-Core rev: 8609c4e5eadfdd60664640c4ae07e250c98dd86b) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/iptables/iptables_1.6.0.bb')
-rw-r--r--meta/recipes-extended/iptables/iptables_1.6.0.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-extended/iptables/iptables_1.6.0.bb b/meta/recipes-extended/iptables/iptables_1.6.0.bb
new file mode 100644
index 0000000000..fbbe4186b2
--- /dev/null
+++ b/meta/recipes-extended/iptables/iptables_1.6.0.bb
@@ -0,0 +1,50 @@
1SUMMARY = "Tools for managing kernel packet filtering capabilities"
2DESCRIPTION = "iptables is the userspace command line program used to configure and control network packet \
3filtering code in Linux."
4HOMEPAGE = "http://www.netfilter.org/"
5BUGTRACKER = "http://bugzilla.netfilter.org/"
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263\
8 file://iptables/iptables.c;beginline=13;endline=25;md5=c5cffd09974558cf27d0f763df2a12dc"
9
10RRECOMMENDS_${PN} = "kernel-module-x-tables \
11 kernel-module-ip-tables \
12 kernel-module-iptable-filter \
13 kernel-module-iptable-nat \
14 kernel-module-nf-defrag-ipv4 \
15 kernel-module-nf-conntrack \
16 kernel-module-nf-conntrack-ipv4 \
17 kernel-module-nf-nat \
18 kernel-module-ipt-masquerade"
19FILES_${PN} =+ "${libdir}/xtables/ ${datadir}/xtables"
20
21SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.bz2 \
22 file://types.h-add-defines-that-are-required-for-if_packet.patch \
23 file://0001-configure-Add-option-to-enable-disable-libnfnetlink.patch \
24 file://0002-configure.ac-only-check-conntrack-when-libnfnetlink-enabled.patch \
25 "
26SRC_URI_append_libc-musl = " file://0001-fix-build-with-musl.patch"
27
28SRC_URI[md5sum] = "27ba3451cb622467fc9267a176f19a31"
29SRC_URI[sha256sum] = "4bb72a0a0b18b5a9e79e87631ddc4084528e5df236bc7624472dcaa8480f1c60"
30
31inherit autotools pkgconfig
32
33EXTRA_OECONF = "--with-kernel=${STAGING_INCDIR} \
34 "
35PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \
36 "
37
38PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
39
40# libnfnetlink recipe is in meta-networking layer
41PACKAGECONFIG[libnfnetlink] = "--enable-libnfnetlink,--disable-libnfnetlink,libnfnetlink libnetfilter-conntrack"
42
43# libnftnl recipe is in meta-networking layer(previously known as libnftables)
44PACKAGECONFIG[libnftnl] = "--enable-nftables,--disable-nftables,libnftnl"
45
46do_configure_prepend() {
47 # Remove some libtool m4 files
48 # Keep ax_check_linker_flags.m4 which belongs to autoconf-archive.
49 rm -f libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4
50}