summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/iptables/iptables_1.4.19.1.bb
diff options
context:
space:
mode:
authorCristian Iorga <cristian.iorga@intel.com>2013-06-05 15:47:15 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-07 16:48:28 +0100
commitd3e982a6c49e1df631b6326710b216f23dca221c (patch)
treeeb129efb0858154672ae1eaa4d6d7dc6da686b61 /meta/recipes-extended/iptables/iptables_1.4.19.1.bb
parentdfd0985065c3447df169198e8cd518e007f630ff (diff)
downloadpoky-d3e982a6c49e1df631b6326710b216f23dca221c.tar.gz
iptables: upgrade to 1.4.19.1
fix-iptables-extensions-build-error.patch no longer needed. (From OE-Core rev: 02971543527e993b60132ddb101a9093efa3f324) Signed-off-by: Cristian Iorga <cristian.iorga@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/iptables/iptables_1.4.19.1.bb')
-rw-r--r--meta/recipes-extended/iptables/iptables_1.4.19.1.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-extended/iptables/iptables_1.4.19.1.bb b/meta/recipes-extended/iptables/iptables_1.4.19.1.bb
new file mode 100644
index 0000000000..a98ad4c0bb
--- /dev/null
+++ b/meta/recipes-extended/iptables/iptables_1.4.19.1.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Tools for managing kernel packet filtering capabilities"
2DESCRIPTION = "iptables is the userspace command line program used to configure and control network packet \
3filtering code in Linux."
4HOMEPAGE = "http://www.netfilter.org/"
5BUGTRACKER = "http://bugzilla.netfilter.org/"
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263\
8 file://iptables/iptables.c;beginline=13;endline=25;md5=c5cffd09974558cf27d0f763df2a12dc"
9
10RRECOMMENDS_${PN} = "kernel-module-x-tables \
11 kernel-module-ip-tables \
12 kernel-module-iptable-filter \
13 kernel-module-iptable-nat \
14 kernel-module-nf-defrag-ipv4 \
15 kernel-module-nf-conntrack \
16 kernel-module-nf-conntrack-ipv4 \
17 kernel-module-nf-nat \
18 kernel-module-ipt-masquerade"
19FILES_${PN} =+ "${libdir}/xtables/ ${datadir}/xtables"
20FILES_${PN}-dbg =+ "${libdir}/xtables/.debug"
21
22SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.bz2 \
23 file://types.h-add-defines-that-are-required-for-if_packet.patch \
24 file://0001-configure-Add-option-to-enable-disable-libnfnetlink.patch \
25 "
26
27SRC_URI[md5sum] = "be97ce9007fa42c867901b496c935a0a"
28SRC_URI[sha256sum] = "dd51d3b942758a462afc7c8495930d25c93058e5319303247375183ad50164d2"
29
30inherit autotools
31
32EXTRA_OECONF = "--with-kernel=${STAGING_INCDIR} \
33 "
34PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \
35 "
36
37PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
38
39# libnfnetlink recipe is in meta-networking layer
40PACKAGECONFIG[libnfnetlink] = "--enable-libnfnetlink,--disable-libnfnetlink,libnfnetlink"
41
42do_configure_prepend() {
43 # Remove some libtool m4 files
44 # Keep ax_check_linker_flags.m4 which belongs to autoconf-archive.
45 rm -f libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4
46}