summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/hdparm/hdparm_9.51.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2017-02-09 19:23:09 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-15 20:06:43 -0800
commit0a7094152576ec33da91b1278966ca8193ec58e9 (patch)
tree8e76702dc4d51467963a0ebe40fc7ebe07d6d817 /meta/recipes-extended/hdparm/hdparm_9.51.bb
parentb413deab20338b11c2dc9cee47e42b73d5d1d943 (diff)
downloadpoky-0a7094152576ec33da91b1278966ca8193ec58e9.tar.gz
hdparm: 9.50 -> 9.51
(From OE-Core rev: 973f4962c5bca8270eb10e2bb2bb65330ad518bf) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/hdparm/hdparm_9.51.bb')
-rw-r--r--meta/recipes-extended/hdparm/hdparm_9.51.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-extended/hdparm/hdparm_9.51.bb b/meta/recipes-extended/hdparm/hdparm_9.51.bb
new file mode 100644
index 0000000000..fa009278b6
--- /dev/null
+++ b/meta/recipes-extended/hdparm/hdparm_9.51.bb
@@ -0,0 +1,40 @@
1SUMMARY = "Utility for viewing/manipulating IDE disk drive/driver parameters"
2DESCRIPTION = "hdparm is a Linux shell utility for viewing \
3and manipulating various IDE drive and driver parameters."
4SECTION = "console/utils"
5
6LICENSE = "BSD & GPLv2"
7LICENSE_${PN} = "BSD"
8LICENSE_${PN}-dbg = "BSD"
9LICENSE_wiper = "GPLv2"
10
11LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=910a8a42c962d238619c75fdb78bdb24 \
12 file://debian/copyright;md5=a82d7ba3ade9e8ec902749db98c592f3 \
13 file://wiper/GPLv2.txt;md5=fcb02dc552a041dee27e4b85c7396067 \
14 file://wiper/wiper.sh;beginline=7;endline=31;md5=b7bc642addc152ea307505bf1a296f09"
15
16
17PACKAGES =+ "wiper"
18
19FILES_wiper = "${bindir}/wiper.sh"
20
21RDEPENDS_wiper = "bash gawk stat"
22
23SRC_URI = "${SOURCEFORGE_MIRROR}/hdparm/${BP}.tar.gz"
24
25SRC_URI[md5sum] = "8fe0a71db02f7ffc602d14a69f766cff"
26SRC_URI[sha256sum] = "1afad8891ecbe644c283f7d725157660ebf8bd5b4d9d67232afd45f83d2d5d91"
27
28EXTRA_OEMAKE = 'STRIP="echo" LDFLAGS="${LDFLAGS}"'
29
30inherit update-alternatives
31
32ALTERNATIVE_${PN} = "hdparm"
33ALTERNATIVE_LINK_NAME[hdparm] = "${base_sbindir}/hdparm"
34ALTERNATIVE_PRIORITY = "100"
35
36do_install () {
37 install -d ${D}/${base_sbindir} ${D}/${mandir}/man8 ${D}/${bindir}
38 oe_runmake 'DESTDIR=${D}' 'sbindir=${base_sbindir}' install
39 cp ${S}/wiper/wiper.sh ${D}/${bindir}
40}