diff options
author | Mark Hatle <mark.hatle@windriver.com> | 2012-04-16 11:15:35 -0500 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-04-26 10:05:08 +0100 |
commit | 469a4b9d8ad5d6c6a7572bdbbdbbaea4a11c71e4 (patch) | |
tree | e50dc40b0dc40338b13da4c997cebaf2027934d9 /meta/recipes-extended/gzip/gzip_1.3.12.bb | |
parent | 46ffeed9183ec12ff20dbb5c5b46ea35555835d5 (diff) | |
download | poky-469a4b9d8ad5d6c6a7572bdbbdbbaea4a11c71e4.tar.gz |
gzip: Use update-alternatives class
Switch to using the update-alternatives class. Need this for
consistency and to ensure the necessary package provides get set.
(From OE-Core rev: e0626a0270fb0f4ff128e761c13d44162723434c)
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/gzip/gzip_1.3.12.bb')
-rw-r--r-- | meta/recipes-extended/gzip/gzip_1.3.12.bb | 24 |
1 files changed, 8 insertions, 16 deletions
diff --git a/meta/recipes-extended/gzip/gzip_1.3.12.bb b/meta/recipes-extended/gzip/gzip_1.3.12.bb index 2836942f8b..6d18d47cb8 100644 --- a/meta/recipes-extended/gzip/gzip_1.3.12.bb +++ b/meta/recipes-extended/gzip/gzip_1.3.12.bb | |||
@@ -16,29 +16,21 @@ SRC_URI = "${GNU_MIRROR}/gzip/gzip-${PV}.tar.gz \ | |||
16 | SRC_URI[md5sum] = "b5bac2d21840ae077e0217bc5e4845b1" | 16 | SRC_URI[md5sum] = "b5bac2d21840ae077e0217bc5e4845b1" |
17 | SRC_URI[sha256sum] = "3f565be05f7f3d1aff117c030eb7c738300510b7d098cedea796ca8e4cd587af" | 17 | SRC_URI[sha256sum] = "3f565be05f7f3d1aff117c030eb7c738300510b7d098cedea796ca8e4cd587af" |
18 | 18 | ||
19 | PR = "r0" | 19 | PR = "r1" |
20 | 20 | ||
21 | inherit autotools | 21 | inherit autotools |
22 | 22 | ||
23 | do_install () { | 23 | do_install_append () { |
24 | autotools_do_install | ||
25 | # move files into /bin (FHS) | 24 | # move files into /bin (FHS) |
26 | install -d ${D}${base_bindir} | 25 | install -d ${D}${base_bindir} |
27 | mv ${D}${bindir}/gunzip ${D}${base_bindir}/gunzip.${PN} | 26 | mv ${D}${bindir}/gunzip ${D}${base_bindir}/gunzip |
28 | mv ${D}${bindir}/gzip ${D}${base_bindir}/gzip.${PN} | 27 | mv ${D}${bindir}/gzip ${D}${base_bindir}/gzip |
29 | mv ${D}${bindir}/zcat ${D}${base_bindir}/zcat.${PN} | 28 | mv ${D}${bindir}/zcat ${D}${base_bindir}/zcat |
30 | } | 29 | } |
31 | 30 | ||
32 | pkg_postinst_${PN} () { | 31 | inherit update-alternatives |
33 | update-alternatives --install ${base_bindir}/gunzip gunzip gunzip.${PN} 100 | ||
34 | update-alternatives --install ${base_bindir}/gzip gzip gzip.${PN} 100 | ||
35 | update-alternatives --install ${base_bindir}/zcat zcat zcat.${PN} 100 | ||
36 | } | ||
37 | 32 | ||
38 | pkg_prerm_${PN} () { | 33 | ALTERNATIVE_LINKS = "${base_bindir}/gunzip ${base_bindir}/gzip ${base_bindir}/zcat" |
39 | update-alternatives --remove gunzip gunzip.${PN} | 34 | ALTERNATIVE_PRIORITY = "100" |
40 | update-alternatives --remove gzip gzip.${PN} | ||
41 | update-alternatives --remove zcat zcat.${PN} | ||
42 | } | ||
43 | 35 | ||
44 | BBCLASSEXTEND = "native" | 36 | BBCLASSEXTEND = "native" |