diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2019-05-12 16:16:28 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2019-05-12 17:55:11 +0100 |
commit | 66d67b818a7bb172f9ab804f9cb5b8e5b9e577f5 (patch) | |
tree | 58781fb06cfb1889afe8cb1c5951125a35858ed4 /meta/recipes-extended/groff/groff_1.22.4.bb | |
parent | 8e7b9685d2d27511aef2cf1ce51d688337fbd31a (diff) | |
download | poky-66d67b818a7bb172f9ab804f9cb5b8e5b9e577f5.tar.gz |
groff: upgrade 1.22.3 -> 1.22.4
- Drop groff-1.22.2-correct-man.local-install-path.patch and
0001-Unset-need_charset_alias-when-building-for-musl.patch
- Inherit bbclass pkgcnofig to fix `undefined macro: AC_DEFINE'
...
| configure:20010: error: possibly undefined macro: AC_DEFINE
...
- Use autotools-brokensep to replace autotools to workaround failure
caused by out of tree
...
| rm -f lib/alloca.h-t lib/alloca.h && \
| { echo '/* DO NOT EDIT! GENERATED AUTOMATICALLY! */'; \
| cat ../groff-1.22.4/lib/alloca.in.h; \
| } > lib/alloca.h-t && \
| mv -f lib/alloca.h-t lib/alloca.h
| /bin/sh: line 4: lib/alloca.h-t: No such file or directory
| Makefile:10407: recipe for target 'lib/alloca.h' failed
...
- Add `--without-doc' to not use target groff to generate doc at build time,
since upstream commit [cfe916e Support of configure option to build the
documentation.]
- Remove groff depends groff-native, and add DEPENDS bison-native
- Add 0001-fix-shebang-for-taget.patch
- Add 0001-support-musl.patch
(From OE-Core rev: 70c2364cae3aad62877e0267d840ea3567d3d1ea)
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/groff/groff_1.22.4.bb')
-rw-r--r-- | meta/recipes-extended/groff/groff_1.22.4.bb | 65 |
1 files changed, 65 insertions, 0 deletions
diff --git a/meta/recipes-extended/groff/groff_1.22.4.bb b/meta/recipes-extended/groff/groff_1.22.4.bb new file mode 100644 index 0000000000..37eee9a6cc --- /dev/null +++ b/meta/recipes-extended/groff/groff_1.22.4.bb | |||
@@ -0,0 +1,65 @@ | |||
1 | SUMMARY = "GNU Troff software" | ||
2 | DESCRIPTION = "The groff (GNU troff) software is a typesetting package which reads plain text mixed with \ | ||
3 | formatting commands and produces formatted output." | ||
4 | SECTION = "base" | ||
5 | HOMEPAGE = "http://www.gnu.org/software/groff/" | ||
6 | LICENSE = "GPLv3" | ||
7 | |||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
9 | |||
10 | SRC_URI = "${GNU_MIRROR}/groff/groff-${PV}.tar.gz \ | ||
11 | file://0001-replace-perl-w-with-use-warnings.patch \ | ||
12 | file://groff-not-search-fonts-on-build-host.patch \ | ||
13 | file://0001-fix-shebang-for-taget.patch \ | ||
14 | file://0001-support-musl.patch \ | ||
15 | " | ||
16 | |||
17 | SRC_URI[md5sum] = "08fb04335e2f5e73f23ea4c3adbf0c5f" | ||
18 | SRC_URI[sha256sum] = "e78e7b4cb7dec310849004fa88847c44701e8d133b5d4c13057d876c1bad0293" | ||
19 | |||
20 | DEPENDS = "bison-native" | ||
21 | RDEPENDS_${PN} += "perl sed" | ||
22 | |||
23 | inherit autotools-brokensep texinfo multilib_script pkgconfig | ||
24 | |||
25 | MULTILIB_SCRIPTS = "${PN}:${bindir}/gpinyin ${PN}:${bindir}/groffer ${PN}:${bindir}/grog" | ||
26 | |||
27 | EXTRA_OECONF = "--without-x --without-doc" | ||
28 | PARALLEL_MAKE = "" | ||
29 | |||
30 | CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'" | ||
31 | |||
32 | do_install_append() { | ||
33 | # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location | ||
34 | # for target as /usr/bin/perl, so fix it to /usr/bin/perl. | ||
35 | for i in afmtodit mmroff gropdf pdfmom grog; do | ||
36 | if [ -f ${D}${bindir}/$i ]; then | ||
37 | sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/$i | ||
38 | fi | ||
39 | done | ||
40 | if [ -e ${D}${libdir}/charset.alias ]; then | ||
41 | rm -rf ${D}${libdir}/charset.alias | ||
42 | fi | ||
43 | |||
44 | # awk is located at /usr/bin/, not /bin/ | ||
45 | SPECIAL_AWK=`find ${D} -name special.awk` | ||
46 | if [ -f ${SPECIAL_AWK} ]; then | ||
47 | sed -i -e 's:#!.*awk:#! ${USRBINPATH}/awk:' ${SPECIAL_AWK} | ||
48 | fi | ||
49 | |||
50 | # not ship /usr/bin/glilypond and its releated files in embedded target system | ||
51 | rm -rf ${D}${bindir}/glilypond | ||
52 | rm -rf ${D}${libdir}/groff/glilypond | ||
53 | rm -rf ${D}${mandir}/man1/glilypond* | ||
54 | } | ||
55 | |||
56 | do_install_append_class-native() { | ||
57 | create_cmdline_wrapper ${D}/${bindir}/groff \ | ||
58 | -F${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/font \ | ||
59 | -M${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/tmac | ||
60 | } | ||
61 | |||
62 | FILES_${PN} += "${libdir}/${BPN}/site-tmac \ | ||
63 | ${libdir}/${BPN}/groffer/" | ||
64 | |||
65 | BBCLASSEXTEND = "native" | ||