summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/groff/groff_1.22.3.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-04-10 01:31:27 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-13 22:33:18 +0100
commit23a8493408f82859c7d1ac6a1b5cf52dc539d7e8 (patch)
tree1bd1ed83f32e8f429eecf446c1732de9a44fa92b /meta/recipes-extended/groff/groff_1.22.3.bb
parent84e8b1ba296c92ec00cfc5b5077ee253c4ed65ab (diff)
downloadpoky-23a8493408f82859c7d1ac6a1b5cf52dc539d7e8.tar.gz
groff: 1.22.2 -> 1.22.3
* Updated groff-1.22.2-correct-man.local-install-path.patch * Add perl to RDEPENDS_groff since there are a few perl scripts: groff/usr/bin/roff2pdf:#! /usr/bin/env perl groff/usr/bin/afmtodit:#! /usr/bin/env perl -w groff/usr/bin/roff2dvi:#! /usr/bin/env perl groff/usr/bin/roff2text:#! /usr/bin/env perl groff/usr/bin/glilypond:#! /usr/bin/env perl groff/usr/bin/roff2ps:#! /usr/bin/env perl groff/usr/bin/gperl:#! /usr/bin/env perl groff/usr/bin/mmroff:#! /usr/bin/env perl groff/usr/bin/gpinyin:#! /usr/bin/env perl groff/usr/bin/roff2html:#! /usr/bin/env perl groff/usr/bin/grog:#! /usr/bin/env perl groff/usr/bin/gropdf:#! /usr/bin/env perl -w groff/usr/bin/pdfmom:#! /usr/bin/env perl -w groff/usr/bin/chem:#! /usr/bin/env perl groff/usr/bin/roff2x:#! /usr/bin/env perl groff/usr/bin/groffer:#! /usr/bin/env perl groff/usr/lib64/groff/gpinyin/subs.pl:#! /usr/bin/env perl groff/usr/lib64/groff/grog/subs.pl:#! /usr/bin/env perl groff/usr/lib64/groff/groffer/subs.pl:#! /usr/bin/env perl groff/usr/lib64/groff/groffer/man.pl:#! /usr/bin/env perl groff/usr/lib64/groff/groffer/main_subs.pl:#! /usr/bin/env perl * Fix the dangling /usr/bin/perl or /bin/perl for grog. (From OE-Core rev: f516c288d37e53856bce273af2cdbf24f3f5a6e1) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/groff/groff_1.22.3.bb')
-rw-r--r--meta/recipes-extended/groff/groff_1.22.3.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-extended/groff/groff_1.22.3.bb b/meta/recipes-extended/groff/groff_1.22.3.bb
new file mode 100644
index 0000000000..36b221aa1f
--- /dev/null
+++ b/meta/recipes-extended/groff/groff_1.22.3.bb
@@ -0,0 +1,67 @@
1SUMMARY = "GNU Troff software"
2DESCRIPTION = "The groff (GNU troff) software is a typesetting package which reads plain text mixed with \
3formatting commands and produces formatted output."
4SECTION = "base"
5HOMEPAGE = "http://www.gnu.org/software/groff/"
6LICENSE = "GPLv3"
7
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9
10SRC_URI = "${GNU_MIRROR}/groff/groff-${PV}.tar.gz \
11 file://groff-1.22.2-correct-man.local-install-path.patch \
12"
13
14SRC_URI[md5sum] = "cc825fa64bc7306a885f2fb2268d3ec5"
15SRC_URI[sha256sum] = "3a48a9d6c97750bfbd535feeb5be0111db6406ddb7bb79fc680809cda6d828a5"
16
17DEPENDS = "groff-native"
18DEPENDS_class-native = ""
19
20RDEPENDS_${PN} = "perl"
21
22inherit autotools texinfo
23
24EXTRA_OECONF = "--without-x"
25PARALLEL_MAKE = ""
26
27do_configure_prepend() {
28 if [ "${BUILD_SYS}" != "${HOST_SYS}" ]; then
29 sed -i \
30 -e '/^GROFFBIN=/s:=.*:=${STAGING_BINDIR_NATIVE}/groff:' \
31 -e '/^TROFFBIN=/s:=.*:=${STAGING_BINDIR_NATIVE}/troff:' \
32 -e '/^GROFF_BIN_PATH=/s:=.*:=${STAGING_BINDIR_NATIVE}:' \
33 -e '/^GROFF_BIN_DIR=/s:=.*:=${STAGING_BINDIR_NATIVE}:' \
34 ${S}/contrib/*/Makefile.sub \
35 ${S}/doc/Makefile.in \
36 ${S}/doc/Makefile.sub
37 fi
38}
39
40do_configure_append() {
41 # generate gnulib configure script
42 olddir=`pwd`
43 cd ${S}/src/libs/gnulib/
44 ACLOCAL="$ACLOCAL" autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || bbfatal "autoreconf execution failed."
45 cd ${olddir}
46}
47
48do_install_append() {
49 # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
50 # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
51 for i in afmtodit mmroff gropdf pdfmom grog; do
52 if [ -f ${D}${bindir}/$i ]; then
53 sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/$i
54 fi
55 done
56}
57
58do_install_append_class-native() {
59 create_cmdline_wrapper ${D}/${bindir}/groff \
60 -F${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/font \
61 -M${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/tmac
62}
63
64FILES_${PN} += "${libdir}/${BPN}/site-tmac \
65 ${libdir}/${BPN}/groffer/"
66
67BBCLASSEXTEND = "native"