diff options
author | Constantin Musca <constantinx.musca@intel.com> | 2013-02-19 10:11:30 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2013-02-22 06:09:21 -0800 |
commit | c07179750301f84c3ba7f55cb2603128cf2fd6dc (patch) | |
tree | 3f4f63144020f53de3cc3274cf83c531a8b2ce03 /meta/recipes-extended/groff/groff_1.22.2.bb | |
parent | e4d204412e062cfb21f0f5ac9311d5c82f556081 (diff) | |
download | poky-c07179750301f84c3ba7f55cb2603128cf2fd6dc.tar.gz |
groff: upgrade to 1.22.2
- add code for generating the gnulib configure script
- replace /usr/bin/perl with /usr/bin/env perl
(From OE-Core rev: c205124d135935855b9b479125f5bddce96a2872)
Signed-off-by: Constantin Musca <constantinx.musca@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/groff/groff_1.22.2.bb')
-rw-r--r-- | meta/recipes-extended/groff/groff_1.22.2.bb | 72 |
1 files changed, 72 insertions, 0 deletions
diff --git a/meta/recipes-extended/groff/groff_1.22.2.bb b/meta/recipes-extended/groff/groff_1.22.2.bb new file mode 100644 index 0000000000..d1361ab8e1 --- /dev/null +++ b/meta/recipes-extended/groff/groff_1.22.2.bb | |||
@@ -0,0 +1,72 @@ | |||
1 | SUMMARY = "GNU Troff software" | ||
2 | DESCRIPTION = "The groff (GNU troff) software is a typesetting package which reads plain text mixed with \ | ||
3 | formatting commands and produces formatted output." | ||
4 | SECTION = "base" | ||
5 | HOMEPAGE = "ftp://ftp.gnu.org/gnu/groff/" | ||
6 | LICENSE = "GPLv2" | ||
7 | PR = "r0" | ||
8 | |||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
10 | |||
11 | SRC_URI = "${GNU_MIRROR}/groff/groff-${PV}.tar.gz" | ||
12 | |||
13 | SRC_URI[md5sum] = "9f4cd592a5efc7e36481d8d8d8af6d16" | ||
14 | SRC_URI[sha256sum] = "380864dac4772e0c0d7b1282d25d0c5fd7f63baf45c87c4657afed22a13d2076" | ||
15 | |||
16 | DEPENDS = "groff-native" | ||
17 | DEPENDS_class-native = "" | ||
18 | |||
19 | inherit autotools | ||
20 | |||
21 | EXTRA_OECONF = "--without-x" | ||
22 | PARALLEL_MAKE = "" | ||
23 | |||
24 | do_configure_prepend() { | ||
25 | if [ "${BUILD_SYS}" != "${HOST_SYS}" ]; then | ||
26 | sed -i \ | ||
27 | -e '/^GROFFBIN=/s:=.*:=${STAGING_BINDIR_NATIVE}/groff:' \ | ||
28 | -e '/^TROFFBIN=/s:=.*:=${STAGING_BINDIR_NATIVE}/troff:' \ | ||
29 | -e '/^GROFF_BIN_PATH=/s:=.*:=${STAGING_BINDIR_NATIVE}:' \ | ||
30 | -e '/^GROFF_BIN_DIR=/s:=.*:=${STAGING_BINDIR_NATIVE}:' \ | ||
31 | ${S}/contrib/*/Makefile.sub \ | ||
32 | ${S}/doc/Makefile.in \ | ||
33 | ${S}/doc/Makefile.sub | ||
34 | fi | ||
35 | } | ||
36 | |||
37 | do_configure_append() { | ||
38 | # generate gnulib configure script | ||
39 | olddir=`pwd` | ||
40 | cd ${S}/src/libs/gnulib/ | ||
41 | ACLOCAL="$ACLOCAL" autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || bbfatal "autoreconf execution failed." | ||
42 | cd ${olddir} | ||
43 | } | ||
44 | |||
45 | do_install_append() { | ||
46 | # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location | ||
47 | # for target as /usr/bin/perl, so fix it to /usr/bin/perl. | ||
48 | for i in afmtodit mmroff gropdf pdfmom; do | ||
49 | if [ -f ${D}${bindir}/$i ]; then | ||
50 | sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/$i | ||
51 | fi | ||
52 | done | ||
53 | } | ||
54 | |||
55 | do_install_append_class-native() { | ||
56 | # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location | ||
57 | # for target as /usr/bin/perl, so fix it to /usr/bin/perl. | ||
58 | for i in afmtodit mmroff; do | ||
59 | if [ -f ${D}${bindir}/$i ]; then | ||
60 | sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/$i | ||
61 | fi | ||
62 | done | ||
63 | |||
64 | create_cmdline_wrapper ${D}/${bindir}/groff \ | ||
65 | -F${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/font \ | ||
66 | -M${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/tmac | ||
67 | } | ||
68 | |||
69 | FILES_${PN} += "${libdir}/${BPN}/site-tmac \ | ||
70 | ${libdir}/${BPN}/groffer/" | ||
71 | |||
72 | BBCLASSEXTEND = "native" | ||