diff options
author | Song.Li <Song.Li@windriver.com> | 2012-06-07 16:36:58 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-06-14 11:23:49 +0100 |
commit | 6514e193ac59f75c484066d11727d66a7466b55d (patch) | |
tree | a2d1722aa1de8924e66eec4451c10d1ba5044601 /meta/recipes-extended/groff/groff_1.20.1.bb | |
parent | 44fb9daa8182eeb71bced15c46b80676c7ca9900 (diff) | |
download | poky-6514e193ac59f75c484066d11727d66a7466b55d.tar.gz |
groff: Fix build on Fedora 17
Generally distros keep perl at /usr/bin/perl
But Fedora 17 also has /bin/perl,
this causes groff_1.20.1 build to put perl
interpreter path as /bin/perl
But we set perl location for target as /usr/bin/perl
This mismatch of perl path causes failure of rootfs image creation
like this:
| error: Failed dependencies:
| bin/perl is needed by groff-1.20.1-r1.ppc603e
(From OE-Core rev: 75824ff13f43b330b11cf9a130f061baee785e1a)
Signed-off-by: Song.Li <song.li@windriver.com>
Sync up with the do_install_append_virtclass-native chunk.
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Elizabeth Flanagan <elizabeth.flanagan@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/groff/groff_1.20.1.bb')
-rw-r--r-- | meta/recipes-extended/groff/groff_1.20.1.bb | 24 |
1 files changed, 23 insertions, 1 deletions
diff --git a/meta/recipes-extended/groff/groff_1.20.1.bb b/meta/recipes-extended/groff/groff_1.20.1.bb index 6cb72bf117..ef2254815d 100644 --- a/meta/recipes-extended/groff/groff_1.20.1.bb +++ b/meta/recipes-extended/groff/groff_1.20.1.bb | |||
@@ -4,7 +4,7 @@ formatting commands and produces formatted output." | |||
4 | SECTION = "base" | 4 | SECTION = "base" |
5 | HOMEPAGE = "ftp://ftp.gnu.org/gnu/groff/" | 5 | HOMEPAGE = "ftp://ftp.gnu.org/gnu/groff/" |
6 | LICENSE = "GPLv2" | 6 | LICENSE = "GPLv2" |
7 | PR = "r1" | 7 | PR = "r2" |
8 | 8 | ||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
10 | 10 | ||
@@ -18,6 +18,10 @@ DEPENDS_virtclass-native = "" | |||
18 | 18 | ||
19 | inherit autotools | 19 | inherit autotools |
20 | 20 | ||
21 | PERLPATH = "${bindir}/perl" | ||
22 | PERLPATH_virtclass-native = "/usr/bin/env perl" | ||
23 | PERLPATH_virtclass-nativesdk = "/usr/bin/env perl" | ||
24 | |||
21 | EXTRA_OECONF = "--without-x" | 25 | EXTRA_OECONF = "--without-x" |
22 | PARALLEL_MAKE = "" | 26 | PARALLEL_MAKE = "" |
23 | 27 | ||
@@ -34,7 +38,25 @@ do_configure_prepend() { | |||
34 | fi | 38 | fi |
35 | } | 39 | } |
36 | 40 | ||
41 | do_install_append() { | ||
42 | # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location | ||
43 | # for target as /usr/bin/perl, so fix it to /usr/bin/perl. | ||
44 | for i in afmtodit mmroff; do | ||
45 | if [ -f ${D}${bindir}/$i ]; then | ||
46 | sed -i -e '1s,#!.*perl,#! ${PERLPATH},' ${D}${bindir}/$i | ||
47 | fi | ||
48 | done | ||
49 | } | ||
50 | |||
37 | do_install_append_virtclass-native() { | 51 | do_install_append_virtclass-native() { |
52 | # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location | ||
53 | # for target as /usr/bin/perl, so fix it to /usr/bin/perl. | ||
54 | for i in afmtodit mmroff; do | ||
55 | if [ -f ${D}${bindir}/$i ]; then | ||
56 | sed -i -e '1s,#!.*perl,#! ${PERLPATH},' ${D}${bindir}/$i | ||
57 | fi | ||
58 | done | ||
59 | |||
38 | create_cmdline_wrapper ${D}/${bindir}/groff \ | 60 | create_cmdline_wrapper ${D}/${bindir}/groff \ |
39 | -F${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/font \ | 61 | -F${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/font \ |
40 | -M${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/tmac | 62 | -M${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/tmac |