summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/groff/groff_1.18.1.4.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2013-08-09 08:36:04 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-13 23:06:02 +0100
commit80f6f35cd2147af5c43990cda6a6fa5400a271bf (patch)
tree358f99cdf5383467c38e6053d7dd4acd9564014c /meta/recipes-extended/groff/groff_1.18.1.4.bb
parent7677dac20d7a7777ba9d9de74a97df642d61e5e1 (diff)
downloadpoky-80f6f35cd2147af5c43990cda6a6fa5400a271bf.tar.gz
groff: Add GPLv2 version
Apparrently a LICENSE change was missed, so we add the GPLv2 version back in (From OE-Core rev: 002818712fab5c6325b1f7205512945ea87ad76c) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/groff/groff_1.18.1.4.bb')
-rw-r--r--meta/recipes-extended/groff/groff_1.18.1.4.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-extended/groff/groff_1.18.1.4.bb b/meta/recipes-extended/groff/groff_1.18.1.4.bb
new file mode 100644
index 0000000000..9838698010
--- /dev/null
+++ b/meta/recipes-extended/groff/groff_1.18.1.4.bb
@@ -0,0 +1,45 @@
1SUMMARY = "GNU Troff software"
2DESCRIPTION = "The groff (GNU troff) software is a typesetting package which reads plain text mixed with \
3formatting commands and produces formatted output."
4SECTION = "console/utils"
5HOMEPAGE = "ftp://ftp.gnu.org/gnu/groff/"
6LICENSE = "GPLv2"
7PR = "r1"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=e43fc16fccd8519fba405f0a0ff6e8a3"
10
11SRC_URI = "${GNU_MIRROR}/groff/groff-${PV}.tar.gz \
12 file://groff-1.18.1.4-remove-mom.patch;striplevel=1 \
13 file://man-local.patch \
14 file://mdoc-local.patch"
15
16inherit autotools
17
18EXTRA_OECONF="--without-x --prefix=${D} --exec-prefix=${D} --bindir=${D}${bindir} --datadir=${D}${datadir} --mandir=${D}${datadir}/man --infodir=${D}${datadir}info --with-appresdir=${D}${datadir}"
19
20SRC_URI[md5sum] = "ceecb81533936d251ed015f40e5f7287"
21SRC_URI[sha256sum] = "ff3c7c3b6cae5e8cc5062a144de5eff0022e8e970e1774529cc2d5dde46ce50d"
22PARALLEL_MAKE = ""
23
24
25do_configure (){
26 oe_runconf
27}
28
29do_install_prepend() {
30 install -m 0755 -d ${D}
31}
32
33
34do_install_append() {
35 mkdir -p ${D}${sysconfdir}/groff
36 cp -rf ${D}${datadir}/groff/site-tmac/* ${D}${sysconfdir}/groff/
37 cp -rf ${D}${datadir}/groff/site-tmac/* ${D}${datadir}/groff/${PV}/tmac/
38}
39
40pkg_postinst_${PN}() {
41 ln -s ${bindir}/tbl ${bindir}/gtbl
42 echo "export GROFF_FONT_PATH=/usr/share/groff/${PV}/font" >> ${sysconfdir}/profile
43 echo "export GROFF_TMAC_PATH=/usr/share/groff/${PV}/tmac" >> ${sysconfdir}/profile
44}
45