summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_3.1.bb
diff options
context:
space:
mode:
authorDengke Du <dengke.du@windriver.com>2017-07-03 04:45:47 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-06 14:38:14 +0100
commitfcdb2ab8f5a6353f5407b544da3993500e020389 (patch)
treeea001a36b2c0458634e90a4095bae13234dc242c /meta/recipes-extended/grep/grep_3.1.bb
parent2d84c7a55daf3777ea31f557cf940f587ec62ab5 (diff)
downloadpoky-fcdb2ab8f5a6353f5407b544da3993500e020389.tar.gz
grep: upgrade to 3.1
(From OE-Core rev: 26289550c572ac4a7c06a21354f8dc7bcbd38114) Signed-off-by: Dengke Du <dengke.du@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/grep/grep_3.1.bb')
-rw-r--r--meta/recipes-extended/grep/grep_3.1.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-extended/grep/grep_3.1.bb b/meta/recipes-extended/grep/grep_3.1.bb
new file mode 100644
index 0000000000..05b6b93949
--- /dev/null
+++ b/meta/recipes-extended/grep/grep_3.1.bb
@@ -0,0 +1,46 @@
1SUMMARY = "GNU grep utility"
2HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
3BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
4SECTION = "console/utils"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=8006d9c814277c1bfc4ca22af94b59ee"
7
8SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz \
9 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
10 "
11
12SRC_URI[md5sum] = "feca7b3e7c7f4aab2b42ecbfc513b070"
13SRC_URI[sha256sum] = "db625c7ab3bb3ee757b3926a5cfa8d9e1c3991ad24707a83dde8a5ef2bf7a07e"
14
15inherit autotools gettext texinfo pkgconfig
16
17EXTRA_OECONF = "--disable-perl-regexp"
18
19# Fix "Argument list too long" error when len(TMPDIR) = 410
20acpaths = "-I ./m4"
21
22do_configure_prepend () {
23 rm -f ${S}/m4/init.m4
24}
25
26do_install () {
27 autotools_do_install
28 if [ "${base_bindir}" != "${bindir}" ]; then
29 install -d ${D}${base_bindir}
30 mv ${D}${bindir}/grep ${D}${base_bindir}/grep
31 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
32 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
33 rmdir ${D}${bindir}/
34 fi
35}
36
37inherit update-alternatives
38
39ALTERNATIVE_PRIORITY = "100"
40
41ALTERNATIVE_${PN} = "grep egrep fgrep"
42ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
43ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
44ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
45
46export CONFIG_SHELL="/bin/sh"