summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_3.0.bb
diff options
context:
space:
mode:
authorFan Xin <fan.xin@jp.fujitsu.com>2017-03-10 19:11:59 +0900
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-11 16:09:14 +0000
commitb89d6500ff0059f22c640a46beff91c6f372033d (patch)
tree7e05e7502f2de979452c2096e1a212738ffc6681 /meta/recipes-extended/grep/grep_3.0.bb
parentf3c73f3d2aee33a6ea2c853c9450fee7257a9fd9 (diff)
downloadpoky-b89d6500ff0059f22c640a46beff91c6f372033d.tar.gz
grep: upgrade to 3.0
(From OE-Core rev: e5bf7d28dc72db652c6cfdaacba858bdc6c42e5e) Signed-off-by: Fan Xin <fan.xin@jp.fujitsu.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/grep/grep_3.0.bb')
-rw-r--r--meta/recipes-extended/grep/grep_3.0.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-extended/grep/grep_3.0.bb b/meta/recipes-extended/grep/grep_3.0.bb
new file mode 100644
index 0000000000..6146ef00f3
--- /dev/null
+++ b/meta/recipes-extended/grep/grep_3.0.bb
@@ -0,0 +1,43 @@
1SUMMARY = "GNU grep utility"
2HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
3BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
4SECTION = "console/utils"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=8006d9c814277c1bfc4ca22af94b59ee"
7
8SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz \
9 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
10 "
11
12SRC_URI[md5sum] = "fa07c1616adeb9c3262be5177d10ad4a"
13SRC_URI[sha256sum] = "e2c81db5056e3e8c5995f0bb5d0d0e1cad1f6f45c3b2fc77b6e81435aed48ab5"
14
15inherit autotools gettext texinfo pkgconfig
16
17EXTRA_OECONF = "--disable-perl-regexp"
18
19do_configure_prepend () {
20 rm -f ${S}/m4/init.m4
21}
22
23do_install () {
24 autotools_do_install
25 if [ "${base_bindir}" != "${bindir}" ]; then
26 install -d ${D}${base_bindir}
27 mv ${D}${bindir}/grep ${D}${base_bindir}/grep
28 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
29 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
30 rmdir ${D}${bindir}/
31 fi
32}
33
34inherit update-alternatives
35
36ALTERNATIVE_PRIORITY = "100"
37
38ALTERNATIVE_${PN} = "grep egrep fgrep"
39ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
40ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
41ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
42
43export CONFIG_SHELL="/bin/sh"