summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_2.7.bb
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2011-06-05 17:02:39 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-07 21:38:35 +0100
commit757db8a21b9b1a20fd9f8af8161d4b9fd7022c4f (patch)
tree0323a9d7e543da57ef1487605ed2fd18baad9e30 /meta/recipes-extended/grep/grep_2.7.bb
parent4555c2bd7bcb721b7bba9e2f752896f54bf9a7f3 (diff)
downloadpoky-757db8a21b9b1a20fd9f8af8161d4b9fd7022c4f.tar.gz
grep: upgrade to v2.8
(From OE-Core rev: 40030433662c8a43c89e20099330aa5172ac0c27) Signed-off-by: Scott Garman <scott.a.garman@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/grep/grep_2.7.bb')
-rw-r--r--meta/recipes-extended/grep/grep_2.7.bb41
1 files changed, 0 insertions, 41 deletions
diff --git a/meta/recipes-extended/grep/grep_2.7.bb b/meta/recipes-extended/grep/grep_2.7.bb
deleted file mode 100644
index c3e098688e..0000000000
--- a/meta/recipes-extended/grep/grep_2.7.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1DESCRIPTION = "grep GNU utility"
2HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
3BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
4SECTION = "console/utils"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=8006d9c814277c1bfc4ca22af94b59ee"
7
8PR = "r0"
9
10SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "e848f07e3e79aa7899345d17c7e4115e"
13SRC_URI[sha256sum] = "ad14831015a79cea36785aa47415f6c0653a6ac4eaf9c15456f0d9d09c9e1bad"
14
15inherit autotools gettext
16
17EXTRA_OECONF = "--disable-perl-regexp"
18
19do_configure_prepend () {
20 rm -f ${S}/m4/init.m4
21}
22
23do_install () {
24 autotools_do_install
25 install -d ${D}${base_bindir}
26 mv ${D}${bindir}/grep ${D}${base_bindir}/grep.${PN}
27 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep.${PN}
28 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep.${PN}
29}
30
31pkg_postinst_${PN} () {
32 update-alternatives --install ${base_bindir}/grep grep grep.${PN} 100
33 update-alternatives --install ${base_bindir}/egrep egrep egrep.${PN} 100
34 update-alternatives --install ${base_bindir}/fgrep fgrep fgrep.${PN} 100
35}
36
37pkg_prerm_${PN} () {
38 update-alternatives --remove grep grep.${PN}
39 update-alternatives --remove egrep egrep.${PN}
40 update-alternatives --remove fgrep fgrep.${PN}
41}