summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_2.22.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2016-02-18 13:29:00 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-19 01:01:24 +0000
commit247f3b4484cec2ed88010b8109798ce086fed1fe (patch)
treefbea9d6977cff01ec4c132554660635b982a91ce /meta/recipes-extended/grep/grep_2.22.bb
parent4e5e501155a21fe64a470c626b3afe6d9748308e (diff)
downloadpoky-247f3b4484cec2ed88010b8109798ce086fed1fe.tar.gz
grep: upgrade to 2.23
(From OE-Core rev: ee3db91738e2d98b18a6426944fd70946e002a94) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/grep/grep_2.22.bb')
-rw-r--r--meta/recipes-extended/grep/grep_2.22.bb43
1 files changed, 0 insertions, 43 deletions
diff --git a/meta/recipes-extended/grep/grep_2.22.bb b/meta/recipes-extended/grep/grep_2.22.bb
deleted file mode 100644
index 8092a0f057..0000000000
--- a/meta/recipes-extended/grep/grep_2.22.bb
+++ /dev/null
@@ -1,43 +0,0 @@
1SUMMARY = "GNU grep utility"
2HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
3BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
4SECTION = "console/utils"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=8006d9c814277c1bfc4ca22af94b59ee"
7
8SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz \
9 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
10 "
11
12SRC_URI[md5sum] = "e1015e951a49a82b02e38891026ef5df"
13SRC_URI[sha256sum] = "ca91d22f017bfcb503d4bc3b44295491c89a33a3df0c3d8b8614f2d3831836eb"
14
15inherit autotools gettext texinfo
16
17EXTRA_OECONF = "--disable-perl-regexp"
18
19do_configure_prepend () {
20 rm -f ${S}/m4/init.m4
21}
22
23do_install () {
24 autotools_do_install
25 if [ "${base_bindir}" != "${bindir}" ]; then
26 install -d ${D}${base_bindir}
27 mv ${D}${bindir}/grep ${D}${base_bindir}/grep
28 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
29 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
30 rmdir ${D}${bindir}/
31 fi
32}
33
34inherit update-alternatives
35
36ALTERNATIVE_PRIORITY = "100"
37
38ALTERNATIVE_${PN} = "grep egrep fgrep"
39ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
40ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
41ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
42
43export CONFIG_SHELL="/bin/sh"