summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_2.14.bb
diff options
context:
space:
mode:
authorMarko Lindqvist <cazfi74@gmail.com>2012-11-30 18:06:55 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-03 14:32:48 +0000
commitd55945c469a985e3054eaed5af1659e2cff0cc02 (patch)
treee21c6204f9717ebfec52fa7bf481588871df9bc2 /meta/recipes-extended/grep/grep_2.14.bb
parent85fb3c4bce6df15b6914cbc5f88de759d9fb62f7 (diff)
downloadpoky-d55945c469a985e3054eaed5af1659e2cff0cc02.tar.gz
grep: update to upstream version 2.14
(From OE-Core rev: 53294e7c6e4fabc36f0a6a303bfd0e72808e4b41) Signed-off-by: Marko Lindqvist <cazfi74@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/grep/grep_2.14.bb')
-rw-r--r--meta/recipes-extended/grep/grep_2.14.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-extended/grep/grep_2.14.bb b/meta/recipes-extended/grep/grep_2.14.bb
new file mode 100644
index 0000000000..386bbd4437
--- /dev/null
+++ b/meta/recipes-extended/grep/grep_2.14.bb
@@ -0,0 +1,41 @@
1SUMMARY = "GNU grep utility"
2DESCRIPTION = "GNU grep utility"
3HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
4BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
5SECTION = "console/utils"
6LICENSE = "GPLv3"
7LIC_FILES_CHKSUM = "file://COPYING;md5=8006d9c814277c1bfc4ca22af94b59ee"
8
9PR = "r0"
10
11SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz"
12
13SRC_URI[md5sum] = "d4a3f03849d1e17ce56ab76aa5a24cab"
14SRC_URI[sha256sum] = "e70e801d4fbb16e761654a58ae48bf5020621c95c8e35bd864742577685872e1"
15
16inherit autotools gettext
17
18EXTRA_OECONF = "--disable-perl-regexp"
19
20do_configure_prepend () {
21 rm -f ${S}/m4/init.m4
22}
23
24do_install () {
25 autotools_do_install
26 install -d ${D}${base_bindir}
27 mv ${D}${bindir}/grep ${D}${base_bindir}/grep
28 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
29 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
30 rmdir ${D}${bindir}/
31}
32
33inherit update-alternatives
34
35ALTERNATIVE_PRIORITY = "100"
36
37ALTERNATIVE_${PN} = "grep egrep fgrep"
38ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
39ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
40ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
41