summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ghostscript/ghostscript_9.20.bb
diff options
context:
space:
mode:
authorHuang Qiyu <huangqy.fnst@cn.fujitsu.com>2016-12-13 15:05:39 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-12-17 09:57:03 +0000
commitbd06c3641a0c5c30302d421cf27de22effed93da (patch)
tree111a10859d1fa72a2f748183f2ac92a098ba24df /meta/recipes-extended/ghostscript/ghostscript_9.20.bb
parent4ab468b0ab3e7fca277801329b5100e3215a9598 (diff)
downloadpoky-bd06c3641a0c5c30302d421cf27de22effed93da.tar.gz
ghostscript 9.19 -> 9.20
1)Upgrade ghostscript from 9.19 to 9.20. 2)Modify ghostscript-9.15-parallel-make.patch, since the data has been changed. (From OE-Core rev: 4f3483c3a0ba22f46d768d78d6f56880e8ac5608) (From OE-Core rev: 9133ba6b8138951f3ef798f0a1cc6f694fe71868) Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ghostscript/ghostscript_9.20.bb')
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript_9.20.bb105
1 files changed, 105 insertions, 0 deletions
diff --git a/meta/recipes-extended/ghostscript/ghostscript_9.20.bb b/meta/recipes-extended/ghostscript/ghostscript_9.20.bb
new file mode 100644
index 0000000000..0800b4ed48
--- /dev/null
+++ b/meta/recipes-extended/ghostscript/ghostscript_9.20.bb
@@ -0,0 +1,105 @@
1SUMMARY = "The GPL Ghostscript PostScript/PDF interpreter"
2DESCRIPTION = "Ghostscript is used for PostScript/PDF preview and printing. Usually as \
3a back-end to a program such as ghostview, it can display PostScript and PDF \
4documents in an X11 environment. \
5\
6Furthermore, it can render PostScript and PDF files as graphics to be printed \
7on non-PostScript printers. Supported printers include common \
8dot-matrix, inkjet and laser models. \
9"
10HOMEPAGE = "http://www.ghostscript.com"
11SECTION = "console/utils"
12
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=70dc2bac4d0ce4448da873cd86b123fc"
15
16DEPENDS = "ghostscript-native tiff jpeg fontconfig cups libpng"
17DEPENDS_class-native = "libpng-native"
18
19UPSTREAM_CHECK_URI = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases"
20
21SRC_URI_BASE = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs920/${BPN}-${PV}.tar.gz \
22 file://ghostscript-9.15-parallel-make.patch \
23 file://ghostscript-9.16-Werror-return-type.patch \
24 file://png_mak.patch \
25 file://do-not-check-local-libpng-source.patch \
26"
27
28SRC_URI = "${SRC_URI_BASE} \
29 file://ghostscript-9.02-prevent_recompiling.patch \
30 file://ghostscript-9.02-genarch.patch \
31 file://objarch.h \
32 file://cups-no-gcrypt.patch \
33 "
34
35SRC_URI_class-native = "${SRC_URI_BASE} \
36 file://ghostscript-native-fix-disable-system-libtiff.patch \
37 file://base-genht.c-add-a-preprocessor-define-to-allow-fope.patch \
38 "
39
40SRC_URI[md5sum] = "93c5987cd3ab341108be1ebbaadc24fe"
41SRC_URI[sha256sum] = "949b64b46ecf8906db54a94ecf83ab97534ebf946f770d3c3f283cb469cb6e14"
42
43EXTRA_OECONF = "--without-x --with-system-libtiff --without-jbig2dec \
44 --with-fontpath=${datadir}/fonts \
45 --without-libidn --with-cups-serverbin=${exec_prefix}/lib/cups \
46 --with-cups-datadir=${datadir}/cups \
47 "
48
49EXTRA_OECONF_append_mipsarcho32 = " --with-large_color_index=0"
50
51# Explicity disable libtiff, fontconfig,
52# freetype, cups for ghostscript-native
53EXTRA_OECONF_class-native = "--without-x --with-system-libtiff=no \
54 --without-jbig2dec \
55 --with-fontpath=${datadir}/fonts \
56 --without-libidn --disable-fontconfig \
57 --disable-freetype --disable-cups"
58
59# This has been fixed upstream but for now we need to subvert the check for time.h
60# http://bugs.ghostscript.com/show_bug.cgi?id=692443
61# http://bugs.ghostscript.com/show_bug.cgi?id=692426
62CFLAGS += "-DHAVE_SYS_TIME_H=1"
63BUILD_CFLAGS += "-DHAVE_SYS_TIME_H=1"
64
65inherit autotools
66
67do_configure_prepend () {
68 mkdir -p obj
69 mkdir -p soobj
70 if [ -e ${WORKDIR}/objarch.h ]; then
71 cp ${WORKDIR}/objarch.h obj/arch.h
72 fi
73}
74
75do_configure_append () {
76 # copy tools from the native ghostscript build
77 if [ "${PN}" != "ghostscript-native" ]; then
78 mkdir -p obj/aux soobj
79 for i in genarch genconf mkromfs echogs gendev genht; do
80 cp ${STAGING_BINDIR_NATIVE}/ghostscript-${PV}/$i obj/aux/$i
81 done
82 fi
83}
84
85do_install_append () {
86 mkdir -p ${D}${datadir}/ghostscript/${PV}/
87 cp -r ${S}/Resource ${D}${datadir}/ghostscript/${PV}/
88 cp -r ${S}/iccprofiles ${D}${datadir}/ghostscript/${PV}/
89}
90
91do_compile_class-native () {
92 mkdir -p obj
93 for i in genarch genconf mkromfs echogs gendev genht; do
94 oe_runmake obj/aux/$i
95 done
96}
97
98do_install_class-native () {
99 install -d ${D}${bindir}/ghostscript-${PV}
100 for i in genarch genconf mkromfs echogs gendev genht; do
101 install -m 755 obj/aux/$i ${D}${bindir}/ghostscript-${PV}/$i
102 done
103}
104
105BBCLASSEXTEND = "native"