summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ghostscript/ghostscript_9.05.bb
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2012-03-14 17:03:42 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-14 13:17:43 +0000
commitae2c5f24771b333f3419aeacae4d2e16daf7badd (patch)
tree03f5e5d85ae6c4ca2034c5581f5bf075d52569a2 /meta/recipes-extended/ghostscript/ghostscript_9.05.bb
parente42e6959516e7b10afcb4aad9eb8b944016420ef (diff)
downloadpoky-ae2c5f24771b333f3419aeacae4d2e16daf7badd.tar.gz
ghostscript: update to 9.05
Update ghostscript to 9.05, and update ghostscript-9.02-genarch.patch at same time because it can't be applied. Add patch ghostscript/ghostscript-9.05-NOT-check-endian.patch to forbid checking endianese. (From OE-Core rev: 7e7bdb9dc4ca61f8427f07f2ff220767385085c5) Signed-off-by: Kang Kai <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ghostscript/ghostscript_9.05.bb')
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript_9.05.bb117
1 files changed, 117 insertions, 0 deletions
diff --git a/meta/recipes-extended/ghostscript/ghostscript_9.05.bb b/meta/recipes-extended/ghostscript/ghostscript_9.05.bb
new file mode 100644
index 0000000000..6c1d1a927e
--- /dev/null
+++ b/meta/recipes-extended/ghostscript/ghostscript_9.05.bb
@@ -0,0 +1,117 @@
1SUMMARY = "The GPL Ghostscript PostScript/PDF interpreter"
2DESCRIPTION = "Ghostscript is used for PostScript/PDF preview and printing. Usually as \
3a back-end to a program such as ghostview, it can display PostScript and PDF \
4documents in an X11 environment. \
5\
6Furthermore, it can render PostScript and PDF files as graphics to be printed \
7on non-PostScript printers. Supported printers include common \
8dot-matrix, inkjet and laser models. \
9\
10Package gsfonts contains a set of standard fonts for Ghostscript. \
11"
12HOMEPAGE = "http://www.ghostscript.com"
13SECTION = "console/utils"
14
15LICENSE = "GPLv3"
16LIC_FILES_CHKSUM = "file://LICENSE;md5=c5326026692dbed183f0558f926580f8"
17
18PR = "r0"
19
20DEPENDS = "ghostscript-native tiff jpeg fontconfig cups"
21DEPENDS_virtclass-native = ""
22
23SRC_URI_BASE = "http://downloads.ghostscript.com/public/ghostscript-${PV}.tar.gz"
24
25SRC_URI = "${SRC_URI_BASE} \
26 file://ghostscript-9.02-prevent_recompiling.patch \
27 file://ghostscript-9.02-genarch.patch \
28 file://objarch.h \
29 file://ghostscript-9.02-parallel-make.patch \
30 file://ghostscript-9.05-NOT-check-endian.patch \
31 "
32
33SRC_URI_virtclass-native = "${SRC_URI_BASE}"
34
35SRC_URI[md5sum] = "f7c6f0431ca8d44ee132a55d583212c1"
36SRC_URI[sha256sum] = "593f77f7584704bdf9de41598a084a4208c3ad3b940a1de1faaf8f59a15cc207"
37
38EXTRA_OECONF = "--without-x --with-system-libtiff --without-jbig2dec --without-jasper \
39 --with-fontpath=${datadir}/fonts --with-install-cups"
40
41# This has been fixed upstream but for now we need to subvert the check for time.h
42# http://bugs.ghostscript.com/show_bug.cgi?id=692443
43# http://bugs.ghostscript.com/show_bug.cgi?id=692426
44CFLAGS += "-DHAVE_SYS_TIME_H=1"
45BUILD_CFLAGS += "-DHAVE_SYS_TIME_H=1"
46
47inherit autotools
48
49do_configure_prepend () {
50 mkdir -p obj
51 mkdir -p soobj
52 if [ -e ${WORKDIR}/objarch.h ]; then
53 cp ${WORKDIR}/objarch.h obj/arch.h
54 fi
55}
56
57do_configure_append () {
58 # copy tools from the native ghostscript build
59 if [ "${PN}" != "ghostscript-native" ]; then
60 mkdir -p obj/aux soobj
61 for i in genarch genconf mkromfs echogs gendev genht; do
62 cp ${STAGING_BINDIR_NATIVE}/ghostscript-${PV}/$i obj/aux/$i
63 done
64 fi
65
66 # replace cups paths from sysroots/.../usr/bin/crossscripts/cups-config with target paths
67 # CUPSDATA is compiled into a utility, and CUPSSERVERBIN is used as an install path
68 CUPSSERVERBIN=${exec_prefix}/lib/cups # /usr/lib NOT libdir
69 CUPSDATA=${datadir}/cups
70
71 sed -e "s#^CUPSSERVERBIN=.*#CUPSSERVERBIN=${CUPSSERVERBIN}#" -i Makefile
72 sed -e "s#^CUPSDATA=.*#CUPSDATA=${CUPSDATA}#" -i Makefile
73}
74
75do_install_append () {
76 mkdir -p ${D}${datadir}/ghostscript/${PV}/
77 cp -r Resource ${D}${datadir}/ghostscript/${PV}/
78 cp -r iccprofiles ${D}${datadir}/ghostscript/${PV}/
79
80 chown -R root:lp ${D}${sysconfdir}/cups
81}
82
83python do_patch_virtclass-native () {
84 pass
85}
86
87do_compile_virtclass-native () {
88 mkdir -p obj
89 for i in genarch genconf mkromfs echogs gendev genht; do
90 oe_runmake obj/aux/$i
91 done
92}
93
94do_install_virtclass-native () {
95 install -d ${D}${bindir}/ghostscript-${PV}
96 for i in genarch genconf mkromfs echogs gendev genht; do
97 install -m 755 obj/aux/$i ${D}${bindir}/ghostscript-${PV}/$i
98 done
99}
100
101BBCLASSEXTEND = "native"
102
103# Ghostscript install tool 'instcopy' tries to remove already created
104# directories during install and parallel make causes problems.
105PARALLEL_MAKEINST=""
106
107PACKAGES =+ "${PN}-cups"
108
109FILES_${PN}-dbg += "${exec_prefix}/lib/cups/filter/.debug"
110
111FILES_${PN}-cups += "${exec_prefix}/lib/cups/filter/gstoraster \
112 ${exec_prefix}/lib/cups/filter/pstopxl \
113 ${datadir}/cups \
114 ${sysconfdir}/cups \
115 "
116
117RDEPENDS_${PN}-cups = "${PN}"