diff options
author | Kang Kai <kai.kang@windriver.com> | 2011-10-18 16:04:24 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-10-20 17:13:39 +0100 |
commit | 8f024357960cfefd9861960f2091abcebd27a5d8 (patch) | |
tree | ae31b6d96bc55e9b72bf91100d2fee43a7db6ab0 /meta/recipes-extended/ghostscript/ghostscript_9.04.bb | |
parent | 2f21384d09bb9b3fe96b7a410e1ae35d8e34f7c1 (diff) | |
download | poky-8f024357960cfefd9861960f2091abcebd27a5d8.tar.gz |
ghostscript: update to 9.04
Remove the old version and update ghostscript to 9.04.
* update ghostscript-9.02-prevent_recompiling.patch
* because soobj is not used any more, remove soobj related work
* gs provides a configure option --with-install-cups to install cups related
files but disabled by default, so need update post install scripts
(From OE-Core rev: a1728fef998d43dc952e42d4c787304086578608)
Signed-off-by: Kang Kai <kai.kang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ghostscript/ghostscript_9.04.bb')
-rw-r--r-- | meta/recipes-extended/ghostscript/ghostscript_9.04.bb | 96 |
1 files changed, 96 insertions, 0 deletions
diff --git a/meta/recipes-extended/ghostscript/ghostscript_9.04.bb b/meta/recipes-extended/ghostscript/ghostscript_9.04.bb new file mode 100644 index 0000000000..dba92e9aba --- /dev/null +++ b/meta/recipes-extended/ghostscript/ghostscript_9.04.bb | |||
@@ -0,0 +1,96 @@ | |||
1 | SUMMARY = "The GPL Ghostscript PostScript/PDF interpreter" | ||
2 | DESCRIPTION = "Ghostscript is used for PostScript/PDF preview and printing. Usually as \ | ||
3 | a back-end to a program such as ghostview, it can display PostScript and PDF \ | ||
4 | documents in an X11 environment. \ | ||
5 | \ | ||
6 | Furthermore, it can render PostScript and PDF files as graphics to be printed \ | ||
7 | on non-PostScript printers. Supported printers include common \ | ||
8 | dot-matrix, inkjet and laser models. \ | ||
9 | \ | ||
10 | Package gsfonts contains a set of standard fonts for Ghostscript. \ | ||
11 | " | ||
12 | HOMEPAGE = "http://www.ghostscript.com" | ||
13 | SECTION = "console/utils" | ||
14 | |||
15 | LICENSE = "GPLv3" | ||
16 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d151214b3131251dfc9d858593acbd24" | ||
17 | |||
18 | PR = "r0" | ||
19 | |||
20 | DEPENDS = "ghostscript-native tiff jpeg fontconfig cups" | ||
21 | DEPENDS_virtclass-native = "" | ||
22 | |||
23 | SRC_URI_BASE = "http://downloads.ghostscript.com/public/ghostscript-${PV}.tar.gz" | ||
24 | |||
25 | SRC_URI = "${SRC_URI_BASE} \ | ||
26 | file://ghostscript-9.02-prevent_recompiling.patch \ | ||
27 | file://ghostscript-9.02-genarch.patch \ | ||
28 | file://objarch.h \ | ||
29 | file://ghostscript-9.02-parallel-make.patch \ | ||
30 | " | ||
31 | |||
32 | SRC_URI_virtclass-native = "${SRC_URI_BASE}" | ||
33 | |||
34 | SRC_URI[md5sum] = "9c2fb4af1eb609d09dba5bb0fa76173a" | ||
35 | SRC_URI[sha256sum] = "f1e333738c41c3bf2b47ceb9806abb8045bcdc7353002c32736150425a7c1ef4" | ||
36 | |||
37 | EXTRA_OECONF = "--without-x --with-system-libtiff --without-jbig2dec --without-jasper --with-fontpath=${datadir}/fonts" | ||
38 | |||
39 | # This has been fixed upstream but for now we need to subvert the check for time.h | ||
40 | # http://bugs.ghostscript.com/show_bug.cgi?id=692443 | ||
41 | # http://bugs.ghostscript.com/show_bug.cgi?id=692426 | ||
42 | CFLAGS += "-DHAVE_SYS_TIME_H=1" | ||
43 | |||
44 | inherit autotools | ||
45 | |||
46 | do_configure () { | ||
47 | mkdir -p obj | ||
48 | mkdir -p soobj | ||
49 | cp ${WORKDIR}/objarch.h obj/arch.h | ||
50 | |||
51 | oe_runconf | ||
52 | |||
53 | # copy tools from the native ghostscript build | ||
54 | mkdir -p obj/aux soobj | ||
55 | for i in genarch genconf mkromfs echogs gendev genht; do | ||
56 | cp ${STAGING_BINDIR_NATIVE}/ghostscript-${PV}/$i obj/aux/$i | ||
57 | done | ||
58 | } | ||
59 | |||
60 | do_install_append () { | ||
61 | mkdir -p ${D}${datadir}/ghostscript/${PV}/ | ||
62 | cp -r Resource ${D}${datadir}/ghostscript/${PV}/ | ||
63 | cp -r iccprofiles ${D}${datadir}/ghostscript/${PV}/ | ||
64 | |||
65 | if [ -f ${D}${sysconfdir}/cups ]; then | ||
66 | chown -R root:lp ${D}${sysconfdir}/cups | ||
67 | fi | ||
68 | } | ||
69 | |||
70 | python do_patch_virtclass-native () { | ||
71 | pass | ||
72 | } | ||
73 | |||
74 | do_configure_virtclass-native () { | ||
75 | oe_runconf | ||
76 | } | ||
77 | |||
78 | do_compile_virtclass-native () { | ||
79 | mkdir -p obj | ||
80 | for i in genarch genconf mkromfs echogs gendev genht; do | ||
81 | oe_runmake obj/aux/$i | ||
82 | done | ||
83 | } | ||
84 | |||
85 | do_install_virtclass-native () { | ||
86 | install -d ${D}${bindir}/ghostscript-${PV} | ||
87 | for i in genarch genconf mkromfs echogs gendev genht; do | ||
88 | install -m 755 obj/aux/$i ${D}${bindir}/ghostscript-${PV}/$i | ||
89 | done | ||
90 | } | ||
91 | |||
92 | BBCLASSEXTEND = "native" | ||
93 | |||
94 | # Ghostscript install tool 'instcopy' tries to remove already created | ||
95 | # directories during install and parallel make causes problems. | ||
96 | PARALLEL_MAKEINST="" | ||