summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ghostscript/ghostscript_9.02.bb
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2011-10-18 16:04:24 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-20 17:13:39 +0100
commit8f024357960cfefd9861960f2091abcebd27a5d8 (patch)
treeae31b6d96bc55e9b72bf91100d2fee43a7db6ab0 /meta/recipes-extended/ghostscript/ghostscript_9.02.bb
parent2f21384d09bb9b3fe96b7a410e1ae35d8e34f7c1 (diff)
downloadpoky-8f024357960cfefd9861960f2091abcebd27a5d8.tar.gz
ghostscript: update to 9.04
Remove the old version and update ghostscript to 9.04. * update ghostscript-9.02-prevent_recompiling.patch * because soobj is not used any more, remove soobj related work * gs provides a configure option --with-install-cups to install cups related files but disabled by default, so need update post install scripts (From OE-Core rev: a1728fef998d43dc952e42d4c787304086578608) Signed-off-by: Kang Kai <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ghostscript/ghostscript_9.02.bb')
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript_9.02.bb96
1 files changed, 0 insertions, 96 deletions
diff --git a/meta/recipes-extended/ghostscript/ghostscript_9.02.bb b/meta/recipes-extended/ghostscript/ghostscript_9.02.bb
deleted file mode 100644
index 1d48cce2b8..0000000000
--- a/meta/recipes-extended/ghostscript/ghostscript_9.02.bb
+++ /dev/null
@@ -1,96 +0,0 @@
1SUMMARY = "The GPL Ghostscript PostScript/PDF interpreter"
2DESCRIPTION = "Ghostscript is used for PostScript/PDF preview and printing. Usually as \
3a back-end to a program such as ghostview, it can display PostScript and PDF \
4documents in an X11 environment. \
5\
6Furthermore, it can render PostScript and PDF files as graphics to be printed \
7on non-PostScript printers. Supported printers include common \
8dot-matrix, inkjet and laser models. \
9\
10Package gsfonts contains a set of standard fonts for Ghostscript. \
11"
12HOMEPAGE = "http://www.ghostscript.com"
13SECTION = "console/utils"
14
15LICENSE = "GPLv3"
16LIC_FILES_CHKSUM = "file://LICENSE;md5=d151214b3131251dfc9d858593acbd24"
17
18PR = "r4"
19
20DEPENDS = "ghostscript-native tiff jpeg fontconfig cups"
21DEPENDS_virtclass-native = ""
22
23SRC_URI_BASE = "http://downloads.ghostscript.com/public/ghostscript-${PV}.tar.bz2"
24
25SRC_URI = "${SRC_URI_BASE} \
26 file://ghostscript-9.02-prevent_recompiling.patch \
27 file://ghostscript-9.02-genarch.patch \
28 file://objarch.h \
29 file://soobjarch.h \
30 file://ghostscript-9.02-parallel-make.patch \
31 "
32SRC_URI_virtclass-native = "${SRC_URI_BASE}"
33
34SRC_URI[md5sum] = "f67151444bd56a7904579fc75a083dd6"
35SRC_URI[sha256sum] = "03ea2cad13a36f8f9160912012b79619a826e7148fada6d3531feb25409ee05a"
36
37EXTRA_OECONF = "--without-x --with-system-libtiff --without-jbig2dec --without-jasper --with-fontpath=${datadir}/fonts"
38
39# This has been fixed upstream but for now we need to subvert the check for time.h
40# http://bugs.ghostscript.com/show_bug.cgi?id=692443
41# http://bugs.ghostscript.com/show_bug.cgi?id=692426
42CFLAGS += "-DHAVE_SYS_TIME_H=1"
43
44inherit autotools
45
46do_configure () {
47 mkdir -p obj
48 mkdir -p soobj
49 cp ${WORKDIR}/objarch.h obj/arch.h
50 cp ${WORKDIR}/soobjarch.h soobj/arch.h
51
52 oe_runconf
53
54 # copy tools from the native ghostscript build
55 mkdir -p obj soobj
56 for i in genarch genconf mkromfs echogs gendev genht; do
57 cp ${STAGING_BINDIR_NATIVE}/ghostscript-${PV}/$i obj/$i
58 cp ${STAGING_BINDIR_NATIVE}/ghostscript-${PV}/$i soobj/$i
59 done
60}
61
62do_install_append () {
63 mkdir -p ${D}${datadir}/ghostscript/${PV}/
64 cp -r Resource ${D}${datadir}/ghostscript/${PV}/
65 cp -r iccprofiles ${D}${datadir}/ghostscript/${PV}/
66
67 chown -R root:lp ${D}${sysconfdir}/cups
68}
69
70python do_patch_virtclass-native () {
71 pass
72}
73
74do_configure_virtclass-native () {
75 oe_runconf
76}
77
78do_compile_virtclass-native () {
79 mkdir -p obj
80 for i in genarch genconf mkromfs echogs gendev genht; do
81 oe_runmake obj/$i
82 done
83}
84
85do_install_virtclass-native () {
86 install -d ${D}${bindir}/ghostscript-${PV}
87 for i in genarch genconf mkromfs echogs gendev genht; do
88 install -m 755 obj/$i ${D}${bindir}/ghostscript-${PV}/$i
89 done
90}
91
92BBCLASSEXTEND = "native"
93
94# Ghostscript install tool 'instcopy' tries to remove already created
95# directories during install and parallel make causes problems.
96PARALLEL_MAKEINST=""