summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/gawk/gawk_5.0.0.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-07 18:06:23 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-08 16:01:41 +0100
commit8dc2f09ea5dd816cf0d406e346e420bbb1cffe2e (patch)
tree6b72ac06bf27cec4e1cd09ad47be4c9b9575e51f /meta/recipes-extended/gawk/gawk_5.0.0.bb
parent946a8802be344ac7ef409ac687fc383c2a6a8684 (diff)
downloadpoky-8dc2f09ea5dd816cf0d406e346e420bbb1cffe2e.tar.gz
gawk: ptest fixes
In minimal images all tests pass due to a missing dependency on make. Add the missing dependecy. The test list created by the run-ptest script is incorrect as it includes entries like "fi". Simplify it and correct it. Some tests are skipped due to mpfr not being enabled. Correctly mark these as SKIP. Some tests need the "../gawk" script, create a link to it so the tests work correctly. Also print more information in the failed test cases. (From OE-Core rev: 8392d60e05c4eed0b08273c1a934eeea54215079) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/gawk/gawk_5.0.0.bb')
-rw-r--r--meta/recipes-extended/gawk/gawk_5.0.0.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-extended/gawk/gawk_5.0.0.bb b/meta/recipes-extended/gawk/gawk_5.0.0.bb
index b1e1b212a3..578901355c 100644
--- a/meta/recipes-extended/gawk/gawk_5.0.0.bb
+++ b/meta/recipes-extended/gawk/gawk_5.0.0.bb
@@ -40,6 +40,7 @@ inherit ptest
40 40
41do_install_ptest() { 41do_install_ptest() {
42 mkdir ${D}${PTEST_PATH}/test 42 mkdir ${D}${PTEST_PATH}/test
43 ln -s ${bindir}/gawk ${D}${PTEST_PATH}/gawk
43 for i in `grep -vE "@|^$|#|Gt-dummy" ${S}/test/Maketests |awk -F: '{print $1}'` Maketests inclib.awk; \ 44 for i in `grep -vE "@|^$|#|Gt-dummy" ${S}/test/Maketests |awk -F: '{print $1}'` Maketests inclib.awk; \
44 do cp ${S}/test/$i* ${D}${PTEST_PATH}/test; \ 45 do cp ${S}/test/$i* ${D}${PTEST_PATH}/test; \
45 done 46 done
@@ -47,4 +48,6 @@ do_install_ptest() {
47 -e 's|#!${base_bindir}/awk|#!${bindir}/awk|g' ${D}${PTEST_PATH}/test/*.awk 48 -e 's|#!${base_bindir}/awk|#!${bindir}/awk|g' ${D}${PTEST_PATH}/test/*.awk
48} 49}
49 50
51RDEPENDS_${PN}-ptest += "make"
52
50BBCLASSEXTEND = "native nativesdk" 53BBCLASSEXTEND = "native nativesdk"